Official LineageOS 19 for Fairphone 3/3+

I tried flashing from twrp, but i only tried opengapps I’m experienced with and mindthegapps, recommended by the los team. So, guess I’ll wait for next week and in case I’ll try different gapps packages also.

Ooooh… I started answer this thread because I was quoted and did not notice… it was about fp3/3+… I’m a FP4 user so there are chances I’m totally irrelevant here. Sorry

Well, gapps are os specific, not model specific, so your input is valuable.
If you have positive experiences with different gapps versions I’m eager to hear about it!

Well like I said I used NikGapps because neither mindthegapps nor opengapps would install.

Didn’t notice any difference, works just fine.

Edit: you talked about “dirty flash”. Do you mean you flashed LOS on top of another LOS version that didn’t have gapps, and without wiping your phone ?
If that’s the case there is absolutely no way at all that flashing gapps will work as it need to be flashed before first boot setup wizard.

The only alternative that I know of for getting gapps on a degoogled system after setup is through litegapps magisk module, but it doesn’t seem very stable.

Not sure whether you addressed me, but I did the normal upgrade routine, no dirty flash. And i even did not get to flash gapps at all, because i didn’t test nikgapps

For those of you who wonder, I’ve just reinstalled LineageOS on Thursday (coming from stock ROM) and I flashed MindTheGApps sucessfully.

With “dirty upgrade” I mean adb sideload of the 19.1 on top of the 18.1 installation without wiping the device.

Hello, I wanted to report that I was able to upgrade from 18.1 to 19 without wiping anything, and flashing mindthegapps (opengapps package failed giving an sdk version error).

Exciting, thank you for developing this!

I just built LineageOS 19 based on the instructions, installed it, and it works beautifully - big thanks!

I also needed an additional reboot to make the fingerprint reader work - minor issue.

One other problem I experienced: my homescreen has been reset - I lost all my icons/multiple home screens. Is this expected when upgrading from 18 to 19?

I just upgraded from Lineage 18.1 to 19(.1? 20220627 nightly anyway) without wiping anything.

I had some trouble sideloading Gapps though. After sideloading Lineage and rebooting to recovery sideloading Mindthegapps (12.1) complained that i was trying to install it onto Android 11 and exited without installing.

Having seen that and looking around in the recovery i realised that my phone was still booting into the slot i didn’t sideload the new Lineage to so i had to reboot to the bootloader, switch boot slot, reboot to recovery again and finally i could sideload Mindthegapps.

Also the launcher was completely reset after the upgrade.


So, if you follow the instructions it is working… :stuck_out_tongue_winking_eye:
Im on Los 19.1, too, with mindthegapps.
Not sure I like the design of Android 12, though. But who asks me… :wink:

I can confirm upgrading from 18.1 via adb sideload worked for me. Was quick and no files or apps were lost, though the home screen was reset as someone else mentioned here.

Others considering to upgrade might wish to first look at screenshots of the new system theme used for Android 12, which looks like it was designed by a child. It’s not bad enough for me to abandon it, but it will definitely take me some getting used to. What I can already say though is that it’s categorically worse than Android 11’s theme. No idea what they were thinking.


Hello, it seems I spoke a little soon.

Unfortunately, the first OTA update (20220704) has not installed for me correctly, and my phone enters an infinite bootloop. Currently I can not use my device (eek!).

Any advice on how to resolve this? Do I need to wipe the phone, or can I reflash the original initial zip file using adb somehow (20220627)?

Update from the unofficial 19 to this version worked flawlessly. thanks again for your hard work <3

1 Like

Is your bootloader unlocked?

Does anyone know when the microg build will follow? The usual cycle would have been 2. July.

1 Like

Yes unlocked bootloader. In the end, I did a factory reset, and sideloaded the latest nightly through adb. All resolved now with the wipe, not sure what happened.

June ASB for kernel is now merged and should be available in next release.



I am curious too. They suddenly stopped providing new MicroG-builds for the FP3 (18.1&19). The FP2 got his latest build on 2.7. as expected. Is there a place where one could ask about that? According to the providers they build a MicroG-version for EVERY official LOS-port TWICE every month, so it is weird that they stopped out of a sudden now since all conditions are met.

Thanks to all maintainers, I never experienced such an active, dedicated & nice community behind any device I owned. Coming along with one fix and update and improvement after the other, I am not sure how you guys keep that up, but I am amazed and appreciate it.

so should this ever happen again and as long as your bootloader is unlocked, it seems its always worth a try to change the slot to see if it boots then.

1 Like