FP4 and LineageOS

I installed lineage os as discribed. It went very well and its working good. It pass safetynet with magisk. They only thing whats not working (some mentioned it already) is loading whatsapp backup from google drive. I will try an local backup tomrow. For the rest i think Gpay works and no problem with other apps. Hope battery life is also good.

In my experience it’s been totally fine with this LineageOS build.

Locking the bootloader boils down to security. Verified boot is an Android security feature that won’t work with an unlocked bootloader.

A huge problem as mentioned earlier is that its nog possible to restore the message backup from whatsapp. I really need my messeges so i go back to stock till some knows how to solve it. Also restore of a local back up wont work (for me)

Getting back to stock looks easy but it result in a endless bootloop. Now back to Lineage for to see if thats boot.?

Have you moved the WhatsApp backup files to the right place before setting up WhatsApp?
Those Backup files must be in /Android/media/com.whatsapp/WhatsApp/Databases, but I usually move the entire WhatsApp folder to com.whatsapp

To do this, you must also install the Google Play Services (GPS).
Do you have e.g. installed NikGapps?

1 Like

Thanks for the answers, i Will try out again, i installed mindthegapps. I Will try the you mentioned.

I checken is Google play services weer installed i update IT the reinstall Whatsapp the same problem in one moment IT ask for angoogle accountbut then IT go wrong. I van only make An new account that’s all

Everything worked with the new image!

Many many thanks!

Thanks i solved everything installing Nikgapps was te solution for everything.

I installed both versions of LineageOS provided by @mmustermann and everything seemed to work fine until I tried to use audio via Bluetooth. With two headphones, all I got was cracking. Does anyone have any idea, what the problem could be and whether that’s fixable on my device without building my own image?

But for now I have to try to reflash the Fairphone OS, which so far also hasn’t worked and once I got that working again, stick with that for the time being. :frowning:

Regardless, thanks for all the work and I hope that it will work properly some time soon.

Hi bluetooth issue is fixable in developer settings and disable A2DP hardware offload switch off. If you activate this setting it will be fixed(it was for me). I also managed to reinstall the original ROM without any issues. Install of LOS also worked but I found out install of a backup of WhatsApp was difficult, install of the right gapps made it work. I will try LOS for a while and then decide what to do. Back to original or keep it. The downside of LOS is less audio quality and not use of full the camera options.

Thats the problem in every A12L ROMs

The fix is to enable this

2 Likes

Thanks to @H_Verweij and @FairphoneHulk for your tips. I’m relatively sure to have tested all Bluetooth options in the dev settings, but that’s probably not actually the case and that would fix it.

But for now, I installed CalyxOS and so far everything I need works out of the box. Also it feels close enough to LineageOS that I think it’s nice breath of fresh air after having used LineageOS for many years.

I’ll try CalyxOS out until there is a official release of LineageOS and decide then what I’ll use in the long run.

1 Like

@mmustermann I’ve decided to take a look at LOS 19.1 and flashed your signed build, I flashed your most recent androidfilehost’s upload, dated from june.
Thanks a lot for publishing those by the way.

I’m globally satisfied with the experience so far but a bit frustrated by a weird fingerprint unlock issue.
It seems that after a relatively short time of sleep - several minutes, definitely less than an hour - when waking the phone, it will ask me for “pin code for additional security”.
This is pretty annoying, I wonder if you noticed that too and found a way to increase the fingerprint timeout or whatever is causing this ?

The problem with the fingerprint sensor is that it listens all the time, even when the display is off. If you touch it somehow and it doesn’t recognize your fingerprint five times in a row, you will be asked to input your pin code. I think that causes your issue. So far this has not been a problem for me. It usually works for weeks without asking me for the pin code.

However, there is a pull request that seems to only activate the fingerprint sensor when the display is on: Update config.xml: setting config_fingerprintWakeAndUnlock to "false", because FP4's sensor is embedded in the power key and listening all the time is annoying. by zq2geXQsmGj · Pull Request #9 · WeAreFairphone/android_device_fairphone_FP4 · GitHub
It got merged into the LOS 18.1 branch, but not into staging/lineage-19.1. I believe this pull request will solve your issue. Maybe you can ask to include it into lineage-19.1 too. I don’t have the time to do so currently.

2 Likes

Thank you for the reply !
I have to check again, but I’m “almost” sure this happens even with my phone not being touched at all for a few minutes.
Because, to me the message when you tried five times in a row is different, it’s actually “too many attempt, enter pin code”, which I indeed met some times. Now the one I got when waking my phones after several minutes of inactivity is “pin required for additonal security”. Could it be linked to the fact it’s used with no sim card in it ?

Anyway I’ll investigate further. Thanks again for taking the time to answer !

Edit:
I just tried it, restarted the device, entered code, put the phone on the table, waited for 3 minutes. When grabbing it: “pin required for additional security”.
Weird.

Edit 2: weirdly enough, it appears reseting the pin code solved the issue… for now.

I was with LOS for a couple of days. Overall everything works as expected. The only thing why I got back was the camera options on the original ROM are slightly better in my opinion. Also go back to stock was easy without any problems. Maybe because I never relock the bootloader that seems to cause issues I understand.

This is fixed in iode

Hi,
I recently built lineageos 18.1 for FP4 and installed it on my device. I tested it several weeks and can say that it works just fine. I would like to participate your team to make official lineageos builds for FP4 available!

Greetings
typh00n

5 Likes