Official LineageOS 18.1 for Fairphone 3/Fairphone 3+

Our build server is telling us

[SNIP] incoming/failures/FP3/1f7e1742ed9e4a36989e7c4e3b930f61//android-build.log: No space left on device

:frowning: Will look and see if someone is taking care of it…

4 Likes

Awesome!

Can you maybe point in some direction on how to include the new blobs etc when I am building the ROM myself?
As I see it, the scripts or whatever is used to include the blobs is not open source, right? :frowning:

Same problem here with 18.1 (on brand new FP3+)

Hi All,
I am very happy to share with you that I am now successful in updating the kernel and rebasing it to the latest state as I had discussed previously.

Now, the question is:

  1. Do we need this for LineageOS-18.1 or
  2. We’ll move to LineageOS-19.0?

Let me know your feedbacks and I’ll take it up accordingly.

Thanks,
TeamB58.

7 Likes

I definitely would like it available now, as I’m an adventurous mind, even though this phone is my daily driver…
Also, i don’t know the schedule for los 19, so this might be still be quite a long haul…
But i can’t say what is involved in integrating it in the actual los…

Here it is: [ROM][Unofficial][Update] LineageOS 18.1 for FP3/3+

2 Likes

Since “LineagOS for microG” does not update the firmware partitions, I installed today regular LineagOS on my FP3 and tried to install MicroG on top of it. However neither NanoDroid nor MinMicroG flashed via Magisk seems to enable Signature Spoofing.

Did anybody manage to get MicroG (or Signature Spoofing) working on regular LineagOS 18.1? If yes, how?

Hi All,

If anyone’s willing to try out an early build of LineageOS 19.0, you can find them here.

Thanks.

3 Likes

A while back I was able to enable signature spoofing using tingle and the help of a guide I found online. But there also should be an Xposed-Module module that does the job.

EDIT: While looking for the guide I found this: https://github.com/Otus9051/spoof11

1 Like

@Schmunzeldrache: I’m also thinking about moving from “LineageOS for MicroG” to the official LineageOS. How did you do it? Were you able to keep your data or did you simply wipe and completely reinstall your device?

Do you know already how MicroG is kept updated when you flash it via Magisk? Does that mean you need to flash the new version every couple of weeks to get the new release?

Thanks!

I thought so too.
But when I installed the lates microG build, I saw that the vendor’s security patch level is now updated to Nov 2021. And these updates are part of these blobs.
Before the microG update:

After the microG update:

3 Likes

Thanks a lot @Switch! spoof11 actually worked!

By the way: Tingle and the FakeGApps (the LSPosed module) did not work. I guess Tingle is simply not ready for Android 11 and FakeGApps too, or might fail because I’ve installed LSPosed with Zygisk and not with Riru.

@f4354: I did not even try to keep my data. I made a backup and fresh reinstall.

Do you know already how MicroG is kept updated when you flash it via Magisk?

No, not yet. And I am not yet fully happy with the microG on my device.

In a naive attempt, I tried to install the microG service core (and its helpers) via its f-droid repositiory, and had they idea to update it via f-droid. However that did not enable the full microG experiance. Map services did not work in apps using maps. So I tried to flash the microG from spoof11 via Magisk. Looks better, but getting a location base on WLAN via the Apple UnitfiedNlp backend seems not to work (or I’m in a blind spot).

So at the moment I am happy that signature spoofing is finally working, and I can go on to solve the microG issues. Maybe I try NanoDroid and MinMicroG again, since signature spoofing is active now.

So at the moment I can’t tell you yet, if switching from “LineageOS for MicroG” to official LineageOS and enabling microG there is thing I can recommend. The experiment has just started. I just had a stopper yesterday, where I recognized that enabling microG did not work so easy as many people report with LineageOS 17.

OK, that is interessting and pretty good news. Well, maybe I end up again with “LineageOS for MicroG”, but at the moment it is also fun to try to get it working with official LineageOS.

1 Like

The vendor security patch level shown in lineage4microg complies with BoardConfig.mk and reflects the status of the extracted blobs by extract-files.sh e.g. proprietary libs. However, the firmware partitions e.g. for the modem aren’t included there as you can estimate from the OTA image file sizes (LOS4MG 694MB < LOS 699MB although ca. 70MB MG et al is included in LOS4MG). For a detailed check you may extract and compare the images included in the OTA’s payload.bin (cf. Extracting proprietary blobs from LineageOS zip files | LineageOS Wiki), and see that the firmware partitions unfortunately are missing the the LOS4MG. To stay up to date with the firmware partitions, I’m afraid you have to continue on basis of the original LOS or you need to setup your own LOS4MG build and include the FW images yourself …

2 Likes

Since a couple of weeks, I can’t receive any SMS for one of my carriers (I have 2 SIM cards). I have tried with the SIM card in another phone, and it works. The carrier claims the SMS have not been delivered because the phone is offline, which it isn’t. It’s been online all time.

So I suspect something happened with one of the latest updates, possibly the 20220221 update (I received my last SMS 2022-02-22 and I guess that’s when I updated the phone).

Anyone else?

Edit: Looking through the changelog, the only thing I find is this: https://review.lineageos.org/c/LineageOS/android_device_fairphone_FP3/+/322885/

The last update did change qti-telephony-common.jar to match stock. That may be related to SMS services. Can you send SMS?

Yes, I can send SMS. After fiddling with the phone and moving SIM cards around, it actually seems to work again. Which is good, of course, but a bit unsettling not knowing why it didn’t work.

Hello, I finally made the jump to 18.1 from 17.1 without a hitch, and I wanted to say a huge thank you to the maintainers. Long live lineageos!

1 Like

My FP3+ top-module front-camera is not working anymore. The FP3+ Module works in a FP3 with stock rom.

On my FP3+ with latest LOS 18.1 build only the 8 MP old FP3 top-module works?
Anyone else is facing problems?

More information in this thread:

Thanks in advance!

2 Likes

Hi @dk1978 ,
Still waiting for your update/feedback on this topic.

Thanks.