Notification bar, home button not working, system ui tuner not visible

Thank you,

that’s how it looks like in my system (Windows 10, FP2 after TWRP rebbot):


The internal Storage only shows the TWRP folder although it says 10,8 GB out of 25,5 GB used…

Your internal storage folders are listed as SD card contents, looks like you chose to incorporate your SD card into Internal Storage when Android asked you about it (hence “Adopted Storage”).

TWRP has to deal with this somehow, and I guess this is how it does.
(I’ve never seen this myself, I always leave the SD card alone as external storage. Incorporating it into Internal Storage was always a bad idea technically, Google has luckily seen the light and removed easy access to this feature in later Androids.)

3 Likes

Thank you very much for your detailed support.
Unfortunately it seems that I finally destroyed my FP2 (correctly even worse: my daughter’s FP2):

we booted using TWRP => worked correctly
we copied all data via USB to the PC => worked correctly
we ran a backup and copied the files from the TWRP Backup folder to the PC => worked correctly
we did a factory reset of the FP2 => worked correctly => blank new FP2
then my daughter found out that one phone number she was called yesterday is absolutely important.
So I tried to restore the TWRP backup to the phone to get the old status.
And this seems to have failed!!!
Now the FP2 stays in the “FAIRPHONE Change is in your hands” boot screen with the blue dot animation.
With no TWRP connection possible and no othe options.
When tying to do a hard reset (power and volume up buttons) the broken android symbol and “No command” is shown…
Is there any possibility to make the FP2 boot into any operating system out of this state?
Any help very welcome!
Thanks

So … please follow the guide for a manual install of the OS … it states “The user data will not be erased.”

(I’m assuming you had Fairphone OS installed, and not Fairphone Open OS.)

2 Likes

When you want to restore TWRP asks what to restore, so I only ticked the box for data. Now the problem seems to be gone.

1 Like

Maybe Explorer has some “hide folder” options enabled.

Thank you very very much for your suggestionn.
I appreciate your help very much.

Unfortunately also the manual installation of the Fairphone OS didn’t help.
The Windows console worked correctly and also announced “reboot your Fairphone it should work correctly”. But after unplugging and rebooting the FP2 it stuck in the “FAIRPHONE Change is in your hands” boot screen forever…

Do you have further recommendations?
Can the TWRP restore job have destroyed something inside the FP2 so that it now doesn’t work even after manual Fairphone OS installation?

thanks

For this to work, the OS version you install should match the OS version the restored backup is from.
Since you didn’t specify which OS and which version of it ran on the phone, we can’t be sure of that.

The guide links to the install file of the most recent 19.11.2 version of Fairphone OS, which is the best guess in such a situation, but if you are certain it was an older version or just want to try, older Fairphone OS versions are being kept available here … https://support.fairphone.com/hc/en-us/articles/213290023

I’m thinking of a different approach now, though.
The backup is restored, the data you require should be there, but the phone doesn’t boot to let you have a look.
TWRP can access the restored files on the phone, so the file in question could be copied to a computer.
Question is: Which file contains the call log, and is there a way to make sense of the file’s contents on a computer?

Perhaps somebody else here has already done this before?

No, I can’t think of a simple restore of a backup doing that.
It is actually not that easy to get the Fairphone 2 into an unsalvageable state.
As long as Fastboot mode works, you will have options, here’s one … (which doesn’t help with accessing the call log just now, because it deletes user data) …

1 Like

My fairphone crashed some seconds after unblocking the phone the whole yesterday afternoon. I shut it down for the night and today I’m having the exact same problem that you describe. I updated the phone to OS 19.11.2 today, but this didn’t help.
Has someone tried to reset the device?

Can people whose notification bar is frozen still access settings? If so, has anyone tried switching into and then back out of a guest account (as that seems to restore access on some other devices)?

Ok, I tried this myself just now, and it worked. Try the following with the restored backup which doesn’t boot …

  • Connect your phone to a computer via USB.
  • Boot TWRP (in case it isn’t installed, see #twrpwoflashing).
  • Make sure you can see the folders on the phone on your computer to copy stuff over later. (Or skip to my Edit below.)
  • In TWRP:
    • Advanced
      • File Manager … this should display the folders in the root directory.
      • Navigate to /data/data/com.android.providers.contacts/databases
      • Tap on the file calllog.db, it should be there.
      • Copy File … this should display the folders in the root directory again.
      • Navigate to a destination folder which can be accessed from the computer, i.e. something in /data/media (that really is “Internal Storage”), e.g. /data/media/0/Download
      • Tap the checkmark icon in the bottom right corner
      • Swipe to Confirm … The following screen should be titled with the two lines “File Operation Complete” and “Successful”. Don’t mind the other output there, it’s just the log TWRP keeps in the background after booting, it has nothing to do with the file copying just now.
  • Copy the file calllog.db from the accessible folder on the phone to the computer to somewhere you can find it.

On the computer:

  • Install DB Browser for SQLite … https://sqlitebrowser.org/dl/ … because calllog.db is a database in SQLite format.
  • Start the program.
  • In DB Browser for SQLite:
    • Open Database
    • Navigate to where you copied calllog.db to and open the file
    • Go to the “Browse Data” tab (instead of the “Database Structure” tab).
    • Set the displayed table to “calls” (instead of the “android_metadata” table).
    • The “number” column should then have the number you’re interested in somewhere.

Edit:

If somehow the file can’t be copied to a computer, you can have a look at it in TWRP.

  • In TWRP:
    • Advanced
      • Terminal … execute the following commands (type them into the command line and then tap the checkmark icon to run them)
      • cd /data/data/com.android.providers.contacts/databases
        (changes the directory to where calllog.db is)
      • cat calllog.db

This will dump the raw content of the file onto the command line, and it will look messy (and the phone will perhaps vibrate from non-displayable characters).
But take your time, you can scroll up and down with the slider on the right side, and the number you’re interested in will be visible in this mess somewhere.

2 Likes

@AnotherElk : You are a genius!!
After several manual Fairphone OS attempts without success I tried to reformat the system partition (!) with TWRP and then I could install Fairphone OS.

Thank you very much.

At least we have a virgin Fairphone which works. Even without most of the settings.

@AnotherElk where do you want your statue of heroism and helpfulness to be built?

2 Likes

Did you get the desired number in the end?
I just was struck by this lightning here …

Shows you what I know, really. I didn’t realise the file format of the backup was simple to deal with.

So, if you wiped the phone before dealing with the calllog.db, and if you have your TWRP backup on a computer, then just open data.ext4.win from the backup with e.g. 7-Zip (Edit: for Windows , the tar command works for Unixoids) … this should show only a folder (without a name in my case, but this could perhaps be different), open that … and there you are … data/com.android.providers.contacts/databases/calllog.db.

I learn every day :slight_smile: .

2 Likes

Yeah, in the calllog.db (opened via a DB Browser for SQLite) we found all called numbers.

Was quite an Odyssey and we nearly gave up when the FP OS flashing failed. But now everything is fixed, all contacts found, alle messages restored and even the notification bar and home button work correctly.

1000 thanks

3 Likes

That’s Fairphone - yours to open (also software wise :wink: )

2 Likes

Thanks Johannes. I’m willing to try and I still have access to Parameters but can’t find how to do this on FP2. Do you know how to do it?

same here…:raising_hand_woman:

I’m not sure what the exact steps are on FP2, as I don’t have one to play with. I have read about people using different user accounts on the FP2, so it has to be possible. The closest I have here is an Android 8 device, where it is under Settings > Users & Accounts > Users (where the instructions I linked to above also suggest it can be found). The last step is maybe counter-intuitive, as the Users & Accounts screen mainly shows a list of accounts (‘Accounts for …’). Above this list is a line ‘Users’, which can be tapped to access a list of users which includes an option to set up a guest session.
The alternative location suggested online is Settings > System > Advanced > Multiple Users. As said, I’m not sure what the exact menu structure is for the FP2. If anyone can find it, please let us know.

This is what Settings > Users looks like on the FP2 (Fairphone Open OS 19.08.1):

I guess the separate “Accounts” settings aren’t relevant in this context, but for completeness’ sake:

Settings > Accounts | Settings > Accounts > + Add an account

Tapping guest where it’s shown in the image should start a guest session. On my test phone it takes a while to start (and at first it seems nothing is happening). Switching back is a case of going to the same menu and choosing ‘remove guest’.