Notification bar, home button not working, system ui tuner not visible

Hello everybody

I have the same problem:

  • Button at the bottom middle and on the right do not work,
  • no notifications from WA, SMS (I was able to set this in the meantime),
  • camera cannot be activated with button on the right side and
  • bar at the top I cannot drag down twice.

Hope also for a solution soon.

Hi everyone,
I’ve been experiencing the same issue for the past few weeks and have created a support request February, 20 with a link to this conversation as well. I’m waiting for their answer and will keep you posted as soon as I’ve got a reply. Soon, hopefully.

Just a short update.

After I wrote here I have created a support request, too. But I haven’t heared back for days. Since I really needed my phone for work, I tried several solutions. Those are basically the same solutions FP suggested to try in their answer.

Summary: a) Try safe mode b) Kill you data and reset c) send back your phone and wait for weeks until we have some news.

The latter is really the last option. Or better: It isn’t. I don’t have another phone and need one - as I mentioned above - for my work.

So here is, what I tried:
a) Manual update: Failed because it doesn’t download anymore
b) Driver intstall: Doesn’t work, because I cannot use the notification bar
c) Save mode: Didn’t work

The final solution was to reset to factory settings. Since it was not possible to make any backup I’ve lost a lot of data. I’m really not happy with this device. I use it since about one year (!!!), the camera module doesn’t work (since the beginning - artefacts. A well known problem at FP) and no new camara modules are held out in prospect. And now this. I cannot trust the idea of “yours to keep” anymore.

I’m afraid FP is just an idea but surely not a solution. Yet at my daily work I cannot be a philosopher: Ideas are not what I expected when I pay a few hundred bugs.

I’m really upset and annoyed but mainly disappointed.

Regarding backing up files … since I don’t see a mention of this yet here, has anybody tried to boot TWRP and see whether the phone’s storage is available to a computer via USB then?

Normally MTP is enabled after TWRP was booted and with this Internal Storage and the SD card (if there is one and it was left as external storage when Android asked) should be accessible via USB.

You can try this without installing anything on the phone as long as you can still boot it into fastboot mode, see #twrpwoflashing.

Understandable, but [insert some remark about the worth of a functioning backup strategy for important files in a tone of your choice here].

3 Likes

For now I have no answer from Fairphone about the case I opened regarding this topic :frowning:

I will try to back-up data with twrp as AnotherElk is suggesting, because when trying to solve the issue I have reset my data synchronisation (Calendar and contacts with OwnCloud) and can’t re-enable it, even with desinstalling/reinstalling the apps… Don’t know if it is related to the bug.

Hi,
Since 1 week, I’ve got exactly the same issue…

  • Button at the bottom middle and on the right do not work,
  • no notifications from any applications
  • bar at the top cannot be dragged down twice

I’m going to ask help to the support too and I hope a solution can be found really soon…

Yep - just tested it with Linux Mint and TWRP 3.2.3-0, accessing both memory types works fine, greeeeat. Many thanks, I would had never even tried this… :shushing_face:
Much better transfer speed than when the system is booted.

1 Like

Hi everyone,
Little update: I’ve received an answer from FP, but all they told me was to do a factory reset. I haven’t tried it yet since I need to back up my data first and I was really hoping it wouldn’t come to this, but we’ll see how it goes.
It’s just a shame to see that it seems to be their answer to everything. It’s gonna be the second time I have needed to do one in 3 months, after having opened a support request. But well, I hadn’t experienced any problem for 4 years before that so it’s not all bad.

1 Like

Hi. Here’s the answer I’ve just received from FP support:

I’m really sorry that we couldn’t answer your message earlier, this is due to a high number of requests at the moment.

Unfortunately, as already discussed in the forum, the only solution that I can offer you is to perform a factory reset.

To exclude the possibility of a software issue:

  1. Make a backup of your personal data
  2. Then, reset your Fairphone 2 to factory settings.

Hello!
For those of you who did a back-up followed by a reset: how did you back up your text messages (SMS)? FP advises to install the [SMS Backup & Restore] App but downloading new Apps (and updating installed ones) always fails. Maybe another bug linked to this problem…
Thanks a lot!

My wife has the same issues and is afraid of loosing all her settings data from her apps. Is it possible to make a full backup with twrp on a not rooted phone?

TWRP is a recovery program. It is booted instead of the installed OS and thus doesn’t care whether the OS is rooted or not.
For just booting it without having to install it see #twrpwoflashing.

It has a backup function which can make a backup of the state of the installed OS for you, but the backup will not include Internal Storage (you can copy that via USB, though, when TWRP is booted).

Thing is … TWRP’s backup function will backup whole partitions,
so if you backup this way, you would probably backup the issue, too.

You can deal with individual folders and files with TWRP’s file manager or terminal, too, but you would have to know what you are doing.

4 Likes

Same issue here.
As it seems that this bug is affecting dozens of FP2s it would be really appreciated if there would be a prcticable way suggested by Fairphone. At least enduring that no data is lost when resetting the device.

I can’t boot or install TWRP because I can’t connect to the phone in fastboot mode. When I type in “fastboot devices” I get the following output:
no permissions (user in plugdev group; are your udev rules wrong?); see [http://developer.android.com/tools/device.html] fastboot

But part of the problem discussed here is that you can’t activate developer mode any longer.
And Google doesn’t backup either.
Has anyone an idea how I can backup the system partition?

When Install something with adb sideload does that erase my data?

Keep calm and don’t confuse ADB and Fastboot.

Fastboot (contrary to ADB) doesn’t need any setting in Android, it doesn’t care about what’s on the phone at all.
It just needs the phone booted in Fastboot mode and a USB connection to a computer with a working fastboot command.

This sounds like an issue to be sorted out on the computer side.
Try sudo fastboot devices or try the fastboot command as root, or try it on a Windows computer if you can.

2 Likes

I was able to fastboot my FP2.
When I connect the FP2 via USB to my Windows PC in TWRP I can connect to the external SD and backup the data to my PC drive.
But trying to access the internal storage I just get a TWRP folder.

Can you tell me which data will be backuped when copying all files from the FP2 SD card and which will get lost (being on the internal storage)?

Thanks!
Running sudo fastboot did the trick.

when you do a backup with TWRP, the backup files get copied to storage that you can copy to your PC. With TWRP it should be possible to restore everthing

@Arnie47

Not quite, please read through this FAQ.
As some data path is excluded from being backed up. But once TWRP is up and running you can mount (both) storage(s) and manually backup these data paths via USB.

It looks this way in Linux when having TWRP booted and my FP2 connected via USB.

2 Likes

But be aware that a twrp restore will also restore the error (and not include /data/media, as mentioned by @Patrick1). So the use of a twrp backup is limited here…

2 Likes