Noisy coloured pixels on my Fairphone 2

I dried it. Doesnt work. Doesnt change anything. I share the assumption that it is not just a problem of THAT contacts. Because it helped the last weeks just when I bent the phone, nt when I give pressure on the places of that display contacts.

With the continued necessary occasional twisting, my phone now has on two occasions of twisting also decided to reboot. So I assume some battery contact is also affected now by this.

This more and more looks like a loose connection somewhere on the motherboard to me…

#contactsupport

And if you still have warranty …

Unfortunately, warranty expired beginning of last year (bought it in the initial crowdfunding). I guess I should still contact support to see what they recommend (e.g. a replacement core module?)

Yes I think the same. I dissambled everything, after the phone were not useable at all anymore. But it seems like I would need someone who explains me how the connection from the pins of the displaycontact to the motherboard works :wink:

Because its very sad, that its obviously just a contact problem and still the only conclusion is to change the whole core modul. ?

:smiley: I tried the oven!

Seems like the display works again :smiley: great! Thank you ElKrasso!

Now the phone stays at the Fairphone symbol. But I am able te reach Team Win. Seems like the 200 degree burned the OS.
I dont realy know what to do further, but I will continue reading how to reinstall the OS in TW.
Crazy journey with this phone!

3 Likes

How long did you let it stay in the oven?
You can enter the recovery?

I’m a little cautious regarding the baking:

  • First, all the places I checked on the web recommended not to use the oven for food afterwards anymore (and I don’t have a non-food oven at the moment)
  • Second, quite a few people also said that just baking like that might make your device work for a little while but the solder contacts will not be redone very well…
  • Also, I’m not sure about what was meant by “Dissemble anything you could from your core module.” - which parts from the core module can I actually still disassemble?

I’m far from a soldering expert (though I have a soldering iron), so maybe it might also work (and is safer) to just re-heat the individual pogo pins with a soldering iron? That’s what I’m probably going to try next…

But I’m very curious to hear more about whether you got your software set up again and whether it works for a longer time! Have you tried booting into fastboot (Power+Vol down)? If that’s working (you’ll see static text - Fairphone, and the phone will be reachable via USB), you should be able to flash everything else again!

2 Likes

A cleaning of the oven after a soldering process should be mandatory as you like to use it for preparing food again.
I described it as a last try before scrapping the PCB. Of course an home oven is not as acurate as a professional soldering equipment, but it can do the job.
The core PCB should not “baked” with any plastic parts mounted on it, like the frame or somthing like that cause it can melt.

1 Like

Everything work well again.

I let the coremodul around 13 minutes in the oven, because my mark on some visible solderjoint had not changed after 10 minutes.

3 Likes

Well, you should be a fairphone angel if you managed to revive it.

Awesome to hear that you made it. :+1:t3:

Greetings.

I seem to be having slightly different pixel problems. I had a look through the forums and couldn’t find anything similar. It happens maybe once a week and only for a few seconds. It’s not a screen hardware issue as this is a screenshot.


I noticed it happen in the magazine app attached, but also WhatsApp and when using the camera. Any help appreciated.

I suppose it could be a bug in Android 7, but wanted to check here first.

It’s this one:

1 Like

Excellent. Many thanks :-). Hadn’t made the connection to the Night Light. Interesting that it went away when you got a new screen…

Hi all,

Unfortunately I have the same problem since Monday. My FP2 froze when I added a contact. Rebooting gave first only a black screen, later on the famous noise or snow appeared. The phone is still working however, it can be charged and turned off and on. The upper right led does function.

Because I was travelling I only removed the screen today and cleaned the connectors with a dry whipe. Unfortunately it didn’t help. When bending the screen (as suggested earlier in the thread) some changes in the screen appeared (see picture), but still only noise and snow.

It crashed one week after I entered the Philippines, maybe the humidity or heat played a role? I also added a local sim one week before it crashed.

Do you have any tips for either cleaning the connectors again (or with alcohol?) or for how to best bend the screen to make it work again?
I really hope it’s not the motherboard. It’s very inconvenient.

Any tips how to back-up data from the phone without a functioning screen are also welcome.

Many thanks in advance!

I am having the same Problem.

I just tried another Screen-module but it showed the exact samt pixel-Screen as before.
So this can definitely be ruled out.

Same problem here. Replacing the display with another (working, of ym wife) did not help. Cleaning contacts neither.
What helped a bit was pressing the Phone, back cover off, between my fingers on it’s right side, approx 5cm from the upper edge, from back to front. There is a point where after a few presses the display sprang back to normal function again. Sometimes the display worked,but no touch screen. after a few presses more, the touchscreen worked too. Su I suppose it’s a connection problem too. A 380,- repair isn’t an option here, as I am out of warranty already…

I did the “paper trick” - and for now it works.

2 Likes

I don’t know if this has been mentioned, but using a non-slim, “fat” cover reduces the chance of the screen going wild, in my experience. Probably because it’s less rigid due to the rubber bumper. But you need to find one that didn’t get screwed…

Hi, I’ve same problem (coloured noise pixels);
Troubleshooting guide suggests to replace display (https://support.fairphone.com/hc/en-us/articles/115001041206-Troubleshoot-your-Fairphone-2-issue)
but reading this topic it seems maybe the problem can be in core module…
So what to do? I’m sure that replacing display solves the problem?