New FP4 does not wake up display

I got my new FP4 today and after the setup it was otherwise fine, but when the screen goes off, it doesn’t wake anymore. The phone vibrates when I put my finger on the scanner and plays the screencap sound when I hold power + vol down. So the phone is awake but the screen is all black.

The only thing I can do is to force reboot.

I did already contact support but got no response yet.
Anyone with similar problems?

1 Like

Yes.
I think is still the same bug then fixed in actual fp3 Software.
Try to disable auto brightnes

Actual for me, i disabled nearly every app and use lawnchair. Since then happened no more

2 Likes

Same issue here. It worked just fine for 2 days. Now the display doesn’t wake up. Also contacted the support.

Have you tried another launcher?
Since I use lawnchair reborn from f-droid and Izzy Repo I never had this issue anymore

1 Like

No, I’m not going to just forget the problem and go around it with my 0 days old phone that I paid plenty for. Maybe later I’ll try something different.

For the whole community, it’s best that the bug gets fixed.

2 Likes

You’re absolutly right.
But better to get a workaround that works, then a device that’s make trouble for months until it get fixed :wink:

2 Likes

Did not try a different launcher but did a factory reset. Now it works fine. We’ll see how long it lasts…

3 Likes

cool. but i think a alternative launcher is simpler and easyer then a factory reset every time :wink:

1 Like

we’ll see how long it lasts…

1 Like

Same problem here, but a factory reset didn’t fix anything. I have contacted support but in the meantime, I have to reboot my phone several times an hour which is not great. Have anyone found even a workaround that at least prevents the reboots?

Maybe just a loose connection between modules, you could check for that.

You could also try starting in safe mode to eliminate soem software possibilities.

I discussed with support sand sent my unit back. They will send me a new one. No tricks could help me at least.

So I tried safe mode and it suffered from the same problem.

While the screen is black, I can plug the phone to a docking station and use it with an external monitor, keyboard and mouse; but the phone’s screen can’t be woken up, and the touchscreen doesn’t work.

I also tried disconnecting and reconnecting the screen but the problem remains the same. Do you have any idea which other module could be related to the issue, so I can try disconnecting/reconnecting it?

No other ideas. I don’t think there is a work-around as this should not be a common software bug. It woulod seem Fairphone would be best looking at the phone under warranty.

I get the same 2 days ago and I didn’t find a solution. I tried to reinstall the phot from 0 as I thought it was a customisation app which changes the main software.
I solved it but I don’t know why and how. It works fine since but reading yours it seems to be back in a few time :confused:
Incredible to get a phone which doesn’t wake up

I ve gut my fb4 today.

Same issue.

After i Turn the Display Off i have to Reboot.

I use the smartlauncher

It seems like Fairphone has no easy solution for now.

I suggest you try out the following :

  • Make sure the latest build is installed ( SettingsSystemAdvancedSystem updateCheck for update )
  • Try without any SIM card inserted
  • Try in safe mode (with the phone unlocked, long press the power button until power options show up, long press Restart then tap OK)
  • Try a factory reset ( :warning:Backup any essential data:warning:, and then go to SettingsSystemAdvancedReset optionsErase all data (factory reset)Reset phone )

If nothing helps, contact support and they will offer you to send the unit to their repair center.

3 Likes

After I do a factory reset it works right now.

3 Likes

I just did a last factory reset before sending the phone in for repair and…it works now!

After a few tests, it seems like the problem comes from restoring data from a google account at the phone’s installation wizard.

My old phone was a Galaxy A5 2017 with an OLED display. The screen was configured in “Always On” mode. Maybe this is what caused the issue.

What I recommend for people encoutering this issue :

  • Backup all of your data, since only your Google-synced contacts will be restored. If you use WhatApp or any messaging app, do a backup of your conversations now or you will lose your latest messages and media.
  • Do a factory reset
  • Go through the installation wizard without going online, do not connect to your Google Account
  • When the wizard is complete, connect to your Google Account, but do not restore anything from any previous phone!
  • You now have to setup your phone and apps from scratch.
8 Likes

I don’t think this is the reason. I successfully restored a Google backup from a Huawei P30 OLED phone with active Always On Display and I didn’t have any issues.

2 Likes