Netflix not installable on FP3?

I just bought a FP3 and when installing my applications I noticed that I am not allowed to install Netflix. I didn’t do anything to the system. Just start it and do the configuration.
I will appreciate to know if I am the only one with that problem or if that is a know behaviour/problem.



maybe that is related to this issue here.


I got my FP3 a month ago and had no problem installing Netflix.
And I just checked, it’s still there and works.

If you say “not allowed”, what exactly happens? Do you see the app in the play store?
What happens if you try to install it from this direct link?

1 Like

[edit] sorry forget my precedent message it was done on another device…

So when follow the direct link I arrived to the netflix pages but there are no ‘install’ button and the message said your device is not compatible with that version

1 Like

Your Netflix issue has the same reason as the Google Pay issue. Wait for the update, fairphone is allready working on…


For pay-applications there has been a system update at the end of februari that caused some problems. It is said that this issue is ‘solved’ by removing the pay-app including clearing all the app-data. Then re-install the app et-presto.

For your phone I think (wild guess) it was working on this system update while your installed netflix. Hence removing the netflix app and its contents from your system and reinstall might solve your issue.

Welcome to the community forum.

Then again, it might not solve the issue, because the issue seems not to be Netflix but the Google SafetyNet. Somebody just tried to install the Netflix App over here …


if netflix is not working then there are some reasons. [Edit by @AnotherElk: Removed Spam link that was inserted here later.]
This might be due to the following reasons-

1- System is not updated
2- Cache should be cleared
3- Try to disable then enable the play store

Nope. @AnotherElk already gave the correct answer above. We’ll have to wait for the next update from Fairphone (long overdue, which makes me kinda worry) …

Same issue Here on new phone. Netflix not working is not acceptable.

Welcome to the community forum.

Consumer tech failing is not acceptable?
Good one. Thanks, we can use some humour these days :wink: .


If I remember well I experienced same thing with another device.

If you check on Netflix website there is an old apk which can be installed.

But be careful to don’t update it otherwise you will experience problems again

A new system update is out that fixes the issue with Google Pay, Netflix and other apps. Just check for updates, it’s a rather small, incremental update.


I solved it by installing an older version of the app. In three steps:

  1. Download older version of Netflix apk-file. I got mine by searching for Netflix on Had to do some scrolling and pressing buttons to find this file:
  2. Install the app “APK installer” from Google Play
  3. Start APK installer app, press Install APK button, check Netflix checkbox, press Install button.

Latest Update for FP3 fixed the SafeteyNet issue, so Netflix can be installed via Play Store again


I still can’t install, or even find the Netflix app, via the play store. When I search for the app via Google Chrome on the web version of the play store, I can find the app, but there is a notification stating my device is not compatible with this version (Je apparaat is niet compatibel met deze versie).

As far as I know my device is updated to the latest version. When I go to settings - system - advanced - systems updates, it says my phone is up to date. Should I update something else?

There is a problem with updates that seems to happen only for people who have a contract with Vodafone or Orange: Has anybody received the latest security update yet?

In this case the updater would show that the phone is up to date when in fact it isn’t.

In the version info for your phone it should show A.0118 and a security patch level of 2020-04-05 if you are really on the most recent version.

1 Like

My security patch level is 5th of February 2020. In the “About phone” section it says I’m on build 8901.2.A.0111.20200131-userdebug. Can I update it manually? My contract is with Dutch provider Tele2 but I’m not sure how that could be related. I bought the phone straight from Fairphone.

With this build you shouldn’t have the SafetyNet issue, it was fixed with A.0111 (it’s the “Fix for Google Pay issue”).

Does the Play Store App display something different when you search there?

I can’t find the Netflix app at all in the play store app :confused: