FP3 lost Google Pay / no longer certified?

The problem has recurred this morning so the fix is certainly temporary, if it works at all. Like others, I submitted an online help form to Fairphone e. However, I have had no respomse so far, and no response on this forum either. Come on Fairphone, where are you?


That works! Thank you

All kudos should go to Chris since it was his idea to clear the cache.

@Chris_R did you get any feedback from support?

Unfortunately for me clearing cache and data did not work at all. I also tried to factory reset as Google help recommended but without success.
I thought that it could be caused by deactivating some pre-installed Google apps but that changed nothing. For now I’m considering some alternatives that do not rely on Google like Garmin pay for example.

Same here. Unfortunately, Google Pay seems to be the only provider which enables me to use PayPal. My bank (Triodos) is not supported by other payment apps / providers.

I think, this is not a Google Pay issue. As stated before, Safeteynet Test fails “CTS Profile match”… This also affects other Apps… Netflix disappeared from the Playstore for me. Pokemon Go should also not be able to run.

This is a major issue imho…

1 Like

Yeah, I get a failed CTS profile match as well. This happened completely out of the blue…

Make sure you’re logging any and all issues with support that way they know the impact and we can hopefully get a swift response


Could be. My initial wild guess was the Let’s Encrypt bug which got uncovered. But that’d explain the reset happening once, and I’m not sure Google uses LE, and I’m not sure the dates add up either.

The response from support

Thank you for contacting us and for supporting Fairphone.

We received seemingly similar customer complaints with this specific issue.
Our Product Team is currently investigating the root of this issue with Google Pay.

To help them solve the issue as fast as possible, if not specified before, we kindly ask you to provide the following details:

  1. In which country are you experiencing this issue?
  2. Which one is your network operator? If you are using two sim cards, please provide both details.
  3. Have you ever unlocked the bootloader?

Everyone affected please make sure to answer Fairphone Support directly in your existing support request, not here. Support won’t dig through this topic or others in the forum.


Thanks - I should have said that lol

Has anyone ever had the bootloader unlocked? I haven’t to my knowledge, but I have had developer options enabled, and may have had usb debugging enabled at one point (but can’t remember), although none are enabled now.

I having same problem, i cant make a payment and either download free apps and i using only my creditcard and get “transfer cant be completed/payment failed” it did worked before at start of Feburary and suddenly it worked against and i paid abit, then again it does ot same problem with payment :upside_down_face: and downloads. I havnt touched any “rooted” stuff when i dont have any knownledge of that kind. But mostly using VPN, but did disabled the vpn app and still nothing working yet. (EDIT): i cant either download new updates :S and i have plenty space enough in my fairphone 3

1 Like

Fix doesn’t work for me it clears the message and won’t let me pay similar to other users reports I have reported to support


Today the problem also persisted for me, even after clearing the app storage. I also heard back from support and sent them my info.

1 Like

Please report to Fairphone support so that they can collect as much information on this issue.

You can do this here https://support.fairphone.com/hc/en-us/articles/115001041206

It may be best to answer these questions as well


My partner has this issue, and he just tried clearing the cache AND uninstalling and reinstalling it. Neither worked. We have reported it to support.


Same issue here. I have reported to support.

1 Like

From support:

“Thank you for your reply and for flagging this issue.
The problem with Google Pay has been identified by our Product Team. They are already working on a new update that will be release as soon as possible and that will solve the issue.”


You beat me to it :stuck_out_tongue:

Was about to post that response haha. Fingers crossed it won’t be long to fix

1 Like