FP3 lost Google Pay / no longer certified?

Hello!
Starting today, my FP3 is no longer able to do Google Pay. It notified me that my device is no longer certified for Google Pay. The corresponding app contains the same message.
Device is not rooted and has latest February update. Reboot did not solve the issue.
Anyone else experiencing the same?
Greetings,
Michael

19 Likes

I have exactly the same problem. Checked Google Play certificatiin, NFC is on, Google Pay as payment app default, and other settings and all seems OK. Seems to be an issue with latest update? Anyone from Fairphone have any info on how to fix this?

2 Likes

I’ve also woken up to this message. I used it to pay yesterday with no problems. Device isn’t rooted and the boot loader isn’t locked

4 Likes

I wonder if this relates to the lastet Paypal/Gpay security issue. I haven’t used Paypal for Gpay, though.

2 Likes

Got the same notification last night. Never a frequent user of gpay but liked to have it as a back up. Disappointed it is gone. Hopefully someone from Fairphone can give us some information. Such a strange thing to experience. Never seen anything like this on any other phone I have ever owned.

1 Like

+1 Same problem here as of this morning.

“Your phone doesn’t meet software standards”

3 Likes

I have reported to Fairphone.

Can I suggest that you all log too? @benfrancis @deanbrickland @mchl-btlr @davidnbull

The more people that report, hopefully the quicker the response

7 Likes

@Chris_R How exactly did you report to them?

Same problem here, I’ve submitted a problem via the form on the website.

Am not sure if I have fixed it or just have a temporary reprieve. I tried force closing and clearing cache but that didn’t work. I updated play store services and play store from APK mirror (not recommended). Didn’t work. Tried force closing and clearing data this time, and for the moment seems to be ok.

Might be a combination of things I’ve done, or just clearing data.

@mchl-btlr https://support.fairphone.com/hc/en-us/articles/115001041206

4 Likes

I have logged the issue through the support form. Let’s hope we get a prompt response.

1 Like

I just cleared the cache and removed all app data, than restarted Google Pay. That solved the problem.

10 Likes

I did what you did, cleared data from Google Pay app and fixed it. Just tried it at a local store and it works now. Strange how that came about. Wonder what caused that issue to begin with?

1 Like

I did not receive any notification and my Google Pay seems to work fine. Probably a temporary hickup.

1 Like

That worked for me as well. Thanks! Hopefully that is a permanent solution.

1 Like

Same for me…

Cleared cache and data and it seems to have solved the problem.

While trying to figure out what happened, i ran the safetynet test app from the play store and it tells me, that the “CTS profile match” failed.

I then tried to add a new credit card and Google Pay tells me that my phone’s Software is modified and can’t use it for nfc payment.

Will try the next payment on saturday with my default payment method and see, what happens.

1 Like

That solution also worked for me. Thanks. I was worried about deleting app storage in case it deleted my stored cards - it didn’t, so all seems now to be OK. I wonder why this has happened - very confusing.

1 Like

I don’t find this amusing:

Any idea why the OS failed on this test of Google’s?

Bootloader is not open (couldn’t do it despite the option available in Dev. opt.).

I just got this message this morning too. Going through the Google help page https://support.google.com/pay/answer/7643995 , it suggests the service manufacturer has accidentally pushed an update that’s stopped this functionality. “If you were previously able to make contactless payments with Google Pay but no longer can, please reach out to your device manufacturer, as there may have been a device software update that is impacting functionality.”.

Welcome to the community forum.

I moved your post here to avoid duplicate topics.
This forum has a search function, by the way :wink: .

Or you can just apply the solution given in this topic here.
(Edit: Seems to be a temporary solution.)

2 Likes