LineageOS 14.1 with OTA updates for FP2

It should install it automaticallly when it reboots. It’s put on a seperate partition (misc if I’m not mistaken)

1 Like

Do I maybe need an external SD-card? When it’s restarting I arrive in the normal TWRP menu… there is no process automatically running…

1 Like

The OTA went smooth without Problems, thanks a lot!
I had / have an external SD Card in my FP2.

1 Like

This time it didn’t work as before. I tried it three times with deleting the older updates before.

Ok, I found the update file in data/data/org.lineageos.updater/app_updates . After I found it, I installed with TWRP. This installing process went without problem. booting took a while afterwards, but now it’s done!

1 Like

I installed the update just now and it worked without problem: once in TWRP the update was called automatically…

1 Like

Your phones are encrypted? My one is. Could it make the difference?

1 Like

Indeed, not encrypted :wink:

I have no encryption yet…

After your big and fruitful efforts of bringing 14.1 to our Fairphones (thank you very much!), will we see 15 on our Fairphones, too?

Haha, I will certainly build a build/update-server, but I can’t do the device development :stuck_out_tongue: maybe someone else will feel up to the challenge!


After downloading the actual LOS download file I can’t find any file at my phone at that place. What is the files name?

It actually puts it on the misc paritition. If the auto-update doesn’t work for you, make sure you followed this step:[quote=“snevas, post:1, topic:29441”]
Flash the TWRP with OTA fix through the fastboot method (made by @z3ntu and awaiting a official build), boot into it and make a backup (backup /data/media separately because TWRP doesn’t do this)

1 Like

Just stumbled about a sensor problem… I have a tasker profile switching the phone to silent when I lay it display down on the table. I realized this doesn’t work any longer… Are all sensors implemented already? Or are there some missing, like positioning?


I don’t know whether the LOS kennel uses stack protection, but maybe an out of order patch might be justified because of CVE-2017-1000251, aka Blueborne… this is a Bluetooth attack on the kennel, with remote (somewhat, due to bt range) exploit… But as a phone might use bt quite often, this might be interesting?


Now I copied the update zip file to the SD card and flashed it via TWRP. Worked flawlessly!
Great thanks to all involved!

1 Like

At my device the sensor works properly: When I lift up the phones upper part and turn it clockwise or anticlockwise, the screen turns as well, staying upright.

Yes, screen rotation does work. But placement of the phone, detection, whether it’s laying on the back or the display, which seems to be a sensor of its own, seems to not exist

Update: my profiles where mixed up after switching to LOS, obviously. It works now, sorry for the confusion

Good morning Ladies and Gentleman,

short question: can and should we use the modem files for 17.09.3?


Good morning :slight_smile:

If you want to give them a go, you can let us know if they have a positive or detrimental effect on your telephony.

If you find issues with these files, then we can investigate, and you can always flash the older modem zip again.

Let us know how they go!

1 Like