Lineage 18.1 - finally official

Ich habe 2 FP2 Geräte. Bei beiden habe ich SIM Karten von Yesss. Den Upgrade auf LOS 18 habe ich bei beiden Geräten genau nach Anleitung durchgeführt. Die SIM Karten waren dabei in den Geräten. Bei beiden FP2 haben nach dem Update die mobilen Daten nicht funktioniert. Die APN Einstellung war bei beiden Geräten auf orange.web. Das wurde offenbar automatisch so ausgewählt. Eine Erklärung dafür kann ich nicht anbieten. Soweit ich weiss gibt es orange gar nicht mehr (wurde von Hutchison 3 übernommen) Yesss gehört zu A1. Ich kann auch nicht sagen, ob es was geändert hätte, wenn man während des Upgrades die SIM- Karten entfernt hätte. Vielleicht ist es ein hilfreicher Tip, darauf hinzuweisen, nach dem Update auf LOS 18 in den Einstellungen die APN zu überprüfen

Dem Betriebssystem sind die meisten APN-Einstellungen bekannt. Dein Problem war wahrscheinlich, dass Du eine alte SIM-Karte von orange hast und das System nicht weiß, dass orange längst zu Drei gehört.

Die sauberste Lösung wäre daher, wenn Drei sämtliche Anfragen an “”, “orange.web”, “orange.mms” und “” umleiten würde. Der Benutzer würde somit nichts davon merken. Aber der Erhalt von Domänen kostet nun mal Geld, und die Telekom-Firmen sind ja so arm!!

Hallo DeepSea Das ist ein netter Erklärungsversuch aber absolut nicht zutreffend. Beide SIM Karten sind ein paar Monate alt und von Yesss. Bei orange war ich niemals. Das System hat, aus welchen Gründen auch immer, die falsche APN Einstellung gewählt.

Anscheinend ist zumindest ein APN von “Yesss” in der (glaube ich) entsprechenden Konfiguration von Lineageos eingetragen, aber warum der bei dir nicht verwendet wird kann ich auch nicht sagen:

1 Like

Naja, ganz so falsch ist meine Erklärung nicht, weil Yesss! früher zu one gehörte, und aus one wurde orange. Um dem Verkauf von orange an Drei zuzustimmen, war die Bedingung der Wettbewerbshüter, dass die seinerzeit zu orange gehörende Marke Yesss! an den Konkurrenten A1 abgetreten wird…

1 Like

Update to 18.1 from 17 on my FP2 went fine and without problems :slight_smile:

  1. Download ZIP to phone
  2. Wipe
  3. Install ZIP
    I had to reinstall some basic apps I use (OSMAND, K9 etc.), but since my phone does not replace my life, no problems on this side (ex. loss of important data).
    Unexpected positive feature: The random boots after charging that I encountered on version 17 have disappeared :-)) Hope it stays like this, since the problem appeared with one of the many updates on 17.
1 Like

Could someone please confirm that Wifi Tethering works now (with build from today)?


I got a connection to my Notebook with WLAN- Hotspot and Bluetooth, but I was not able to activate Bluetooth-Tethering

Wifi Tethering works for me too (with today’s build). Thank you @chrmhoffmann!

I was able to share my FP2’s internet connection via Bluetooth tethering, alas only with Windows 10. I was not able to get a connection with Debian 11, but the problem is probably the configuration of my laptop.

Finally I found a few hours to make the update from 17.1 to 18.1. In my experience setting up all apps is what takes the most time (and I don’t even have many apps installed). However the actual installation process really works without any issues. Thanks @chrmhoffmann for the great manual!
The biggest issue in my update infrastructure was that my Win10 computer (I know I should have used Linux…) didn’t want to detect the phone with fastboot. The solution was to “force install” the universal ADB driver from Google (don’t let Windows find the correct driver but tell it to take this specific one). After the setup everything that I have tried so far just works, that’s amazing.


WiFi Tethering works without issues since the installation of the last weeks’s build.

Anyone has an answer to this?

Or (How) Are you all manually updating apps?

I installed LOS18.1 with Gapps pico today. During set up I added my google account, but would like to remove now. However, I get an error message telling my, that my admin does not allow. Does anyone have any idea how to identify and switch off the admin?

Next 18.1 build should bring back Wireless Display / Miracast. Please report back esp. for people who will use it really (for example does netflix work?).



@chrmhoffmann : Thank you very much for your many years of continued work on Lineage for the FP2! For me, this has been a critical factor to achieve the objective of a phone that stays alive as long as (reasonably) possible and, thus, contribute to a (more) sustainable environment.

Regarding compatibility between LOS 18.1 and TWRP: Does the need to work on this currently lie with Lineage or with TWRP? Both? Or Unspecified?
And could you tell if it’s being actively worked on right now?

(Reason why I’m asking: I’ve used TWRP quite often, for a long time and rather liked it. So I try to estimate how likely it is that it will return…)


If its not coming soon you can still use for back ups #twrpwoflashing

Edit 23Nov21: tried to restore a back-up on another device without success, ended up in a bootloop.

1 Like

Not sure if that is still valid…

My statement? At least I used it to create a back-up

I have no plans to work on this. I don’t know if someone is going to pick it up.


1 Like

Hi, when I try to flash LOS recovery and reboot into recovery I’ll get the Android “no command” screen. When holding power button + pressing volume up at this screen again I’ll end up at Android recovery.

I tried the official procedure and I tried to flash the LOS recovery using TWRP (without flashing it), same result.

I checked sha256 and also tried another build of the LOS recovery, same result.

The Phone currently runs Andoird 7.1.2

I bought the phone second hand and the previous owner said she did a factory reset.

Any hints?