Lineage 18.1 - finally official

Do you directly after installing/flashing the LOS recovery, reboot into the recovery? Booting first into system will overwrite with FP recovery.

1 Like

Yesterday I switched to LineageOS 18.1 for microG and I know this is for the official one without microG, but they share a large amount of code and I hope to get some help :).

@chrmhoffmann Are you aware of any VPN issues with LOS 18.1? With 17.1 I was able to connect from my FP2 to my FRITZ!Box just fine. This is currently NOT working with LOS 18.1. Any ideas or recent fixes that are not yet integrated in the microG version (which is at 2021-09-15 currently)?


I just checked again with LOS 18.1 and GApps pico and for me VPN works with my Fritzbox 7362 SL. As far as I can tell this has always worked with LOS 18.1 (but I don’t use it regularly).

Maybe you could share more info about the setup. Maybe there is something in particular that Singulus is using that is broken.

FRITZ!Box 7590 with latest FRITZ!OS, but I can share a workaround, which fixed the connection problems (in german sorry):

It seems that my carriers APN settings (Telekom) needs to be switched to IPv4 in APN-protocol, they were on hybrid-mode IPv4/IPv6. Any ideas if this “fix” should be integrated into LOS?

1 Like

Yes, I’m sure that I directly booted into recovery after flashing, at least several times.

Any other ideas?

I think I would try to flash TWRP permanent, just to see what happens and/or try last LOS 17.1 build with LOS recovery and then when it works 18.1 afterwards and/or upgrade to FPOS latest Build, therefore you might need to update the updated App first….

It’s not available anymore.

1 Like

Hmmm… I have the LOS build but not the recovery however as its TWRP compatible could be flashed using TWRP

1 Like

Same, I kept about a 17.1 LOS build a month for the last year if someone needs.

Hi, thank you for all the work and the instructions.
It is, however, not quite working for me.
I did flash the lineage recovery as instructed, did the data wipe and installed lineage 18.1 via adb sideload.
There was no error message, but it seems to get stuck upon booting. It reboots into the lineage recovery, telling me to wipe/format my data again, which leads to again getting stuck in booting.
I don’t know what could be the problem, as I don’t get any error messages and the adb sideload tells me that the installation finished.
Tried with and without OpenGApps and with different versions of lineage 18.1, but get always the same result: super long boot and reboot into lineage recovery.

it seems to be a problem with the version of openGapps: 20210929. was reported for multiple devices on reddit.
the installation works with the version 20210925.


Did anyone try to encrypt their FP2? @chrmhoffmann I get the error Cryptfs : Orig filesystem overlaps crypto footer region. Cannot encrypt in place. I found some comments on this in the forum about resizing data partition, but is there any current documentation what are the most recent and correct stepts/values to do this?


@yvmuell you were right. Looks like I didn’t boot into recovery directly after flashing the LOS recovery. I tried again directly after flashing and used power button + vol up to boot into recovery and it worked.
I think I used shell commands before to boot into recovery.

Thank you very much for the hint and sorry for my mistake here. I must say it was not clear to me how to do it correctly, neither after reading LOS installation guide nor after your post. My bad, but maybe it might help others to be more specific in this case :slight_smile:


Which seems to not work as I mentioned in this thread :-/. Any ideas?

Encryption doesn’t work? Ah, the memories :slight_smile:

Did you already format the data partition before any new encryption attempt? If so and it still doesn’t work …

I just successfully encrypted my FP2 once again.

@Singulus I am afraid that you might have wiped data last with very old recovery.

I’d suggest to take latest lineage recovery (NOT TWRP) and wipe and try again.



@chrmhoffmann I indeed wiped with TWRP 3.5.2, which would explain the hassle. At first I tried LOS recovery and hat trouble with it, switched to TWRP and got LOS 18.1 working (it’s not said that it was a problem of LOS recovery here, could also be me ^^). Is there any smooth way to resize the partition without the need for an extra wipe for making encryption work again?


I am not aware - in theory you could maybe shrink the filesystem. But smooth…


I wanted to know whether your system also needs more than half of the internal storage space?