Lineage 18.1 - finally official

No for me its around 6GB, I assume it depends on the Apps and the amount of Apps installed?..or do you have GApps installed and in which Version?

1 Like

Same here, nearly 6GB for System, LineageOS 18.1 and Open GApps pico.

1 Like

I think I would try to flash TWRP permanently. :grinning:

What are you referring to? TWRP is on longer supported on the FP2 with LOS 18.1, so this might lead to issues….

I have open gapps and version pico. I have not installed TWRP.

Old system upgrade images can also take up space in that category. Check under “System Updates” and delete the old ones there.


I only have the latest update, I always delete the old ones after an update.

Joined the 18.1 Party late, after my LOS 17 got too outdated (wanted to switch to FP4 - but I fear this will take some time until I find it in stores). Installed it with all precautions (data wipe etc.). Works like a charm, thanks for all the hard porting and testing work!!!


Also for latest LOS18.1 build the following is still valid, right?

  • usage of LOS-Recovery instead of TWRP for flashing LOS18.1
  • if upgrading from LOS17.1 to LOS18.1 it is neccassary to wipe data (and of course caches)
    still correct? Could anybody tell me in detail, what the consequences could be, if I would not follow this recommendation (especially wiping data e.g. in order to keep all android/app data alive)? So what I should expect with a dirty flash, despite it is not recommended? (I neither have phone decrypt nor use the lock passphrase.)

Thanks. (Until now I could make every upgrade with TWRP and as a dirty flash with my FP2)

TWRP might work, however is still not officially supported and might lead to issues (incl data loss). I recently tried to restore a LOS 18.1 back-up on another device and that did not work. If you never had any Pin etc active to unlock the screen it might work without doing a factory reset in the LOS recovery. You will be stuck in a bootloop when it fails.

I just updated FP2 from LOS17.1 to 18.1. I used LOS-recovery as recommended, but did a dirty flash (=not recommended, but did it since LOS 14.1) without wiping data and doing just wipe cache - of course after making backups of everything and beeing ready to start at zero. I did never used encryption or PIN for screen lock.

Upgrade went fine, until now everything works as usual (I even can’t see any difference between 17.1 and 18.1 at a glance), all settings/apps/data are still intact. I will report back, if I encounter any misbehaviour (just for sake of completeness).
Thanks @chrmhoffmann and sorry that I upgraded the not-recommended way…

From my own tests restoring a TWRP backup is working only with this two-step procedure:

  • Restore the backup
  • Flash the Lineage image

Otherwise if you only do the first step it doesn’t boot :red_circle: :wink:

I did a dirty upgrade from 17.1 to 18.1 with TWRP and it was successful :white_check_mark:
Later I did (two times) an OTA update of 18.1 with TWRP and it failed (the two times!) :red_circle:
After a restore (see above), the same OTA update but with LOS-recovery worked.:white_check_mark:

In any cases a backup is highly recommended :smiley:


Edit: Despite having same problems (graphical glitches) in LOS18.1 I had already in 17.1, during these glitches I now had additionally quite a big bunch of sytem-freezes/unresponsiveness and error messages (“process doesn’t answer: kill or wait?”), quite often from “SystemUI”, but also from the app used in foreground (mostly meteblue, Fronius SolarWeb, K9, tagesschau).

Therefore I decided to make a factory reset (with LOS recovery) and hoped to erases all errors which could come from my non-.recommended dirty flash. Of course my data have -been wiped by this. Flashed latest LOS-18.1-20211203 by updater.

First it looks promising. During reinstall of apps everything went fine. Now, after 1 day of -usage und just installing some basic apps for me - same problems reappear. Graphical glitches, and sometimes (quite rare compared to before) also freezes/unresponsiveness -of the app. I managed it during the last freez to make 2 screenshots (see below) to demonstrate it, and directly after this I pulled a logcat (via adb shell), which I post here.

Do you see any clues what could be wrong? Anybody saw this already? As I could make a screenshot - I doubt it could be some hardware problem (e.g. bad contact pins of display) if it is possible to make a screenshot. What do you think? Worth to report somewhere else?


LogCat via adb shell around time index of above screenshots have been taken and are pasted here.

1 Like

@chrmhoffmann Thank you very much for keeping the FP2 alive!

I switched from LOS16 to LOS18.1.
Started with TWRP 3.2.3, installed latest LOS Recovery via TWRP, Wiped Data, Cache, System from Recovery, Installed LOS18.1 + Pico Gapps, configured System, Encrypt the Phone again.

All fine, thanks a lot!


I also opened an issue in GitLab … maybe there is anything which can be done about. No ideas here? Also posted in XDA…as it is the only show stopper to my nice FP2@LOS18.1 …

Sorry for not having really answered before, but I experience exactly the same issues on 17.1, and a family member as well.
I just live with it now…

Ah, thanks for coming back to this. In FP-OS there is nothing reported like this, only LOS?

That’s also the way for me now - but with this I end up with about 2-3 reboots a day what’s not nice. Also before starting any app there is the “fear” that system will hang for the next minutes - reliability is something else :frowning:

Thanks for also confirm this. But you don’t have any more insight what the root cause could be and if it could improved maybe with doing anything in expert settings? As starting point I would be interessted in which part of the software (driver, LOS, App) it is located and WHO could do ANYTHING about this?
Mostly it happens if somethin is “moving” on the screen (waiting circle in K9, scrolling in tagesschau, flow-aniation in fronius, cloud-animation in meteoblue - but nerly never in just scrolling in Firefox, Conversations or Telegram…). strange…

The screen artifacts, I have seen reported by someone under all OSes on the same device, and it was very present. Don’t quite know what topic it is anymore.
For the freezes, not that I have seen, but it doesn’t mean it doesn’t exist.

Yeah, I know, I get a bit fed up sometimes as well… I don’t have as many reboots (around 1 a day, perhaps more if you count hardware reboots when it falls) and only rare freezes (once or twice a week).

For the freezes: I would guess the RAM is not following perhaps, I’m constantly around 1,5-1,6 GB and I think a lot of things such as browser tab cache get deleted very quickly, and it might be that when you have many things running in background, it doesn’t manage anymore (most of time for me the freezes are preceded by a general slow-down). Perhaps it’s also linked with the number of apps you have (I’m around 250, I should get rid of useless ones, although it might not make a big difference) and the internal storage (I’m at 29,77GB out of 32, probably not enough left, and you?). Perhaps having some task killer like Drowser/Greenify/SuperFreezZ could work? Doubt it, but worth a try.
For the screen artifacts: Mystery… Maybe the firmware? I would have to try with a first gen display to see if there’s a difference, although I’m not expecting any… Will try sometime. For me they appeared at some point, I don’t remember seeing any, 6 months ago. The first time they appeared and I noticed it because I had read of these software glitches on the forum was in Oct 2021 on a small area, according to my screenshot, and now I have some on the whole screen nearly every day. I didn’t change anything to my system at this point I think, except regular updates.
And for the reboots, that’s probably the kernel or the firmware.

Hi, I had the same issue on a “defective” matherboard and I could not get rid of it, cause apparently it was not a software issue.
I changed the matherboard and did not happen to me again.
So I am worried that there is not much you can do

Hm, if it is a hardware defect it would not be nice. I guess you don’t have any idea to really proove it (logs, tests, …)?

Unfortunately my LOS-issue on GitLab was also closed with a small comment that FP or QCom should do something about this, its no LOS issue :-/

And finally I want to share this funny screenshot I recently made after SystemUI crashed, and afterwards all my app-symbols looked black/white-striped … in the main app menu just the apps which I also placed on home screen looks crazy, all other apps not beeing on home screen are still normal. funny funny. For me this doesn’t look as a real hardware thing…does it to you?