Lineage 18.1 - finally official

Hi there, thanks for the work on LineageOS 18.1!

I upgraded from 17.1 following the instructions. First thing I noticed was that battery life seems to be shorter than it used to be. The phone works okay but later on I noticed that auto-screenrotation is not functioning. The Fairphone Proximity Sensor Tool hangs when I try to calibrate the phone. The app ‘CPU info’ gives no information about any sensors, so the problem seems to be that the OS does not connect to the sensors. Any ideas how I can fix this?

Nun habe ich seit 10 Tagen LOS 18 Apps funktionieren alle wie gewohnt. Was mich etwas nervt, ist der ständige Ausfall des mobilen Datennetzes. Damit es wieder geht, muss ich einen Neustart machen. Allerdings fällt es nach kurzer Zeit wieder aus. Wenn ich also nicht im W-lan bin, muss ich das FP2 neu starten um zu sehen ob was Neues gekommen ist. Ich kann nur hoffen dass sich das mit weiteren Updates wieder gibt. Dieses Problem hatte ich bisher mit keinem vorangegangenen Betriebssystem.

Upgrading went like a breeze and LOS18.1 runs quite nicely so far. Great thanks to @chrmhoffmann and everyone else involved into this. You are awsome!

Only thing not working is the filtering mode in Netguard. If it’s enabled, all traffic is blocked. Can anyone confirm that?

Netguard was fixed recently. Hmmmmm… I can see if we miss something in 18.1 kernel that was added in 17.1


Netguard actually works fine here on fp2.

Have you:
Installed with lineage recovery?
Wiped data during upgrade?


I use CPUZ and I can see the sensors.

Have you:

  • installed with lineage recovery
  • wiped?


Hello Chris,

I installed CPUZ, but then also no sensor values. And yes, I installed through Lineage recovery with data wiped.
Satstat also shows no sensor values. GPS is working though and much faster than it has ever been on my Fairphone.

Yes and yes.

Blocking or allowing internet access via Netguard works fine for me. Only when I start filtering the traffic for using the adblock function problems occur. Then no traffic comes through at all.
Have you set any special options like VPN-DNS which I might be missing?

Hi, i have only tried the basic block/unblock of apps in netguard. Not the advanced stuff.


Isn’t it rather a problem on Netguard’s side? I remember having noticed the same problem under FPOOS very recently.

I have the same problem since LineageOS 16 on the Fairphone. On my Oneplus3 it all work fine.

FYI, LineageOS for microG seems to be available now, too:


I actually don’t think so. On stock android it worked with the FP2. I have done some research about this behaviour and it seems that it is a known lineage issue.
See question 51 in the Netguard FAQ:

Same observation here in the XDA forum:

I finally had some time to back up my apps and to upgrade with clean data partition. I was finally able to properly encrypt my phone and the UI feels really responsive. :grinning:

I noticed that the WiFi hotspot does not work with the current image. The problem has already been reported (Wifi hotspot not working after update to 18.1 6th August (#3822) · Issues · LineageOS / issues / android · GitLab). Unfortunately I don’t own any other device which can run 18.1, hence I cannot test if it is a general LOS 18.1 issue or if only the FP2 is affected.

Did you delete the respective WLAN and add it again?

Did a fresh install with lineage-recovery. Had no problems with the installation and it is already running for 2 weeks without any major problem.

Like @Zebrafax had a problem with my SD-Card at the beginning. I formated the SD-Card as a unified storage. But the problem didn’t happen again, so not a problem anymore.

Unfortunately I backed up apps (with data) with OAndBackupX instead of using the internal Seedvault. Cause I had some probs with some apps, but after some tinkering it’s running now without any showstopper.

Thank you @chrmhoffmann again for your work to keep this beautiful and fair piece of technology going. :slight_smile:


Das Problem mit den mobilen Daten hat sich erledigt. Die APN Einstellung war falsch. nun läuft alles zu meiner Zufriedenheit

1 Like

Welcher Anbieter und wie sind die neuen APN?


I found the wifi hotspot issue. Will get fixed in next build.



Many thanks @chrmhoffmann, everything here is working fine :partying_face:

I have one question though which might be a feature request :wink:

Can I install Magisk in a way that it is preserved when upgrading lineageos? Currently I would have to reinstall it every week :crying_cat_face:
(With lineageos 17 I had the same problem already, but there I used TWRP which apparently ignored / did not find the “survival” script installed by magisk.)

Alternatively, I do not need magisk itself but would be happy if there is another way than root-via-magisk to get the f-droid privileged extension (permanently) installed? I really like to have automatic fdroid updates.

Maybe it matters for this that my phone is encrypted?

(Apologies if this belongs to another thread, but I only saw microG related stuff which I am not asking about.)