Latest update broke multitasking pane

After the latest update, whenever I use a widget or a notification to open an activity from any app, the multitasking pane gets broken. It scrolls all the way to the left and can’t be moved. The gesture to quickly switch apps also stops working. Only restart helps.
Example: I have a widget to quickly access my lights in a room with a Home app. I click it, my activity with bulb controls launches, then when I want to switch app it doesn’t work…

Edit: I just want to see if anyone else has the same problem before I file a support issue.

Edit2: Here is a screen recording of the issue: Ente Photos

Edit3: I can confirm that the issue is not present with Fairphone launcher (Quickstep)

6 Likes

I’m having the same issue, but only while using Nova Launcher, which is kind of annoying.

1 Like

I’m using the latest update and Nova Launcher - no issues, everything works as it should.

I see, I am using Lawnchair, I will try to check with the original launcher.

1 Like

Fixing by delete cache of QuickStep (is app for stock launcher and app card switcher)

Edit: before ok with stock, problem with Nova

Are you saying that deleting cache for QuickStep fixes this launcher only or it does fix it with other launchers as well?

I fully understand your problem, @fairtony, especially after watching the comprehensive video.

However, I cannot at all reproduce it. I have a FP5 with the latest Update installed, I use Lawnchair and on my phone, the problem does not occur. I cannot enforce it to occur in any way. I can open various apps by tapping on their widges or notifications. Both the multitasking bar and the gesture still work. :thinking:

I wonder what makes the difference…

@fairtony
i use NovaLauncher and with it have similar problem as you
(when try switch via card, auto moved from last to first, or all is gray back not show card)

so i try change to stock Launcher, with it i not have any problem…

then i change back to Nova, delete cache for QuckStep (and i think also force close it) and with Nova problem is gone

Ok that is strange. Might be something cached somewhere. Dunno :frowning: I switched to QuickStep for time being but its very poor launcher. I will probably file support issue tonight.
Is it possible that your QuickStep is not up to date?

I can confirm this fixes the issue, but only until any activity is opened from widget/notification again.

I did get the issue again and this time I tried only to “force stop” QuickStep and it fixed the issue again, but seems not completely, but its much more usable. (basically the pane is ok and only the quick app change does weird thing when used on the home screen)… so maybe the cache cleaning and launcher switching is not needed, maybe the QuickStep launcher just start interfering with our launcher and by force stopping it it gets fixed (temporarily).

I do not use QuickStep, @fairtony. As I mentioned earlier above, I use Lawnchair, and yes, the version is up to date. You also mentioned above that you actually use Lawnchair. That’s why I decided that I, with an FP5, latest Update + Lawnchair, cannot reproduce these issues.

Sure, I understand that, I was just asking because with k3dAR we discovered that even if we do not use QuickStep, the app is somehow interfering with our launcher.
Anyway, thanks for the reply :slight_smile:

Yep, also have that issue with nova launcher (latest beta) , switching to quickstep seems to solve it.
Will write a ticket later today, hopefully nothing major

1 Like

not sure what you mean “open activity from widget/notification”

but after delete cache of QuickStep i try from notification

  • open AccuBattery and AFWall
  • open “update avaiable” message from GooglePlay
  • open Bluetooth settings from Bluetooth Tile
  • open some apps (from Nova Launcher Docks and Apps)

and still now not problem as before :slight_smile:

about “interfering” of QuickStep, this as i write above,
because QuickStep is not only stock launcher, bul contains “Card Switcher”
aka “Recents Apps” via com.android.quickstep.RecentsActivity,
so this part of QuickStep is what you see if activated as you write “multitasking pane” :slight_smile:

you try this?

Yep, I cleared cache and force stopped, it is still bugged for me.

I think quickstep somehow thinks that nova laucher is a regular app that should be shown in the overview, but at the same time some other part of it disagrees so it ends up with an invalid app in the overview stack that breaks everything. Would explain some of the weird behaviour I’m getting

I’m experiencing the same with Lawnchair. Emptying the cache didn’t help.
Edit: I’ve reinstalled Lawnchair, same issue. When moving back to Quickstep it started fine, but now also shows the grey background only, but no apps.

I have the same problem on my FP5, using Kvaesitso, Niagara and Nova as launchers. The recents screen is bugged and only shows grey, switching between apps using the left an right swipe gestures does not work and it jumps to the far left when opened from the homescreen.

The issues are not present for a short period of time after clearing the cache from Quickstep til I go to my homescreen again, when using Quickstep as my launcher or when using button navigation instead of gestures. So I’d suspect it’s also the gesture navigation being broken in some way.

1 Like

Can confirm, same problems when using the gesture navigation. Clearing cache of Quickstep didn’t help, but also clearing all data worked for me.

I am also experiencing this with nova launcher :melting_face: