English

🇩🇪 Kein WLAN nach update

Tags: #<Tag:0x00007f05d8b26dc8> #<Tag:0x00007f05d8b26c60>

Ich glaube eine Lösung gefunden zu haben. Ich hatte das gleiche Problem, wie alle, die vor mir hier geschrieben haben. Ich habe einen neuen Router von der Telekom gekriegt (Speedport Smart 3) und mit dem konnte sich mein Fairphone 2 nicht verbinden. Wenn ich auf “verbinden” gedrückt hab, ist einfach nichts passiert.
Aber jetzt funktioniert es!
Ich habe in den Einstellungen des Routers etwas geändert. In meinem Fall habe ich den Speedport über einen Laptop angesteuert (einfach “speedport.ip” in einem Browser eingeben). Dann ist es wichtig, unter “Einstellungen” - “Ansicht” den “Expertenmodus” einzuschalten, damit wirklich alle Einstellungen vorgenommen werden können. Unter “Netzwerk” habe ich dann zunächst den Namen der 5-GHz-Frequenz geändert, so dass sie sich von der 2,4-GHz unterscheidet (sicherheitshalber ohne Sonderzeichen, weil das ja evtl. Probleme verursachen könnte). Das alleine hat aber noch nichts bewirkt. Die folgenden zwei Schritte haben den Ausschlag gegeben:

  1. Ich habe bei “Verschlüsselungsart” statt nur “WPA2” jetzt “WPA / WPA2” angeklickt;
  2. Ich habe bei “Sendeeinstellungen” - “Übertragungsmodus” im 2,4-GHz-Frequenzband “802.11b+802.11g+802.11n” ausgewählt.
    Dann hat es plötzlich funktioniert!
    Mein Fairphone verbindet sich jetzt mit dem 2,4-GHz-WLAN und wird vom Router auch als WLAN-Gerät erkannt.
2 Likes

Hier habe ich auch schon was geschrieben:

WPA2 habe ich aus Sicherheitsüberlegungen belassen und es funktioniert trotzdem.
Bei 5Ghz habe ich noch den Verdacht, das die hohen Frequenzen/Kanäle vom FP2 nicht unterstützt werden. Das konnte ich aber noch nie sicher klären.
(In der Fritzbox kann man diese separat ein oder ausschalten; vgl https://de.m.wikipedia.org/wiki/Dynamic_Frequency_Selection)

Dosc

Ja, ich habe alles versucht, auch auf Werkeinstellung zurückgesetzt. Habe das gleiche Problem schon seit 1 1/2 Jahren. Alle zwei Minuten muss ich auf Flugmodus schalten und neu um Verbindung “bitten”. Zum K…! Es nervt entsetzlich.

Dann würde ich einen “manuellen downgrade” empfehlen (oder ein alternatives System wie z.B. LineageOS, /e/, …).

Hallo, Volker, danke für die Antwort. LineageOS werde ich wahrscheinlich installieren. Aber wie geht ein “manuelles downgrade”???

Siehe z.B. hier:

oder du kannst mal schauen, ob du #fairphoneangels in der Nähe hast, die können evtl. bei Bedarf helfen.

1 Like

Hallo, Volker, mein Schwiegersohn hat mir LineageOS installiert, jetzt läuft alles super.
Liebe Grüße und nochmals Danke!

2 Likes

Auch hier der Link zu dem was ich im neusten Post geschrieben hab:

Das ist doch ein Hit, dass man die Verschlüsselung abschwächen müsste, um ein FP2 sauber ins WLAN zu bekommen. Jeder Plastik-Taschenrechner von vor 10 Jahren kann WPA2 :scream:!

Wurde das aktuelle LinageOS installiert? Damit habe ich die gleichen geschilderten WLAN Probleme :frowning_face:

Hallo, es ist Android 9 llama. Ich glaube, es gibt noch eine neuere Version, einige Tage neuer, aber das wollte mein FP2 nicht annehmen. Wenn du genaueres wissen willst, müsste ich meinen Schwiegersohn fragen. Liebe Grüße!

Pie :wink: .
Ab Android 10 (“Q”) gibt es zum Glück keine Namen mehr, nur noch Nummern.

Die Versionen seit 20190824 sind kaputt und booten nicht, die Behebung des Problems ist in Arbeit.

Sind die aktuellen #modemfiles installiert?
Bei Fairphone OS und Fairphone Open OS sind die bei Updates immer dabei gewesen, bei LineageOS muss man sich selbst darum kümmern, es sei denn, man kommt von einem aktuellen Fairphone OS oder Fairphone Open OS zu LineageOS.

1 Like

Im englischsprachigen Forum, siehe Link, habe ich folgenden Tip gefunden:
https://bugtracker.fairphone.com/project/fairphone-android-7/issue/276

suggestion to set the Wifi connection to g or b or g+b but not to “n” " Thanx! g+b worked for me too.

Daraufhin habe ich meinen WLAN-Standard geändert zu 802.12b+g
Seitdem komme ich wieder ins WLAN.

5 Likes

Schade, sogar ich fand die Namen immer ganz witzig. Aber das Bewusstsein für zu hohen Zuckerkonsum scheint zu wachsen…:grin:

@Singulus

Nun, es hat ja auf dem FP2 auch mal richtig funktioniert mit Lollipop & Marshmallow. Aber Nougat wird weder von Google noch von Qualcomm offiziell mit Treibern zum 801 Chipsatz unterstützt. Somit muss Fairphone auch noch diesen Treiber Teil selbst programmieren. Daher die vielen bestehenden Probleme.

Hm, kann ich nicht bestätigen. Funzt mit meiner Fritzbox reibungslos. Beide Netze haben die selbe SSID genau das war mein Wunsch. Bin aber noch auf Marshmallow.
Hin- und her schalten kann ich mir nur vorstellen wenn kein Netz eine stabile Verbindung aufbaut. Aber dann ist evtl. das Signal des Routers zu schwach und reißt immer wieder ab oder zu viele Nutzer auf einem Kanal.
Ich ziehe lieber das 5GHz Band vor, da ist noch reichlich Platz und die Reichweite sollte je nach Bausubstanz ausreichen. Meistens muss ich meine Signalstärke etwas drosseln (was andere Nachbarn auch gerne tun dürfen, sofern sie überhaupt wüssten wozu das gut sein soll).

Es ist demnach anzunehmen, das Dein FP2 sich nun nur noch mit WPA Verschlüsselung verbindet.

1 Like

Wow, danke, das hat auch hier geholfen :slight_smile: