Issues with the forum

Must be :joy:

I renamed my test account to @Alex.A (Edit: I had originally written @alexba), and have an identical problem… Can’t understand.

Help… What’s happening in this forum, it must be haunted.
Edit: It seems that when changing the usernames, the forum considers alexba and Alex.A as identical, and renames alexba to Alex.A

No, I got it wrong!

I’ll open a topic on Discourse meta one day if I have time.

This still doesn’t happen for me. Usernames getting distinguished totally fine.
Windows 10 Pro 21H1, Firefox 88.0.1, Vivaldi 3.8.2259.42, Edge 91.0.864.37

You can’t see the same as me?
image

Debian 10.9; Firefox 78.10.0esr (64-bit), Chromium Version 90.0.4430.212 (Developer Build)

I meant they get changed in the posts.

Well, I see that, too, and that’s messed up, but I don’t know whether that’s the same issue.
The user profile links still lead to the correct user profiles for me.

Test … @alexka , @Alex.A … screenshot …

Does that display differently for you?

Links lead to

https://forum.fairphone.com/u/alexka

https://forum.fairphone.com/u/alex.a

1 Like

I found this here …

https://meta.discourse.org/t/incorrect-canonical-url-for-user-profile-page/190847

… but this still doesn’t explain how something would get from alexka to alex.a.

Quoting the user names still works for me, too. Screenshot …

Since you tried with different computers and (browser?) safe mode … must be your account. Don’t ask me how :slight_smile: .

2 Likes

Works fine for me on Firefox ESR Raspberry Pi Buster. Each goes to the correct profile.

Could it be a cache issue that cuts the search short and you get the same. I note it is also case insensitive
https://forum.fairphone.com/u/Alexka
https://forum.fairphone.com/u/alexka

https://forum.fairphone.com/u/Alex.a
https://forum.fairphone.com/u/alex.a
https://forum.fairphone.com/u/AleX.A

what about
https://forum.fairphone.com/u/alexa
or
https://forum.fairphone.com/u/alex

1 Like

I have been trying to change my username from @Alex.A to @Alex.At, and then back. But when changing usernames, the forum now also takes care to change it in the posts. So it changed in all posts it found mentions of @alexka to @Alex.A. So this is explanable, and related to the same issue.

I have posted on Meta: https://meta.discourse.org/t/incorrect-canonical-url-for-user-profile-page/190847/6?u=alex21 Now here: Problem with periods in usernames - bug - Discourse Meta

Edit: Typo
Edit2: Added new link

3 Likes

I guess, that most likely it’s the “.” (dot), causing this trouble?
Maybe change to “Alex_A”?

There are quite a few users named “Bert…” (Bert, berta, BertM, bertl, Bert69) in this forum but clicking on their names always takes me to their profiles. No mixup with my name whatsoever.

3 Likes

I see no problem clicking names in Firefox on FP2 Android 9, apart from the ones modified by the forum software they point to the correct place.

Edit: just see on the Meta post that only Alex himself sees the problem with the dot :flushed:

3 Likes

Problem should be solved by the next update:

6 Likes

The forum does not offer a PWA to be downloaded, although this feature should work out of the box:

Other Discourse Meta forums do not have this issue…

What happens if you try it in Safe Mode with all options disabled:
https://forum.fairphone.com/safe-mode

Seems my trust level is too low to open the link:

Oops! That page doesn’t exist or is private.

FYI, I did a fresh setup of Google Chrome. It works in the Discourse forum, but not here…

I think the issue referred to by @UPPERCASE as linked to above maybe beyond the scope of the administrators of the forum, so have advised contact with the ‘discourse’ admin.

https://forum.fairphone.com/safe-mode

Should work for anyone, even when logged out or in incognito mode. Try refreshing the page.

That would be me. FYI: the original poster already contacted me via our ticketing system, where I advised him to loop back to the forum thread he had already started.

Thanks for the quick response I hadn’t imagine you’d be following this topic. Brilliant let’s hope things work.

I can use the safe mode. Is there a guide as to how to install the forum as an APP?

1 Like

Refreshing the page directed me to safe mode, thanks, but there it does not work either.

This is how it looks on the Discourse Meta forum:

grafik

1 Like
  • We’re running a recent version of Discourse so I don’t think that’s the cause
  • If PWA doesn’t work in Safe Mode then it’s obviously not related to installed plugins or our custom stylesheet

I have no clue what else might be causing this.

2 Likes