English

Installing from scratch is not scratchy enough

Hey! :slight_smile:
After upgrading to Android 9 I got a couple more erros to the ones I’ve already had for over half a year now (the phone thinks it doesn’t have any sensors anymore), so I went and wiped it completely to reinstall LOS15 (Android 8), since e.g. LOS16 doesn’t have XPosed at the moment.

Fast forward, backup and everything is in place, but the stupid errors are still there:


I have no idea why this is still the case, here is a list of what I’ve already tried:

  • install back and forth between LOS and OpenOS multiple times
  • wipe every partition with TWRP multiple times
  • flash modem.zip multiple times times

To be honest, I don’t have any ideas left. Is there any way to completely wipe absolutely everything (including bootloader, fastboot, recovery, etc., really every single bit of storage) from the phone and start as if it has never been touched by anybody since production?
If so, please tell me, if not, I really hope that this is not the end of my FP’s journey, but I am clueless at the moment.

Thanks
Clemens

See here whether you missed something …

Already tried it. Like I said, I wiped and formatted the hell out of the phone via TWRP…

You didn’t say formatted, wiping is not formatting :wink: .

I honestly have no idea why sensors would work in one OS and no sensors at all in the other OS.
Back in my Fairphone Open OS or LineageOS 14.1 days (don’t know anymore) I remember SatStat wouldn’t get a location for me even though it had permission, but the other sensors showed up … hmmm.

Can you try to install Sensors via Yalp or Aurora?

No, you misunderstood it. It doesn’t work in OpenOS either.
But I’ll try Sensors, atm I have OpenOS 19.5., give me a sec…

Ah, sorry. Makes more sense this way :slight_smile: .

In my guide I just wrote to format the data partition for relative simplicity’s sake.
Of course you can format any other partition, too, instead of just wiping them … the system partition would come to mind:

In TWRP … Wipe - Advanced Wipe - (choose partition) - Repair or Change File System - Change File System - EXT4


That’s the sensor overview. However, there are no values displayed when I tap on a specific sensor.
(e.g.
x-axis - - - y-axis - - - z-axis
i suppose this is the reserved space vor values
m/s^3 - - - m/s^3 - - - m/s^3)

Consistent little critters :slight_smile:

Did you always flash the same modem.zip, or did you try different versions?
Older ones are still here … https://io.pinterjann.is/public/misc/fairphone/modem/.
Newer ones are here … https://github.com/WeAreFairphone/modem_zip_generator/releases.

Nope… Still doesn’t work.

If it was me, I would throw UBports at it now to see what a non-Android would have to say to this … https://devices.ubuntu-touch.io/device/FP2 (manual installation recommended).

1 Like

I guess after these problems you do not wanna go back. However, there is edxposed for android 9 (lineage 16) and above: https://forum.xda-developers.com/xposed/android-9-0-xposed-solutions-t3889513

1 Like

@sn0b


I already tried this method, but apart from it not being official or open source, I don’t like Magisk, since it takes control over root priviledge management, which messes some stuff up (e.g. Yalp wasn’t able to use the root install method anymore), so I deleted it again.

@AnotherElk I haven’t hat that much time (or motivation) during the week, but I’ll try to get UBports on it today or tomorrow to see how it behaves. (Btw, where can I download the files manually when the installer is so broken?)

The manual installation instructions along with the download links for all the files are on https://devices.ubuntu-touch.io/device/FP2

You could try the installer first, though. I had lots of trouble with earlier versions, but the newer ones almost always worked for me (when the same versions failed for others). But I wouldn’t invest more than 2 or 3 tries with the installer.

1 Like

Well, the manual installation requires me to run a couple of these commands wget http://cdimage.ubports.com/devices/recovery-FP2.img -O recovery.img && echo "534cc2da2add4a2bd8136b01069ed7dbe432076659fd4780910b6910b916f77b recovery.img" | sha256sum -c, which I can’t do that easily (at least I don’t really know how). But I’ll try the Installer :slight_smile:

Basically, instead of pasting that command here into the forum, paste it into a terminal and that’s it :wink:

I searched a bit, and here’s an introduction to the command line, which I think should work well (it’s part of a wider programming tutorial, so just concentrate on this command line part) …

https://tutorial.djangogirls.org/en/intro_to_command_line/

@Ingo I am not that stupid, it didn’t work.
Der Befehl "wget" ist entweder falsch geschrieben oder konnte nicht gefunden werden.
I hate the Windows command line. Maybe I’ll try it with Linux later, I hope that I have enough time in summer to ditch Windows completely (at least as much as possible).

4 posts were merged into an existing topic: State of the UBports installer, or command line

Paise @AnotherElk, my Lord and Savior!
Today I finally had the motivation* to try this out. (*= I had to get it done until saturday because I need the phone by then)
After procrastinating studying for my biology exam I have in two days (:man_facepalming:), I tried everything, and after a successful install of UBports using the Linux installer (the Windows version didn’t recognise the phone in fastboot mode), installing TWRP and not being able to transfer the files because neither MTP nor ADB sideload worked, a couple of failed attempts to install UBports via Linux again I remembered that I could install OpenOS via fastboot, which is what I did and *tadaa*, the screen rotates. Currently, LOS 15 is booting and I hope this works too.

My mental health is completely destroyed and my sanity gone, but hey, at least I have a working phone again. After 7 months.
Tomorrow I’m going to put my data on it again. Hopefully.

Edit from tomorrow: It refused to boot yesterday, but today I wiped the storage and flashed LOS15 again and it finally worked! :smiley:


I haven’t finished setting it up completely (Xprivacy is going to take a while), but so far everything runs :slight_smile:

1 Like

FWIW, you can get GNU Wget to work via Cygwin or WSL(2).