Accelerometer/Tilt sensor broken

For that issue, please refer to:

In the last month, I installed LineageOS and whilst I did that I also wiped the internal storage (I don’t remember exactly which partitions, but I think everything except the MicroSD card) and even re-formatted it and the sensors still don’t work.
And for a couple of days now the standard Download manager also doesn’t work (meaning I can only download anything via apps that handle downloads externally).

I don’t know what to do, and while I still can use my phone, functionality is pretty limited…

If it was me, I would reflash the #modemfiles. This can be done at any time without breaking anything.

If that fails to help I would install Fairphone Open OS from scratch to see whether the sensor failure is an OS thing.

And if the sensor failure is there in Fairphone Open OS, too, I would consider hardware failure.

I just flashed, but it didn’t help.

The problem appeared after I updated from 18.04 OpenOS to the Nougat beta (I don’t remember which exact version, 18.10.something), so it also happened on OpenOS (I reverted to the official version in January, which also didn’t help).
I can’t imagine a software update causing a hardware failure, so it has to be some missing drivers or something I guess…

I’ve been experiencing the same problem for a few days. Tried everything I could think of : re-flashing modem zip, new Lineage clean install (I’ve been running Lineage for quite a while), other roms like /e/ and FPOOS. Whatever I do, it doesn’t work and Satstat says my accelerometer is non existent…
I also took the phone apart and cleaned all modules and connectors. Still no accelerometer.
It really seems hardware related, which has got me slightly pissed as I’ve been a happy FP2 user for 3 1/2 years and wasn’t intending to change for quite a while.
I’ve filed a support request.
Does anybody have an idea, or should I try and find a second hand core module?

Hey @tomgey :slight_smile:
Fortunately, I was able to solve the issue a little more than a week ago. Have a look here:

(TL;DR: Try installing Ubuntu Touch via Linux since the installer doesn’t work on Windows)

Hi @Stanzi !
Thanks a lot for the advice. I hadn’t come across that topic during my search in the forum.
Will try this afternoon and tell you wether it worked.

1 Like

Well can’t install UBports via Windows either.
I don’t run Ubuntu on my PC.
Is there another way, like flashing via TWRP?

I tried a complete format of the internal storage, which I hadn’t done until now, and a (very) clean install of lineage, but still no accelerometer…

It’s a bit hidden on the website, but there’s a link to manual installation instructions to be found on this page here …

Thanks @AnotherElk.
Not easy, though…
Haven’t they thought of a flashable image through TWRP? So easy…

Finally managed to install Ubuntu. The manual procedure didn’t work (couldn’t find the commandfile in the folder), so tried the installer again and it worked immediately, probably thanks to all the drivers I had installed for the manual procedure.
Anyway, still no accelerometer with Ubuntu…
Have reverted back to my lineage 16 backup with the same prolem. Really think it’s hardware related on my phone.
Got to think about my next move now…
Thanks for all the advice!

OK, so got a very quick answer from support offering to replace my core module with a new one for 223€. Slightly expensive in my view…
My contact at support also suggested contacting a Fairphone Angel locally. Despite the fact I don’t think there is one near where I live, I don’t think she/he would be able to do much more than I already have (no offense!).
My best option is probably to keep an eye open for a second hand Fairphone. For roughly the same price as the new core module, I’d also get a few more pieces just in case…
The other easy move would be to consider buying a non Fairphone device, but that would mean all I’ve done with my partner these past years (trying to reduce waste in the household and paying real attention to what we buy and the impact it has, not easy with three children!) would have been for nought if we step out of the path as soon as it becomes slightly difficult. Have to be a bit more imaginative than that!
Any other ideas?

1 Like

Glad the installer worked afterall.
For anybody else stumbling upon this … please read the instructions thoroughly … you will have to create the commandfile yourself, else it will not be there.

I did create the commandfile and put it in the right folder, but the installer (well, when I typed the command lines) never found it. I checked it was the right format (.txt). Must have got it wrong somewhere, but can’t figure where!

Ah, my bad then.
Would have been interesting where it went wrong, they really change the instructions if you can give them explanations for improvement.

If nothing helps, buy a normal second hand phone. It’s way better than buying a new one :slight_smile:

Yup! Totally agree, this is why I posted this today Looking for a FP2 core module or an entire phone :wink:
The idea being : second hand Fairphone/parts > new Fairphone/parts > second hand non Fairphone > new non Fairphone.

It’s better to switch no. 2 and 3 I think

That’s a debate I had recently with one of my friends.
We finally agreed that everything we buy (well, nearly) had an impact (political, environmental, social…) , which can’t be discarded when bought second hand.
That is, if you buy non fair stuff on the grounds that it doesn’t matter as it’ already been produced, you’re comforting the people who bought it in the first place in thinking they can buy whatever they want because they’ll eventually manage to sell it second hand.
If we want things to change, the value of non fair stuff has to drop, and one of the ways of achieving this is not buying it, even second hand.
That is why I put it in that order, but I agree it’s a matter of debate especially from a ressource consuming point of view.
And of course I’m far from perfect in my day to day life :wink:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.