Install /e/ on a Fairphone FP4 - “FP4” (beta)

In vanilla FPOS it’s called MMITest. It should show up under Settings → Apps if Show System is active (or check it with adb shell pm list packages mmi).

If it’s there you can trigger it with

$ adb shell am start-activity -n

Edit: I checked the /e/ images, it’s not included.

I had same problem. I tried with diffferent cables, with no luck. I also try to force reinstall of the driver from the devices manager. No luck either.
I finally solved the problem with a simple “windows update”. But I had to go in “the optionnal updates” part. There I found updates waiting for Android.


1 Like

Yep, that’s the most frequent issue on Windows
You have to install ADB & fastboot drivers in the Windows Update section “Optional updates”
I remember they detailed the procedure for FP3 afaik, but nothing for the FP4

That’s it with W11, if it can help someone:

:warning: For the last one, you can check only the ones that are related with ADB (Android Debug Bridge) and fastboot :warning:
However, I advise you to do all the updates, these are frequently drivers updates

1 Like

Also, I have found quite a few bugs on /e/OS:

  • All the given apps that are not up-to-date (that’s a /e/OS classic, but fortunately we can have them on F-droid, and uninstall the stock ones with root and Package Manager)
  • Discord is crashing VERY often, but still usable if you have the courage to force-close it every 5-10 minutes x) - No solution found
  • Aegis is literally not working, after the setup it crashes, and when re-opened it restarts the setup, and re-crash…
    An alternative solution is andOTP (with no biometrics support :confused:), but you have to:
    • export your 2FA codes in a plain text file (not Aegis .json file) before going to /e/OS (not very secure)
    • or have Aegis (and your 2FA codes) on another device and just scan all the QR codes with andOTP on your /e/OS FP4
      (for any help, feel free to ask me :wink:)

Apart that, everything seems to work well for me, with Lawnchair 2 (got it from Aurora store, cause the stock launcher is horrible) and Magisk root (I’ll make a wiki on how to do it in a few days :wink:)


That’s probably due to a known bug of not enough allocated memory (maybe the same for Discord):

AFAIK it’ll be fixed in the next update.


Cannot confirm all these issues in iode…
But yes, you’re right, had the same problems before on my FP4 with /e/OS

I’ll add that the workaround from that link has fixed the issue with Discord (and Newpipe, for what it’s worth) crashing for me.


Do you know if Aegis is working on iodé ?

Yes it is. There’ s enough memory
Thy didn’t do the mistake like the /e/OS guys with the jvm heapsize

I’ve got everything in place now, but got stuck with the backup options. Found this thread stating that TWRP misses user data and this wiki and now I’m confused and would appreciate a hint into the right direction.
I can live with backing up my files manually, but would like to back up system settings and app settings to recover my FP4 to the state it is right now.
Is adb the way to go?

@Alex.A Is the wiki only for FP2 or also FP3? As its the second time someone stumbles over it, we should maybe add that its not for FP4, because

@OvO I think in the above its already clarified at least that the wiki doe not work and data can def not be backed up using TWRP

Edit: @OvO reg ADB backup you might want to read this thread

So TWRP and ADB are not sufficient to restore to the current state.
Are there no reliable alternatives? Is there a best practice - e.g. to backup system settings via TWRP and then to recover App settings and Data manually?

TWRP misses the internal storage (/data/media) in the phone whatever the device. My hack allows to integrate internal storage in TWRP data backups.
But currently TWRP can’t decrypt at all the data partition of the FP4 (i.e /data), so there is nothing my guide will change to that. Using adb won’t be enough, you will only be able to save the internal storage manually (/data/media/0), and copying /data from a switched on phone with adb is a bad idea (and very probably won’t work).
Currently, no backup of the whole device such as TWRP does is possible on the FP4. Apps such as Titanium will work with root for backing up apps, and to use adb backup is a bad idea IMO, as it’s deprecated.
Hope it clarifies.

System settings are on the data partition, as all the user data.


Thank you for helping me out here - there’s a lot of new stuff to wrap my head around coming from the fruit of convenience…
So there is no reliable way (without root) to backup and restore system settings running /e/ on a FP4 at the moment? I can only document and restore everything manually as long as TWRP doesn’t support decrypting the data partition?
Is there something in the pipeline I can be looking out for?

AFAIK, indeed.

The TWRP topic I guess, to check for updates when it’ll support decryption.

NO it isn’t

Therefore you have to ask the /e/ developers.

I would add, be sure you actually want to switch to /e/, as it is a one way street for now:

It should be possible to get back to vanilla FPOS with properly backed up partitions, but so far no one has tried…

1 Like

there’s no way back, but there’s a way sideways to iodé (:

I did and if I may share the response:

We have several things in the pipe regarding backups and we hope to be able to roll out something later this year.