Install /e/ on a Fairphone FP4 - “FP4” (beta)

i do have that issue, too (as described by TFTD). Everything worked fine until step 6.
adb recognizes the phone, fastboot won’t. (fastboot = )

after entering recovery mode and selecting ‘enter fastboot’ the command fastboot devices -l shows the device. unfortunately fastboot flashing unlock is not possible, i get

FAILED (remote: ‘Unrecognized command flashing unlock’)

then I tried fastboot oem unlock and got

FAILED (remote: ‘Command not supported in default implementation’)

after executing adb reboot bootloader ‘Fastboot Mode’ is in red letters (as DEVICE STATE - locked).
Is Fastboot Mode disabled?? How to enable it? It would be very helpful to have some comments on this within the manual as well.

very confusing… any ideas how to get this working?
thanks for any help in advance.

using macos montery + homebrew

That’s already benn said last year (2021) :wink:
The discussion about backup was already held and exactly this statement was part of it at that time. Here or in the /e/ forum.
Therefore, it can really take longer. Must remain patient

1 Like

This has to be entered in bootloader mode. Not recovery mode
And it is fastboot flashing unlock for FP4

Thanks for your reply, FairphoneHulk!

I tried another cable - and it worked.

First try was using the cable from my macbook.

Now I used a cable for external SDD and everything worked fine.

Maybe helpful information, how to check wheather the cable is suitable…


Did you ask Murena (/e/) or Fairphone?

1 Like

… finally I have installed it! :slight_smile: And, yes, almost without problems.

Now it would be nice if I could transfer as much as possible of my system settings and apps (and their settings…) from my FP2 with /e/OS (connected to a self-hosted Nextcloud instance) to the FP4.

But I’ll probably have to do that myself, right?

Is seedvault integrated in e/OS? That could at least backup and transfer some Apps, but only during initial setup. Settings-System-Backup

1 Like

Thanks for your hint about “seedvault” – had not heard of it.
… and found @Ingo in this thread; [HOWTO] use Seedvault early to understand Android backup - #5 by Ingo_FP_Angel - HOWTOs - /e/ community – maybe he knows more :wink:

Hmm, just found:, seedvault seems to be integrated only in the /e/OS version for FP4:

… not for FP2. There is no backup option in the system menu.

But it’s too late now :wink: >> Thanks for your response!

1 Like

Sorry, I don’t know. I don’t have the time to follow what happens with /e/ anymore.


No problem. I’ll do it step/app by app/step : )

News: Today there is a new stable release of e/OS/: with this release OsmAnd on FP4 will run again as we are used to.


And also the german CoronaContact Tracing App

This came from the /e/ foundation support - though the topic was more getting the bank details for donation - so it may not have come from the department most up to date…

I’ve reported the issue to /e/ devs, and the upcoming build (currently available on the staging server) comes with a fix that makes NFC usable again!

Nice to hear that they managed to fix all of the issues. Does anyone knows when will it be available to install it with Easy Installer?

I’m satisfied with Startmail, not the cheapest though…

Leaving this here as well:

Hi all with the < waiting for any device > issue in step 6 of “Unlocking the bootloader”: I had the same issue and using another USB cable did not resolve it.

For me the issue was that I had to run the fastboot commands as root. i.e. sudo fastboot ... in Linux

→ if you have the same issue in Linux, make sure to make yourself su during the installation, as there are a lot of fastboot commands and it would be a pain to add sudo before all of them → enter sudo su in the terminal before using the first fastboot command.

Kodus to @Lidwien who figured this out here :+1:


You can also install android-udev-rules to avoid running fastboot as root.
More work now, but less work in the future :smirk:

1 Like

Hi there,
I just noticed that Fairphone has released a zip file for offline installation, see support article FP4. Install Fairphone OS offline
Seems that installing /e/ other roms is no longer a one way street…


:tada: :tada: :tada:
Finally!!! :smiley:

Good thing I didn’t have the time to test my homebrew way back to vanilla, this is much safer :smirk:

Edit: Worked great, had to use fastboot flashing unlock_critical (as expected, but not mentioned in the docs).
Why you would add and just have that call flash_fp4_factory.command is beyond me :man_facepalming: Just tell linux users to run flash_fp4_factory.command, we aren’t stupid… :roll_eyes: