Install /e/ on a Fairphone FP4 - “FP4” (beta)

Thanks for the quick reply. I will try a different cable. Just have none with me at the moment.
If I get you correctly for you it only worked with USB-c to USB-c. I don’t have a pc with a usb-c port but I have a Fairphone cable. Will try this later.

USB/a to USB/c worked

both side USB/c didn’t worked

Ah soory, missread you. Mainly because for me it is not working with USB/a - USB/c. But it is Samsung cable. So I have hope. (Bot I think, I didn’t have issues with it before.)

curiosity…adb commands are working with my bothsides USB/c but not fastboot commands in bootloader mode
therefore I did not suspect the cable at first

try it and you will see… :wink:

Had a similar issue with fairphone where it was not recognized when in fastboot mode everytime I plugged in.

Basically my computer (Windows 11) requires to manually install the driver of my phone identified as “unknown device” in device manager. Had to download the google usb driver → device manager → Unknown device → install driver from file → adb interface

Funny enough, when I switched to recovery mode I actually had the popup of USB drivers being installed automatically, if I remember correctly. But after this, things still didn’t work. But this is a good idea, where to check for the problem, too. Thanks!

OK, using Linux Mint. No experience with Windows, sorry

1 Like


Maybe the popup in the phone, “allow USB debubugging” ? :wink:
I also had to a few times after booting, no matter what mode.
Even if the cable is pulled, confirm again and again, device / PC remember the phone is not interested. :face_with_raised_eyebrow:

Is this not normal behaviour and only fastboot commands would work? And would you not need to update the driver while in fastboot? On the FP2 and FP3 driver issues are most times fixed by actively searching for updates und er Windows updater while the FP is connected in fastboot. Under additional updates - driver you might find google stuff to update

1 Like


No, you start adb reboot etc and switch to fastboot flashing etc. :thinking:
I guess it doesn’t work for /e/. Not for me anyway and I’m not alone with this.
And maybe someone can push this all together :wink:

so you are telling me when you are in the bootloader /fastboot mode through adb reboot bootloader, you can use adb commands? I cannot neither on the FP2 nor the FP3.
Eithter way I think when the above reported issue is really caused by missing drivers, it does not really matter. In addition I doubt that your issue is the same as reported in the other post else hirnsushi would have had a solution. In the other post the issue is that the bootloader is locked and OEM unlocking is disabled and phone not booting, so no way to enable OEM unlocking again and without that the bootloader cannot be unlocked again.


I guess because ADB and fastboot get distributed together they often get lumped together as simply ADB.
When we get into detail, the two are seperate entities working with different modes of the phone, and referring to fastboot as ADB then leads to confusion in troubleshooting.

I think we should assume fastboot doesn’t find the device.

Thanks for all the answers. I managed to install /e/ using my old Win7 pc with a usb-cable I bought with the FP4.


Waiting for any device,… unauthorized,… I also had the messages/ errors and was also stuck in fastboot mode. Just wanted to “try” to explain how I solved it.
Good luck :slightly_smiling_face: seems to be more difficult to solve because we need a way to enable “oem unlocking” without a working OS/recovery

Es ist ja bereits bekannt dass einige Apps nicht laufen. Osmand, Aegis, etc… Das ist auf die geringe jvm heapsize zurück zu führen.
Ein issue ist in Git eingekippt, bekannt und bereits gelöst. Kommt mit dem nächsten Update.

Workaround für die, die nicht zum Update warten können: im /e/ Forum eben berichtet und von mir bereits getestet. Funktioniert. Danach läuft Osmand, davor nicht.


Thanks @AlphaElwedritsch that finally explains the Magisk issue we were investigating


Test Option: *#*#2886#*#* is no longer working wih /e/
Is there an alternativ, or is it not possible on /e/ (Lineage, CustomRom) in general?

It’s the same at least with the respective test menu dial code for the Fairphone 3/3+ in /e/OS. I wouldn’t get my hopes up.

Maybe @urs_lesse found at least a solution for some the tests. The Fairphone Checkup App (Originally for the FP2) fork available on F-Droid seem to work on other phones as well

1 Like