Headset mic not working

Thanks much Sonne

A lot of terms going on here and much confusion. I’ve got some standard Philips headphones which don’t state which kind of remote it has. The thing I notice is not being able to use the remote. It used to have start/stop and skip (double click) function and I was always told that’s industrie standard.
Anyone known with this?

This one.

The question is whether the mic works. If it does then the headset is probably CTIA (if it would be OMTP the mic wouldn’t work). If the mic works then your question is about the buttons on the remote - which judging by other posts on the forum can be tricky to get right. There are some apps that are occasionally recommended to map the buttons to a specific function - I can’t specifically recommend any (no experience) try searching around a little for recommendations (though I do note there appears to be a philips specific one that offers button customisation - but maybe only for 1 button models - and audio ‘enhancements’).

A post was merged into an existing topic: Headset buttons do not work

Hi everyone,

I have been following this thread for a while and now I’m going to post a conversation that I had with the support about this issue:

So… the one precise information is the hint not to use Apple-compatible headsets (even though some of you stated that this “CTIA” standard is used by Apple?).
If I get any update on this, I will let you all know!

1 Like

A post was merged into an existing topic: Location based profile apps not working on FP2

Ok so as far as I understood, there are two standards concerning the plugs (with mics): CTIA and OMTP. But they are only hardwarewise which ring is for what, and a adapter can change from one standard to the other.

The Apple only headsets have an ADDITIONAL thing named TRRS conncection that is more interesting softwarewise, and that is patented though not usable for android phones (-> no mic, not full button function). There you can do nothing.

But any headset lacking this TRRS with buttons should be work, either with or without adaptor.

Unfortunately enough most headsets don’t have a detailed descrition about used standards (which annoys me incedible). But with something like “android headset” you should be on the save side.

But concerining a good android headset there are many discussions on the internet, so a little bit of research should do.

Hey all,

I opened a wiki to create a list of headphones that work or not with the FP2.
Please add the type and model of your headphone to the list so others can learn from it.

1 Like

The Wiki is a great idea, thanks very much!

Hi Douwe, there is a lot of info on the different standards, and it seems like FP2 opted for changing its position compared to the last FP1. In most cases it seems like a converter cable would work, and this would be a better advice then to buy a new headphone I think. Mobile Phone Headsets for sale | eBay

1 Like

Does somebody have an advise which other smartphone company is the closest to the FP2? I just went to a store a tried some headsets… all without succes :frowning:
… at least the wiki is extended with models that don’t work

I have also two simple HeadSets, which are not properly working with the FP2 but did it like a charm with the FP1 and another old Nokia phone.
I made some more research I want here to share and which I also sent to support.
The 3.5mm headsets are 4-wired (2xstereo sound, 1 mic, 1 ground) with a call button.

Strange behaviour includes:

  1. If I plug in the headset slowly I** can’t see any symbol** in the notification bar (maybe normal behaviour of Android 5.1 in contrast to 4.2, which clearly showed me If I have plugged in a headset or a headphone)
  2. During plugging in, I can feel different “snaps” according to the 3 black rings of the jack-stick which are connected with the outer contact of the jack.
    a) if it connects to the contact between 2nd and 3rd ring: my right headphones of the set begins to make clicking noises continously
    b) if it connects exatly the 3rd ring there is nothing to hear
    c) if it connects to the last contact after the 3rd ring: the clicking noise at the right headphone is back, just quieter
  3. If I only play music through the headset I basically CAN hear the music, but in a very bad quality. Only during pressing the CALL-BUTTON the sound is as expected!! Releasing the button, sound again bad!
  4. If I try to call through the headset the mic seems to work - but in an unexpected way:
    The headphones itself do not work (or extrem quietly). But during PRESSING the CALL-BUTTON I can instantly clearly hear everything correct (as Nr. 3 above). The MIC is working quite OK, but DURING PRESSING the CALL-BUTTON, the MIC is disabled.
    Thus it is not possible to make a normal call !!
  5. During plugging-in any headphone/-set one should care about to fully plug-in the jackstick, as the last 1mm needs some stronger pushing… see pictures
  6. If I plug-in the headset, the software makes different things.
    -sometimes a grey screen appears just announcing “Initializing” in the middle
    -sometimes the music player continues to play (could be intended behaviour)
    -sometimes the music player does not continue to play
    -sometimes it appears the screen from “Google Now - please speak now”

forum threads in connection: here, here, here and the semi-official list here

For me it seems that there is any contacts inside the FP-jack wrong connected.
OR: my headset is not suitable for the FP2. BUT: Why it worked without problems with the FP1 and another Nokia-phone?
Plus the (hopefully) software-side is not programmed fully functional…

Playing Music through other headphones (without any mic) works well!

Any comments ???
Cheers, Robert

My headsets are:
Nokia WH-102 HS-125: and
B7 ZTE Blade:

1 Like

Thank you for detailed information, Robert! I have delivered a support request approx. one week ago, still waiting for answer. I will supply them with your information, too. I have checked my FP2 more in depth, and it seems to the “little plate” at the entrance of the “hole” that “only” may have to be removed a little bit. But I do not dare to do that without having asked the support.
I will forward their answer, when arrived.

I also did already wrote to support and pointing them to my post/this thread…
We will see, who gets an answer first…

About your idea about the “plate” - are you sure? Do you mean the black part of my close-up picture of the “outer contact”?
If yes: I think this is not the reason. Because if you look at my pictures of the jackstick without the FP-case: there is still some mm space at the outside, if the jackstick is connected properly.
IF it is about physical design: it would be more at the “end” of the hole" (=inside), as the jackstick stops there maybe to early (although there is a more deep hole inside, but which is smaller than the stick).
AND: normal earphone do work properly. So also the most inner connector is well placed and connected I would say.

I think the problem is more about a wrong (or different to FP1) connection of the individual contacts inside the jack or wrong recognition of the software or the dedicated audio-hardware…And I fear there will be no fix…What would be a high disappointment :-/

We will see.

I use an (few years old) apple wired headset which I also used with FP1. In fact I have two of these both of which I have tested on FP1 and FP2… THe audio out on FP2 is fine, but the mic appears not to work on either headset - when i have tried to use the headset for calls no one can hear me, although I can hear them. Removing the headset and going back to handset mic has always worked. FP1 I am able to make a call with headset audio in and out.

Could you check, if you really plugged-in the mic COMPLETELY, as I made a picture in my post above?
As for my headset the mic works, the audio out not good if I plug it in very strong.
If there only 1mm is missing, the mic does not work, but the audio is OK (not perfect). Could you confirm or not?
Do you have a Call-Button? If yes → how sound and mic is behaving if pressed?
You could also add your findings to the list here.

Yes, it’s absolutely definitely plugged in completely - the plastic around the plug is just touching the FP2 external case (so it cannot plug in any more). No call-button, just volume controls. The audio out is fine, not had any issues with that (but have used it quite a bit for podcast listening).

Hi, same problem here.
Bose noise canceling head phones, inline microphone worked fine on FP1U and doesn’t work on FP2. Headphones works fine, just mic doesnt pick up anything. Other headsets do work, just this one suddenly does not. It’s all the way plugged in, it works on other devices, just not the FP2. It does manage to pick up a sound when i click the volume buttons.

Hey @dull: so you exactly have the same problem, including changing sound if the button is pressed. good to know.

Could you also provide the headsets (+ details) which do work with the FP2 (incl. mic + button) in this post and also here?

Hi @therob,

The working model i have is an old motorola wired headset. I attached a picture to show its not really a hardware problem from my point of view. Left works, right does not.
I’ve tested with and without cover on the FP2 to test if it was the edge of the plug.
Problem remains in both cases, while it does receive some input if I press the volume buttons.


Its a pretty standardised principle, and I’m not going to supply the model numbers on some sort of buy list for FP2 headphones. People shouldnt need to buy new headphones due to the Fairphone. Just like they shouldnt have to buy new charger cables. The headphone brands that aren’t working are well known, also for complying with industry standards.