Location based profile apps not working on FP2

Hi everyone,

so far I had nine happy days with my FP2, everything works just fine. But now I realized that my Location Profile App (Llama) is not working correctly. For your understanding:

Llama is a location based profile app that uses the IDs of cell towers your phone is connected to. You can train your Llama so it knows which cell towers are “at home” or which are “at work”. Llama then changes your profile (and many many other stuff) accordingly. Basically it’s like Tasker but less allmighty.

I used this app for years on different phones and Android versions, rooted and unrooted. It never let me down. But now on my FP2 it does not recognize any cell tower IDs anymore. There are no error messages or anything, it just does not detect any IDs and thus any location changes. I considered using Tasker instead, but obviously there are similar issues (see comments section here https://play.google.com/store/apps/details?id=net.dinglisch.android.taskerm).

Setting back the privacy impact as described here (Misbehaving Apps - fix expected for next update; workaround: re-enable privacy impact) did not solve the problem.

I’m not sure now if this is an issue of FP2 or rather Android 5.1.

Any ideas?

Kind regards,

JohannesCommunity Moderator:

Btw, which Llama app do they refer to?

This one

Thanks much Johannes! But I have bad news… I installed the app and it didn’t work in my FP2. It was missing a choice validation button and I was not able to find a way to confirm and store my choice. If anyone knows about it please tell me, it looks all right, even if it doesn’t solve my headphones problem…
I’ll try to find out about the resistances and post my findings…

I’ve moved the post above here, as it deals with the same general problem. Probably more convenient for everybody if all posts about this problem are in one place.

I also noticed that this does not work on the fp2. It does work on lollipop, as my last phone was omnirom 5.1 based, and there it worked flawlessly. I’m right now collecting debug info and will contact the developer, maybe he can give a hint…

Same issue here…

I have also the same problem. I also tried to import the data from my FP1. That also does not work at all.

I only get cell poll timeout in recents tabs, and in Llamalog.txt, when it should do something, I’m getting a

I have the impression the medthod should be there…

I just tried Tasker. Does not work also… There’s also a comment on play store, that Tasker on FP2 does not work.

So, I guess there’s a problem with Fairphones OS that does not allow location based automation tools to work…

That’s interesting, Tasker works for me :confused:
I use two profiles defining “work” and “home” by using Google Maps coordinates + radius. The system setting for “location” is set to “energy saving” meaning it does not use GPS. This works for me - which leads to the conclusion that location based stuff generally works on the FP2 but it does not correctly communicate with the Llama-App.

I didn’t use taker before, so I can’t get over the start screen with its explanation. Location works, e.g. for navigation, yes

Problems when starting apps are treated in this thread, maybe it helps?

1 Like

Maybe only the location detected by the cell towers doesn’t work. The location detected by the phones location-service based on A-GPS/Wi-Fi-database is working fine because it’s used by all the apps with location based functions?!

1 Like

You’re right, I forgot about this one… And indeed, Tasker does start…

Thanks for the reminder!

Location detection works fine in energy saving mode. At least with Google maps, camera, here maps, … :wink:

hooray, I think I found it :relieved:
I digged a little bit around in my Llama settings. I found “Android Postitionsbestimmung” under “Versuchslabor” and activated it - it seems to work. At least Llama instantly finds new cells and updates its area information. Let’s see if this solves the problem. If so I guess the Llama location service uses a depricated API.
I don’t know the english terms for these menu items, most probably “Experimental” and “Use Android location service”? Here are some screenshots to make thins clear:

1 Like

Can you add the position to a region? I only get a white screen

Edit: I see, there’s a plugin necessary. Now I can select the location, but it doesn’t save it…

Judging from your previous description of how Llama is supposed to work and the description of this setting, I’d say that there are still no cell towers found.

Do I understand correctly? The normal way for Llama to get a position is by circumventing the built in (to Android) position service (offered by Google) and decide whether you are in your home region by comparing IDs of cell towers in range.

The “experimental” positioning is different: It clearly says that it now does use the position service built in to Android. That means it doesn’t look for cell tower IDs anymore but relies on the position given by Google (based on stuff like WiFi networks, cell towers, GPS, … whatever is available to Android).

Your solution solves the problem from a usage perspective but does not seem to fix the underlying problem that Llama is not able to see cell tower IDs on your phone.

Yes, this is a work around. Llama can’t get information from cell towers. If you activate debug, you’ll see “cell poll proximity timeout”. Every five minutes or so

Indeed, I was too optimistic. Llama just detected a different cell ID then before but still it does not find the right IDs. The IDs provided by Llama can not be found in the openCellID-database - so obviously something’s messed up here. Still trying to find out if this is a general Android issue or a FP2 issue.

Regarding the “Android location service” under Llama:

Thanks to lklaus I found the plugin needed and it worked for me as soon as I deleted all cell IDs for my areas and chose two points for “work” and two points for “home”. “It worked for me” in this case means that the location was saved and it shows up under the area tab saying “two points defined on map”.

Let’s see if I’m still happy tomorrow :wink: