Headphone connector can't hold on to Headphone Jack properly

Hello everyone

This is not about about a headset with microphone. So don’t direct me to that list of compatibles. I am talking about normal stereo earphones no microphone or any fancy buttons mkay?.

Bought the FP2 this July. After losing my last earphones and not being able to replace them because they were 10 years (yes!) old, I invested in some time to listen and choose a new pair of earphones.
Last week, I bought them. Standard, stereo, 3.5mm jack.

Problem details:
I plug it into the FP2, start the music, all perfect.
I put the phone into my pocket.
Music plays. New track comes up.
“eh… not in the mood for that, gotta change to the next track”.

Because the FP does not have Volume Rocker Audio controls, I have to take my phone out of the pocket to change the track.
While taking the phone out of the pocket, the earphone jack unplugs, just a millimeter and the connection is lost. I hear nothing.

Problem core:
It takes literally next to no force to unplug the earphone jack. When held by the cable, the weight of the phone itself is enough to uplug itself.

Today, I cross-checked with my office workmates and their phones. I tried SONY Xperias, a HTC, a Huawei, iPhones, Nexus 6 and even an FP1 and the jack fits snugly in all of them and I feel a distinct “click” when doing so.

Things i’ve done:

  • check headphones with other phones - earphones work perfect
  • check other headphones with FP2 - same problem with all
  • checked forum
    – cleaned the Headphone connector - no gunk found
    – tried with the cover off - no change in jack-in-depth
    – replaced the Headphone module - No, I think if I should have do that, the part + shipping should be free because warranty

Pictures, maybe a Video will follow soon, tonight if I can make it.

I am happy for all helpful helping helps

PS: Don’t judge my choice. They sound best for me. Also, I believe lossy MP3 from a youtube video or whatever, decoded with a crappy Mobile Phone DAC doesn’t require 400$ earbuds.

20161207: Made a picture of the whole situation.

Well, it seems obvious that the plug isn’t going into the port deep enough. Maybe there is an irregularity in the case, more precisely the headphone port cutout is too small? To verify, you might want to try plugging it into the phone when the case is taken off the phone.

Dear Urs

Thank you for your quick reply. Yes the jack does stick out quite a bit from the headphone connector. I tried that too, the cover is not even touching the base of the jack.

Just tested this with my (also non-400$) earbuds: when I plug them in and hold them by the cable, the plug easily carries the phone. So I strongly guess your FP2’s top module is the problem.

I have the same problem. For me it’s not possible for me to use headphones while I moving. I already get a different top module. I have the slim case and if take off the back cover it works fine.

1 Like

Are you absolutely positive that there isn’t any compressed dust right at the bottom of the port? I had that problem with my old phone. Dust accumulates in the port and each time you stick something in there you compress it to a growing disk of solid dust, which does not easily come out when cleaning. You have to really dig in with a hard tool like a small screwdriver.


I got the Fairphone 2 with a slim case at the beginning of this month and I have the same problem… Headphone jack does not fit properly into the input. Is this a design flaw or a problem with our individual phones?

1 Like

Ther is no dust inside. I tested it also with two new replacment top modules. I think it’s a design flaw.

Update 29.05.2017:
The Volume Rocker Media Control can be activated using XPosed Framework and Gravitybox. https://forum.fairphone.com/t/fp-open-os-feature-requests-vote-for-your-favorites/12303/262?u=technorati

After trying many more earphones and extension cords, I have reported this issue to support and requested a replacement module. I hope this solves the issue.

I have the same problem!
Really annoying, even for a 15 min walk, it will not hold in my pocket.

And when the headphone connector disconnects, it prompts Google Now or Android Voice Command unexpectedly “listening” to my instructions.

I have the same issue. It was there since the day FP2 was delivered. Sadly… That is why I thought that its a design flaw with the slim case. But removing rear case isn’t making anything better as does cleaning the port.
Is there any update on / solution to this issue?

1 Like

I had the problem with my FP2 for a short wile.
First everything worked fine and all of a sudden the plug would not fit in to the end anymore.
After I reported it to support, the problem disappeared all by itself again and the phone is working fine again since then (more than a year ago).

My - uneducated - guess was, that there might be a rubber ring (or something like that) at the bottom of the connector holding the plug in place, that got dislocated and relocated itself again. Maybe - just maybe - it might help to use a tiny screwdriver or a needle to poke a bit and try if there is something in the way, that can be “removed”.
Maybe it would be adviseable to contact support first; so you are not held accountable for damages, because the poking might leave traces.

I poked around (with a fork, followed by screwdriver, followed by needle xD). No moving parts detected. I also used a flashlight to see if I can find something in there. Nothing…
But I went around the office and tested other peoples head/ear phones. Multiple Sennheiser pieces had no or very little hold. 12$ standard Apple earphones were just fine, I was able to gently pull my FP2 up holding the cable without the plug instantly slipping out. So I guess it might be just an issue of micrometers in range of the manufacturing tolerance. As soon as the new camera pack is on store I will order it and see if changing the top module helps.

EDIT: I went to the electronic market today and asked the assistant if I can test multiple plugs with my phone. After some weird looks he let me do that. Verdict: SONY MDR-EX 110 had no hold, just as SENNHEISER MX 375 , but PHILIPS SHE 8500/10 holds well. Maybe it helps someone …

1 Like

OP here - I forgot to update you guys:

June: After some mail exchange with the support, I have received a new module.
Only needing a screwdriver and the FP deconstruction video, I easily exchanged the module. Big Kudos for the design. The headphone plug worked normal, just as it does in any other device I had since the WALKMAN.

September: The new module has the same problem again.
The jack doesnt hold in the plug and thus it frequently disconnects.
When I take the phone out of my pocket, without explicitly holding a finger on the plug
When I put the phone in my pocket without explicitly holding a finger on the plug
When it’s in my jeans pocket while on my bike, the up and down motion my legs make during cycling triggers a disconnect.

I just got my Fairphone 2 and have noticed that the headphone jack does not work properly. As mentioned in this thread it disconnects when moving but I also cannot get it to connect properly to the speakers I have at home (when the phone is completely still). I am curious about the suggestion to remove the case, has that worked for people?

Same here. Could it be for the simple reason that the back of the FP2 is sloped and that the jackplug therefore easily gets cought when taking it out of your pocket, for example? Or is it the jackplug itself?

Same here with my FP 2 new life edition. I even got a new head module from support but it didn’t solve the problem. Maybe I try the one from philips that @Beatzekatze mentioned.

Yesterday I received the camera bundle and changed the top module. The jack is perfectly fine there. Plugging in the headphones now feel pretty different xD Maybe I got lucky or maybe the problem is fixed in the new generation of the top module


Hey guys,
I have a problem with my headphone socket. The headphone plug doesn’t stay in the socket. It’s very loose and deconnects almost without touching…
Normally I still have warranty. But I don’t want to miss my phone for months. And as far as I heard, warranty process of FP does take a long time…
Do you have experiences? Would you recommend to just buy a new toomodule instead of going through the warranty process.

maybe they just send you a top module on warranty without you sending in your phone.

(I had the same problem, it’s now slightly better with a new module.)