English

Google Apps keep reinstalling/ reactivating

Tags: #<Tag:0x00007f05db35e520>

Hi everybody

Maybe someone else walked into this problem
I’ve deactivated almost all of the google apps on my FP3 (as gmaps,chrome,youtube,gmail, etc.) The only one i still installed is playstore. But everyday with some new updates, these deactivated google apps keep to reinstall themselves. Does anybody know how disable them permanently?

Second question: If i push the home-button for a second, there’s still this google-tool opening, even if it’s not working (i’ve disabled it). How can i get rid of it completely?

Thanks

2 Likes

First of all: Disabling is not the same as uninstalling, so if the apps come back they are not re-installed, but re-enabled.
I’m guessing it’s a default Google behavior to re-enable updated Google apps. Maybe you can go to the Play Store and search for the installed apps and disable updates for them?

About the assist app: You could probably install an other one and then in Settings > Apps > Default apps (or similar; if that setting even exists - I’m on an FP2 with Lineage OS) select it as default.

1 Like

To get rid of the google search bar I installed a different Launcher (mine is called Nova Launcher, I think, but there seem to be lots of them out there) that had the option to not show it and to also customize the behavior of the start button.

1 Like

Yes, i know but i can’t uninstall them. And true, they are always reenabling themselves even if turned “auto-update” for these apps “off” in playstore. Couldn’t find any settings to prevent the reenabling so far. Any more hints?

Ps. I Use smart launcher. I could use Firefox as assist app, or none. but even with none, it’s still opening some kind of menu while holding the home button.

There is a way to get rid of them even more. It’s also not uninstalling, but better than just disabling afaik. Download Minimal ADB and Fastboot and connect your phone to your PC. Then go to developer options and activate USB-Debugging. Then start Minimal ADB and Fastboot and type adb shell. Now your phone should have a popup, accept it. Then you can delete apps via pm uninstall *package name*. To find out the package names, download the “APK inspector” to your device, it shows you what package name each app has.
Now you can uninstall or at least (hopefully) permanently disable almost every G00gle app. Almost, because the most evil of them all, the G00gle Play Services, probably can’t be disabled.

There is also this YouTube tutorial (eww, youtube) in case you want to know it in more detail :slight_smile:

7 Likes

Unfortunately, you can’t uninstall system apps, even with the (somewhat) privileged ADB permissions. That’d mean you could uninstall the phone app, or the launcher, or the Settings app.

Of course, you can do it with root permissions, but that’s probably out of the scope of this answer (for the moment, since that’d interfere with system updates).

2 Likes

Thank you very much @Stanzi!

I’ve followed almost the same path as you described. For other People who got the same issue and use a apple computer, i did following stepps:

  • Download platform tools to your computer

  • cell phone: activate “developper options” then enabled"usb-debugging"

  • connect cellphone with cable to your computer

  • enable data-transfer on your cellphone

  • computer: copy path of platformtools folder (right click while holding option key on the folder allow you to copy the pathname)

  • open terminal and enter cd and your path. example:

cd /Users/userfolder/Downloads/platform-tools

  • then enter in terminal following:

./adb shell

  • accept acces on your cellphone

  • list all packages of your cellphone in terminal:

pm list packages

  • search for the apps you want to disable

  • disable them by following command in terminal (youtube as example):

pm uninstall -k --user 0 ‘com.google.android.youtube’

  • some more apps you could disable:

pm uninstall -k --user 0 ‘com.android.chrome’
pm uninstall -k --user 0 ‘com.google.android.apps.photos’
pm uninstall -k --user 0 ‘com.google.android.calendar’
pm uninstall -k --user 0 ‘com.google.android.apps.messaging’
pm uninstall -k --user 0 ‘com.google.android.apps.maps’
pm uninstall -k --user 0 ‘com.google.android.webview’
pm uninstall -k --user 0 ‘com.google.android.gm’
pm uninstall -k --user 0 ‘com.google.android.apps.tachyon’
pm uninstall -k --user 0 ‘com.google.android.music’
pm uninstall -k --user 0 ‘com.google.android.apps.wellbeing’
pm uninstall -k --user 0 ‘com.google.android.videos’
pm uninstall -k --user 0 ‘com.google.android.googlequicksearchbox’
pm uninstall -k --user 0 ‘com.google.android.marvin.talkback’

there are still more apps to disable.
Maybe someone got some other proposals on this toppic, or simpler ways to achieve this. Please Share.

ps. take care with uninstalling webview, some apps may not work without this. are there any substitutes?

8 Likes

Oh, nice that you could disable them. But why using the -k flag at all? That’d keep app data of applications that you want to permanently disable.

1 Like

Thanks for your hint, that’s true… with -k i keep the data. I haven’t tried it without -k so far. Did it work for you?

I didn’t try, I don’t have any system app I want to get rid of (clean LineageOS here). I got the info from the pm command help text. But it should work. At least, there’s no reason for it not to.

Anyway, to remove the app data you could use pm clear <packagename>, if the former command doesn’t work.

Hi guys,

I just got the FP3 and as usual, the first thing I do after setup is to uninstall or deactivate apps I don’t need, e.g. Chrome, Google Photos, Duo, Youtube …
Usually I don’t have to worry about them afterwards. But on the FP3 they constantly reappear. It only takes a couple of hours and all the apps I deactivated are active again, asking for updates and stuff … very annoying. I tried several times now, deleting caches and whatnot, theyy always come back. Anyone else got this problem? I really don’t know what to do about it and right now it’s the #1 reason to return the phone.

Welcome to the community forum.
I moved your post here to avoid duplicate topics, please have a look at the previous posts here.

3 Likes

Thanks. Good to know there is a way, even though it seems uneccessary complicated. I never had this issue before, not even with the Pixel phones, which should be totaly googlelized. Once deactivated, the apps stayed that way.

Hello,

I had a similar issue when I installed a secondary language pack.

When I disabled all the google apps, they kept being re-enabled.
I let them update and let Play Store download the language packs in the background. I then disabled the apps without removing the data etc.

I then removed the Play Stores ability to modify system settings.
Settings> Apps and Notifications> Play Store> Advanced> Modify System Settings

I’ve also removed the auto-updating aspect of the play store.
I’ve not been bugged by the app upgrades etc since.

Hopefully this helps people =)

7 Likes

FWIW: Mac users using Homebrew can open a Terminal and execute

$ brew cask install android-platform-tools

(Disclaimer: Never execute commands you don’t understand.)

What I used in past in a script I would fire at startup which would disable all the advertising features from apps. It required root, and used the same pm command.

AFAIK you unfortunately cannot use Firefox instead.

That seems to have done the trick! Thank you!

1 Like

Edit: Nevermind, just got it with the additional command --user 0 mentiond by @solanum

I tried to uninstall the nasty google stuff on my fairphone 3 using this method, but everytime I type the command pm uninstall *package name*, I get the readout Failure [DELETE_FAILED_INTERNAL_ERROR].
I tried this with several apps and a search on ecosia didn’t help me either. So I have no idea what to do now.

This is important. Some Apps will not work!

If you uninstall WebView and later perhaps want to try e.g. the Play Store nonetheless or just add a Google account in the settings, you will just get a black screen because WebView is missing.
Without the WebView APK to install it again you can use APKMirror …

https://www.apkmirror.com/?post_type=app_release&searchtype=apk&s=com.google.android.webview

… choose the latest “Android System WebView” which is not labeled “beta”, for the correct variant choose Architecture “arm64-v8a + armeabi-v7a” and Minimum Version “Android 5.0+” (currently, as long as “Android 10.0+” doesn’t fit the Fairphone 3).

Some apps, especially some Google stuff, may refuse deinstallation if they are defined as app for device management.
Have a look at <Security & Location >> Apps for device management> (frei übersetzt, deutsch: Sicherheit & Standort >> Apps zur Geräteverwaltung)
Disable them there and repeat the adb command.

Some time ago I had made a little script for a Huawei Mate 9 to delete some Google and other apps. I have modified it to run against my FP3. It contains the -k flag in every pm command. Thanks @Roboe for the hint about it. I’ll correct and test it later.

For reference I attach it here:

##########

#!/bin/bash
adb devices

#adb shell pm list packages

#google
adb shell pm uninstall -k --user 0 com.google.android.onetimeinitializer
adb shell pm uninstall -k --user 0 com.google.android.apps.photos
adb shell pm uninstall -k --user 0 com.android.hotwordenrollment.okgoogle
adb shell pm uninstall -k --user 0 com.android.hotwordenrollment.xgoogle
adb shell pm uninstall -k --user 0 com.google.android.googlequicksearchbox
adb shell pm uninstall -k --user 0 com.google.android.music
adb shell pm uninstall -k --user 0 com.google.android.videos
adb shell pm uninstall -k --user 0 com.google.android.feedback
adb shell pm uninstall -k --user 0 com.google.android.backuptransport
adb shell pm uninstall -k --user 0 com.google.android.gm
adb shell pm uninstall -k --user 0 com.google.android.gms
adb shell pm uninstall -k --user 0 com.google.android.gmsintegration
adb shell pm uninstall -k --user 0 com.google.android.apps.restore
adb shell pm uninstall -k --user 0 com.google.android.gms.policy_sidecar_aps
adb shell pm uninstall -k --user 0 com.google.android.tag
adb shell pm uninstall -k --user 0 com.google.android.gsf
adb shell pm uninstall -k --user 0 com.google.android.gsf.login
adb shell pm uninstall -k --user 0 com.android.vending
adb shell pm uninstall -k --user 0 com.google.android.apps.tachyon
adb shell pm uninstall -k --user 0 com.google.android.apps.maps
adb shell pm uninstall -k --user 0 com.google.android.apps.docs
adb shell pm uninstall -k --user 0 com.google.android.syncadapters.contacts
adb shell pm uninstall -k --user 0 com.google.android.syncadapters.calendar
adb shell pm uninstall -k --user 0 com.google.android.ext.services
adb shell pm uninstall -k --user 0 com.google.android.ext.shared
adb shell pm uninstall -k --user 0 com.google.android.youtube
adb shell pm uninstall -k --user 0 com.google.android.apps.messaging
adb shell pm uninstall -k --user 0 com.google.android.calendar
adb shell pm uninstall -k --user 0 com.google.android.contacts

#partner
adb shell pm uninstall -k --user 0 com.android.partnerbrowsercustomizations.tmobile
adb shell pm uninstall -k --user 0 com.google.android.partnersetup
adb shell pm uninstall -k --user 0 com.android.providers.partnerbookmarks

#bloat
#adb shell pm uninstall -k --user 0 com.android.chrome
adb shell pm uninstall -k --user 0 com.example.android.notepad
adb shell pm uninstall -k --user 0 com.example.android.notepad
adb shell pm uninstall -k --user 0 com.android.apps.tag

##########

After letting it run, the following preinstalled apps didn’t work anymore:

messaging
calendar
contacts

I added them to the script and substituted them with free alternatives from F-Droid.
Use it at your own risk. Feel free to modify it :wink:

6 Likes

@Stefan
Thank you for putting the script part into shape.

@ All
If your’re willing to try it out please be careful.
I have found that the Setting “System > Systemupdate” had vanished. It could be something in the script but not necessarily. I have resetted my FP3 and now it’s back. Have to investigate …

2 Likes