🇬🇧 🇩🇪 Phone app doesn't appear when a call starts

Hi,

I bought a Fairphone and made some privacy settings such as disabling Google Apps.
Now I have the problem that the phone app is not displayed when I get a call. The phone is ringing but I don’t have a button to answer it. Only when I activate the lock screen, a “back to call” button appears that I can press and the Phone App to answer the call appears.
Has anyone had this problem before? Does anyone have any ideas what log files or similar I could look at to get to the bottom of the problem?

Regards

Ich habe mir ein Fairphone gekauft und ein paar Datenschutzeinstellungen vorgenommen wie z.B. Google Apps deaktiviert.
Nun habe ich das Problem, dass bei Anrufen die Telefon App nicht angezeigt wird. Das Telefon klingelt zwar, aber ich habe keine Schaltfläche um abzunehmen. Erst wenn ich den Sperrbildschirm aktiviere, erscheint ein Fläche mit “zurück zum Anruf” auf die ich drücken kann und es erscheint dann die Telefon App zum annehmen des Anrufs.
Hatte jemand dieses Problem auch schon mal? Hat jemand Ideen, welche Logdateien oder ähnliches ich mir ansehen könnte, um dem Problem auf den Grund zu gehen?

Gruß

Welcome to the community forum.

Did you follow a particular guide or something?
Just disabling Google Apps in the stock OS as if it was a normal setting can really mess up the functioning of the phone … but I guess you found that out right now.

Did you keep track of what exactly you disabled? That would help.

If you by chance disabled the stock Dialer (com.google.android.dialer), then the Lineage OS Phone 19.0 by LineageOS (Variant: September 21, 2018) Dialer was found to be a suitable replacement you can install, I’m using that myself.

For more on that, please see this topic …

1 Like

I searched for the app “com.google.android.dialer” at my phone, but I didn’t find it (system apps are shown). I have no root access, so I’m not able to deinstall this. This is curious.
My contact app is Simple Contacts Pro from F-Droid. It has also a dialer. I set this as default dialer, but the problem is still there. But I will try the LineageOS App. Thank you for you help

I’m not an expert in this, but I can tell that this phenomenon is due to a change in Android 9, and not every phone app has yet adapted to it.
So you should look for a phone app that is up-to-date with Android 9.
I have Phone + Contacts and Calls, which works fine.

1 Like