🇬🇧 🇩🇪 Random reboots with (official) Lineage OS?

Under Lineageos the phone crashes too often. Be first back on Android 6. Pity. :frowning:

I did not had a single crash since I started using LO in July. Can you identify any particular app or setup that causes these crashes ?


I had 5 crashes in one day.
Apps | Number of crashes
Sygic Navigation | 2x
Clash Royal | 2x
Clas of Clans | 1x

Best regards

Just to be precise: Are you talking about app crashes or crashes of the whole phone so that a restart is required ?

The phone crashes at longer runtime of these apps completely. Screen freezes (one to two seconds) and then reboot (device). Without any signs.


Please try again with official and report crashes with kmsg_last.


1 Like

Two things come to my mind: Resource (memory) leak or overheating. I would suggest (if you have not already tried) to boot into TWRP, do a backup just to be on the safe side and wipe cache and dalvik.

1 Like

Kernel Adiutor app is not running properly under Lineageos. The app crashed after reboot Phone.
I then manually started Kernel Adiutor and set the MHz to 1497. But without success. The phone crashes anyway.
Have been running this app for ages on the Android 6, without any problems.

1 Like

The phone does not get hot and I deleted the cache and Dalvik. That’s what I do not understand. Lineage OS has been running flawlessly on my tablet for years. Only my FP2 does not like it. :frowning:

Hey guys. Like already mentioned in another thread (Official LineageOS is here!), since switching to the official version, I have lots of random reboots, too. Didn’t have random reboots with the unofficial releases, but had (a few) random reboots with FPOOS before switching to Lineage.

It literally started the moment i went from unofficial to official. Already tried factory reset and (as this didn’t help) completely reinstalling from scratch (didn’t help, also).

Now, as coincidence would have it, i recently got my hands on another FP2. Not even a single random reboot there, though it basically runs the same setup.

There’s some more things I’m going to try (like switching uSD between the two), but this really seems strange to me. It looks like a hardware issue, as one works and the other doesn’t, but then again the now faulty one used to work perfectly fine when still on the unofficial releases… :expressionless:


Good to know, since I had the official version installed on the FP2.

Yup, my first recommendation is trying without a microSD card.

1 Like

Yes, interesting, because I am still on the unofficial build and that probably explains why I did not had any problems. I wonder what the differences between the two builds are.


Hello !
I have a lot of randoms reboots with the official version of LineageOS too ! (I have been experiencing this problem since I have my FP2 but since Android 6 it was much better) :sob:
My kmsg last crash log is here if it helps : https://pastebin.com/GJ2rtjqe (I hope it’s the right log file !)

PS : I have AA processor and crashs with and without SDcard

What are you trying to do with adiutor? And what is AA processor?


There are two processor types in FP2s and for a while people thought random reboots could be related to the processor:

1 Like

I can confirm, i have the same behaviour, lots of reboots after installing the official version!

1 Like

When I captured my kernel log yesterday I didn’t activate anything on Kernel Auditor. This morning I tried to downclock my CPU to 1497MHz but after reboot, my configuration was not saved, I think Kernel Auditor doesn’t works with my phone. (@StevenHachel said it did not work for him either)

Some more info regarding those random reboots:
From the two devices I currently can experiment with, the one that has random reboots came with the infamous AA processor. The other one (without reboots) is an AB model. I’ve changed uSD card, SIM card and display module between those two devices, but however i combine them, it’s always the AA one that has the reboots.

Then, i found this old thread from @z3ntu from last year:

Looking at the table in there (I guess it was taken from ibtimes.com), it’s pretty clear, that the AA variant can’t run with a GPU clock of 578 MHz, but only at max. 450 MHz. So I tried throttling the GPU clock in kernel adiutor to 389MHz (that’s the maximum value I can select, that’s still below 450MHz), but still got reboots (though it felt a little less often, but you can’t really tell, because they come very irregularly for me).

Is there any way to find out more about what’s different between those two processor variants? I fear there’s no way for us to get proper documentation from Qualcomm, is there?

I’ve now upgraded both phones to the 2017-10-31 release. Let’s see if that makes a change.

If anyone has any further ideas what to try next: That AA phone is not in production use right now, so I’m willing to do lots of crazy experiments here :slight_smile: