Official LineageOS is here!

Finally, I have been waiting for this :grin:

1 Like

BTW I have for obvious reasons not yet tested the lineageos updater. I’ll try next week when the next update gets released.

Chris

5 Likes

Obviously, you forgot someone!
A @Roboe should be thanks too imho :smiley:

7 Likes

So kind of you, :blush:

2 Likes

I switched without any problems and so far no wake-up delays on my device - no root and pico openG - many thanks to all who made this possible

Switched to the official LOS version yesterday night, and it seemed to go flawlessly, but I have random reboots every few hours since then. Interestingly, I didn’t have random reboots with the unofficial version.
I have LOS with root and microG (patched with tingle), but reading above, it seems like this configuration works for others? :confused:
Already tried cleaning cache and dalvik-cache of course, but to no avail.

Anyone else with random reboots after migrating?

Edit: Did a factory reset, then reinstalled all apps. Problem seems solved now, not a single random reboot since then. :slight_smile:

2nd Edit: OK, it still does reboot, though less frequently than before.

Where do we report issues now? Still on fp bugtracker, or on the LOS site?
I observe a delay of up to five seconds between pressing the power button and the display going on…

(And no, no reboots up to now , 16h runtime)

2 Likes

Same as @lklaus here. No reboots, but screenlag.

Not yet sure where to report the bugs now: I’ll will ask around and report back here :slight_smile:

1 Like

@lklaus Possibly the wake lock problem that should be closed next week. With me about 1-2 seconds delay.

1 Like

updated to official updated, with microG and patched. so far so good. i will check how is battery working and come back with info

1 Like

I installed LineageOS last night because I had the option to go back if I prefer (with a backup).

It works very well!

Not sure yet on the battery usage but its also partly on me.

I had some issues with the Privacy Guard. Although it is a nice feature I had multiple applications spamming for permission even though I already gave permission. Couldn’t exit the dialogues without keeping clicking.

1 Like

Some issues I stumbled upon. Not sure where to report.

  • Auto-rotate works in apps (all?), but not Android itself.
  • Unable to disable either 2,4 GHz or 5 GHz WiFi (possible in FPOS not possible in LOS?).
  • When changing brightness from the drop-down menu there is a one line artifact of whatever app is in the background. If that’s the settings screen, its likely a white line because the quick settings from the menu remain. If its an application like Firefox or WhatsApp, those quick toggles aren’t there so there is no artifact.
1 Like

Stock launcher (Trebuchet)? … (I don’t use it, so I can’t check) …

2 Likes

Yep, default launcher indeed. That fixed it as well, cheers. Which launcher do you use?

1 Like

SquareHome 2 (old Fairphone Open OS screenshot) … for wacky people like me who really like the Windows Mobile UI (but not on the desktop, of course) :slight_smile: .

It can zoom.
And it can badge notify to a certain degree.

Seems like Google removed the setting … (coming from here) …

Can you give us a screenshot? I don’t see it.

1 Like

Hi guys,

First post here. I would like to join the club. Do I need to install the modem.zip like in the unofficial builds, if I’m coming from FPOOS? Or is this integrated in the LineageOS image somehow?
Thank you all for your effort. It is great that that our phone is now officially supported.

Cheers

2 Likes

6 posts were split to a new topic: Artifact when changing brightness

Really great, the 14.1-20171024-NIGHTLY-FP2-LOS-version just landed smoothly at my FP2! Lots and lots of thanks to all you made it possible!!!

Edit: Meanwhile within two days I have had two spontaneous reboots at my phone, just laying around and untouched. :unamused:

Yes, but if you are coming from a recent FP(O)OS, you already have the most recent modem. No need in that case. Later on you’ll need to manually flash modem updates.

1 Like