English

Official LineageOS is here!

This needs getting used to again :slight_smile: .
Migration worked well :+1: .

Edit:

  • modem-17.09.3.zip (unchanged, not installed again)
  • lineage-migrate-to-prod-signed.zip
  • lineage-14.1-20171024-nightly-FP2-signed.zip
  • addonsu-14.1-arm-signed.zip
  • open_gapps-arm-7.1-pico-20171024.zip

The following things work for me so far:

  • call / be called
  • send SMS / receive SMS
  • internet via WiFi
  • internet via mobile network
  • location
  • compass
  • screenshot
  • main camera (new module)
  • selfie camera (new module)
  • USB connection to PC / MTP
  • alarm (incl. swiping it off)
  • MyPhoneExplorer
  • root
3 Likes

I migrated just now (you’ll have a +1 for the community challenge :slight_smile: ) and all was smooth. I have kept microG with @roboe survival script, no need to install it again :smiley: (As I do for every update, i only did patch with tingle…)

4 Likes

Just migrated. I only have one word to say: AMAZING!!!

2 Likes

What does the survival script do?

This survival script keeps UnifiedNLP/MicroG installed as a system app trough OTA updates…

My migration also went smooth except of the alarm clock, the clock was active before migration, but didn’t ring this morning. A short test (deactivate/activate -> wait -> ring) showed me, that the alarm clock works well. So maybe I was to tired to hear the clock :slight_smile: or the storing of the alarm time or something like this was erased in the migration process (cache etc?). Anyone else noticed this?

Btw.: A very big thanks to the Fairphone LineageOS migration team for all your work! :heart_eyes:

1 Like

“OTA survival script” is a common name for Lineage OS’s addon.d scripts. Like LOS’s su addon, all my flashable ZIPs include an script to survive LOS updates without reinstalling.

1 Like

A great and big THANK YOU to all the people that have put their effort to make an official LineageOS port possible! This acknowlegment includes @NicoM and @Arvil for initial work and documentation, @z3ntu for getting it to boot and make an official TWRP port, @snevas for his hosting, build machine and updates support for the community build and specially @chrmhoffmann for his outstanding dirty work in porting it completely, cleaning the sources and upgrading it to its official status (actually he did the whole work starting from scratch, a tough man, phew). Thank you, people, you all are awesome! :grinning:

(My bad if I’ve forgotten someone, I hope not. Ping me otherwise!)

😊
33 Likes

Official LineageOS is awesome!
I installed the image without any problems. Everything works fine at the moment.

Thank you very much for the effort.

I allready appreciated FairphoneOS but to be honest LineageOS is my favorite.

4 Likes

First experience (14.1-20171024-NIGHTLY-FP2, Baseband-Version: 4437.1-FP2-0-07, with su add-on, no google):

  • The display turns on with a delay of about 1 second (wakelock issue?)
  • The battery is discharged faster and charging takes longer (wakelock issue).

Everything else works as usual. :clap: :clap: :clap:

Edit: The wackelock issue is a FP2 specific issue? Is there a LineageOS review link?

1 Like

Please, @snevas, could you add a step to patch with Tingle to the first post (for those of us #livingwogoogle)? Anytime after flashing the new system is fine, :slight_smile:

There’s no need to flash microG again if already installed with my flashable ZIP, as stated by @oli.sax, but patching is per-release required.

1 Like

The first post is a wiki. :slight_smile:

2 Likes

Finally, I have been waiting for this :grin:

1 Like

BTW I have for obvious reasons not yet tested the lineageos updater. I’ll try next week when the next update gets released.

Chris

5 Likes

Obviously, you forgot someone!
A @Roboe should be thanks too imho :smiley:

7 Likes

So kind of you, :blush:

2 Likes

I switched without any problems and so far no wake-up delays on my device - no root and pico openG - many thanks to all who made this possible

Switched to the official LOS version yesterday night, and it seemed to go flawlessly, but I have random reboots every few hours since then. Interestingly, I didn’t have random reboots with the unofficial version.
I have LOS with root and microG (patched with tingle), but reading above, it seems like this configuration works for others? :confused:
Already tried cleaning cache and dalvik-cache of course, but to no avail.

Anyone else with random reboots after migrating?

Edit: Did a factory reset, then reinstalled all apps. Problem seems solved now, not a single random reboot since then. :slight_smile:

2nd Edit: OK, it still does reboot, though less frequently than before.

Where do we report issues now? Still on fp bugtracker, or on the LOS site?
I observe a delay of up to five seconds between pressing the power button and the display going on…

(And no, no reboots up to now , 16h runtime)

2 Likes

Same as @lklaus here. No reboots, but screenlag.

Not yet sure where to report the bugs now: I’ll will ask around and report back here :slight_smile:

1 Like