FP4 Stock Camera app on /e/ or Iodé

Hi everone,
I woukd like to use the stock camera app from FP4 on a custom Rom OS, because it is the only app that can use the wide angle Camera on a FP4.
The Question is: Is it possible to get the apk to install the app on a custom ROM?
thanks for help, Yo

I’m not sure if the app is going to work on other operating systems but you can pull system packages from the phone using adb.

  1. Enable developer settings and enable USB-Debugging.
  2. In your shell, use adb shell pm list packages which should list all the installed packages. In the list you get, you can search for the camera package, it should be com.fp.camera
  3. Find out where the package is using adb shell pm path com.fp.camera, this should give you something like this: package:/system/priv-app/FPCamera/FPCamera.apk
  4. Pull it from the phone using adb pull /system/priv-app/FPCamera/FPCamera.apk

Do let us know how it went and if you succeeded! :blush:


To get it running u have to install it as system app and that’s the problem.
Tried it, got it not running

oh, great to know. But I´ve got a custom rom installed. So I need to go back to strock rom pull the app and then I have to go back to my custom rom…
I think that´s too much work to do in the next time :slight_smile:
But thanks for the info. it is good to now more about adb and fastboot and all this stuff I have to learn.

Hey Hulk,
how did you test it in only half an Hour. I´m impresst. Awesome! (or considering your nickname better incredible :wink: )

Half an hour???

I got the apk weeks ago.
I’ve installed the apk, and the camera didn’t work. Crashed

In original FPOS, it is installed as system app. And as long you install it not as system app on other OS, it will not work

This topic was already discussed here weeks ago…

Have the apk file here on my laptop
Don’t know how to share it

tried it again on iodè. Before I tried it on /e/
The app starts, asks for permissions and then crashed.

On both systems the same

1 Like

Do you have any logs? It would be interesting to see why exactly it fails!

1 Like

no. how?

This is the FPCamera.apk for anyone who wants to test it


Using logcat for example.

Like this (just substitute Magisk for FPCamera :slightly_smiling_face: )

We discussed this a few weeks ago, IIRC correctly it also depends on Google Photos, otherwise it just crashes if you try to open the preview.

Edit: Too slow…
If you are on Linux you can also just use adb exec-out 'logcat -c && logcat' > logcat.txt

1 Like

Hi rar(),
are you sure this is the apk for FP4?
I see that it can´t use the the wide Angle Cam. Only the "normal cam and selfi cam are used.

Yes, I extracted it from my FP4 like Error described in her first reply. Maybe it’s not the latest version, I think I pulled it right after I got my phone.

yes, it is the right app

You can try the one I uploaded, should be the newest one. Haven’t checked the hashes, might be identical :man_shrugging:

It’s the same file, same hash.

This is the logcat when I tried to open FPCamera the first time on iodéOS: https://pastebin.com/raw/Pkw2HbMa


thanks everybody for your effort!
Yes these both apks seems to be the same.
Funfact: If I klick the apps Icon it crashes. When i klick and hold the Icon I can see three different Options. If I klick one of the Options (pro,video,selfie) the app don´t crash and I can use it. But the app looks very different as in FPOS and I can´t see the Button for the wide angle Cam.


You’re right, seems like only photo mode of back camera doesn’t work and I don’t have Google Photos or com.google.android.googlequicksearchbox installed.

1 Like

Google Search just seems to be a soft dependency, haven’t managed to get it to crash with that removed. Google Photos however will have to be patched out for this to become widely usable.

Strange that the main activity crashes but the other ones don’t :thinking:

1 Like