FP4: "revert to FP OS" fails – recovery mode/fastbootd

Hi,
after installing /e/OS and then LeOS I want to revert to FP OS (connected to Win10).

But in step 6 …

… the final information “Info: Done. The dev…” does not appear, the windows command prompt was just closed.

Now I can can restart only into recovery mode:

… and fastboot(d):

Any tip to jump into bed? :wink:

Thanks!
webaschtl

1 Like

Did you try to just start from step 4 again?

You can also open a command window and start flash_fp4_factory.bat from there (after changing into the correct directory). In case of an error the window will then not close.

1 Like

Hours später:
Now I have access via ADB again. flash_fp4_factory.bat executed with these command:

@REM This batch script starts git-bash environmnent
@REM which then runs the .command script
start bin-msys\git-bash.exe -c "./flash_fp4_factory.command"
@REM start bin-msys\bin\sh.exe -c "./flash_fp4.command"

… und diesem Ergebnis:

Auszug:

INFO: flashing partitions...
Sending 'abl_a' (148 KB)                           OKAY [  0.000s]
Writing 'abl_a'                      FAILED (remote: 'Flashing is not allowed for critical partitions')
fastboot: error: command failed

Found https://www.droidwin.com/fix-failed-remote-flashing-is-not-allowed-for-critical-partitions/:
fastboot flashing unlock_critical

Result:

OKAY [  0.031s]
Finished. Total time: 0.031s

Once again the batch file – same error :frowning:

Any help appreciated! Thanks!

Next trial. And the final step 6 was successful.

With the little help of OBS I was able to record the last lines before the window was closed:

But the FP4 is in a “boot loop”, it reboots and reboots.

I have no chance. :frowning: :frowning:

I always have started the batch file within the command window and not by double-clicking. But it closes anyway.

In the meantime I tried it again - see my updates.

But I can’t boot into recovery mode; neither by the menu, nor by fastboot reboot recovery, only into the The FP4 boots always with this menu (after showing the Fairphone logo):

Did you try to go back to /e/OS or LeOS to see if you get a bootable device back by this?

Have you tried changing the slot? :thinking:

$ fastboot getvar current-slot
current-slot: a
$ fastboot --set-active=b

Since your bootloader is still unlocked, this should be fixable one way or another :slightly_smiling_face:

Hello noch mehr hours später :laughing:
Did you look at the display after “each” reboot? I had the same/ following problem during installation . . .

May sound stupid and too simple, for me this was (probably) the error :wink:

Maybe our firewall blocks the download of the /e/OS image: https://images.ecloud.global/stable/FP4 not available? - /e/ Smartphone Operating System - /e/ community

I tried it:

fastboot getvar current-slot
current-slot: b
Finished. Total time: 0.000s

fastboot --set-active=b

After booting again into the fastboot mode …

… and after further trials to run flash_fp4_factory.bat with the same result (the command window closes and FP4 is in a boot loop again), I have run this command in “Git Bash”:

Screenshot of the beginning:


… and of the end:

→ all seems to have gone well. But again the “boot loop”. And again. And ag…

Now I am in the fastboot menu again (and aga…):

What is / would be the next step or similar?

Thanks again! And again…

Please try changing it to the other slot :pray: that’s a in your case.

4 Likes

i was just on the jump - the jump to freedom …
… but o my god! You are my god! :slight_smile:
Thank you all!

FP2 with /e/ vs. FP4 without /e/ and LeOS – yet! :wink:

2022-02-26_14.03_fairphone_reset

1 Like

Now I try to install LeOS again. Ah, not now, later Alligator! ; )

Only problem with LeOS and FP4 (after using /e/OS for a short time, which I use on my FP2 since more than 1.5 years): no bluetooth connection. Maybe because I did not reset correctly to the “stock rom” (?) after my /e/-experience and before trying LeOS …

“Only” seems like a big understatement to me, though, doesn’t it?
Nothing works without Bluetooth. At least with me. I couldn’t do without it.
Maybe it’s also because LeOS is only available as a GSI image. I am really skeptical

1 Like

Therefore I’m going to try a fresh install of LeOS.

The first thing I did with my FP4 was to install /e/OS, which I still use on my FP2. But I was just interested in LeOS: if there are differences in handling, or if Android 12 makes a/the difference… and so on.

So I tried to install LeOS. But it was not as easy as /e/OS. But probably my fault was that I was not able to really reset the phone before the installation – removing all /e/ parts … – , e.g. the logo of /e/OS still appeared during/after the installation:

image image

→ therefore the suspicion fell on an “unclean installation”.

Somehow like this … As you can see I am really no expert :wink: :frowning:

… but now: evening meal!

Just a dump question did you unlock the phone before you started with all that? And after the install lock it again? As it is written in the FP4 guide of murena (/e/ ).

Yes, I had to unlock the phone for/during the installation. This was not the problem. :wink:
Now having a fresh LeOS installation and – still… – no problems …

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.