Fairphone stuck in fastboot mode - bootloader unlocked

I got my Fairphone stolen and I had to get a new one and re-config my os onto it (I had Iodéos).
I followed the official instruction here iodéOS installation - iodé but got stuck when my phone never reached recovery mode. It is now stuck in the bootloader menu (Start/ Restart to bootloader/ Recovery mode/ Power off/ FFBM/ QMMI) and whatever the option I chose I keep comming back to this screen. The phone don’t start normally anymore. The bootloader is unlocked and I never locked it before finishing the installation as I read it can brick the phone, still I’m stuck here. I tried everything I found on the internet (removing the battery and waiting etc). Fastboot commands work fine. Adb commands obviously does not. I’m kind of desperate… Any ideas ?
Thanks a lot in advance !

May try to change the slot?

1 Like

I tried this and didn’t see any difference…

What about installing FPOS and when it boots with FPOS, install Iode again? I think as long as the bootloader is unlocked your are somehow safe… With manual installation of FPOS I could always rescue my FP2 when I was stuck somehow during Installation of other OSes

Edit:link to manual Installation

I’m trying that, thanks !

I did it yesterday. Just for testing. Attention!!!
FPOS installation will fail, because of the avb_custom_key.
You will get more trouble then now, if you start installing FPOS again. My mention.

I would suggest following:

You bootloader is not locked. Thats fine.

Start in bootloader and do following command:
fastboot flashing get_unlock_ability
Do you get 1 or 0 back?

Be sure that you are in slot a

fastboot --set-active=a

If you get 1, everything is fine.

Then start again, beginning at Step 8)

  1. remove SIM card and check that akku has at least 50%
  2. eneable USB Debugging and “Allow unlock OEM” in Developer Options
  3. check if adb is working and device is recognized correctly =>adb devices => ACK USB debugging on phone-screen. check box: always trust
  4. adb reboot bootloader
  5. check if fastboot is working and device is recognized correctly =>fastboot devices
  6. fastboot flashing unlock => Acknowledge unlocking on phone (VOLUME UP + POWER) Device is doing a factory reset and reboots to system
  7. start again in bootloader => switch phone off. pull out USB cable. press Volume (-) and put in USB cable in. Keep Volume (-) pressed. Phone should start in bootloader. (¹)
  8. check if fastboot is working and device is recognized correctly =>fastboot devices
  9. fastboot flash recovery_a iode-3.0-20220530-FP4-recovery.img
  10. fastboot flash recovery_b iode-3.0-20220530-FP4-recovery.img
  11. fastboot erase avb_custom_key
  12. fastboot flash avb_custom_key avb_custom_key-FP4.bin
  13. press VOLUME UP until see message reboot in recovery. Then POWER
  14. From recovery => Factory reset => Format Data/factory reset
  15. From recovery => Apply update => Apply from ADB =>adb sideload iode-3.0-20220530-FP4.zip
  16. back to bootloader mode. From recovery => Advanced => reboot to bootloader
  17. check if bootloader unlock ability is possible =>fastboot flashing get_unlock_ability → (bootloader) get_unlock_ability: 1 ==> if you get 1 then follow with step 18) otherwise do not lock bootloader (can brick your phone) and follow with step 19)
  18. fastboot flashing lock
  19. reboot system. First should see a Lineage screen doing a wipe. After a second (automatic) boot you should see the yellow boot screen and then the iode bootscreen.
  20. start setup wizard

(¹) From FP Support Page:
Alternatively, you can disconnect the USB cable, turn off your Fairphone, then connect the cable and hold the volume down button. After a few seconds, you’ll see the fastboot mode

I did a lot of testing yesterday
Deleted my iode 3.0 installation
tried to flash FPOS
installed LeOS
killed LeOS
reinstalled iode

FPOS installation didn’t worked, got bootloop
Installed then LeOS GSI dirty (why not). worked…
reinstalled iode 3.0 via my steps/instruction. worked well
It will work, but you have to do exactly my steps.

adb only works if you are in normal OS mode and in recovery mode, if you enter “update via adb”
in bootloader mode only fastboot commands are excepted

Thanks A LOT for all those answers.
I did what you suggest
flashing get_unlock_ability
(bootloader) get_unlock_ability: 1
OKAY [ 0.000s]
Then began to follow all the steps as you said
Got stuck again at
.\fastboot flash avb_custom_key-FP4.bin
unknown partition ‘avb_custom_key-FP4.bin’
fastboot: error: cannot determine image filename for ‘avb_custom_key-FP4.bin’

Are you using Windows or Linux?

I’m using Windows 10 !

these commands worked?

Yes, they did.

.\fastboot flash recovery_a iode-3.0-20220530-FP4-recovery.img
Sending ‘recovery_a’ (98304 KB) OKAY [ 2.607s]
Writing ‘recovery_a’ OKAY [ 0.470s]

.\fastboot flash recovery_b iode-3.0-20220530-FP4-recovery.img
Sending ‘recovery_b’ (98304 KB) OKAY [ 2.175s]
Writing ‘recovery_b’ OKAY [ 0.432s]

.\fastboot erase avb_custom_key
Erasing ‘avb_custom_key’ OKAY [ 0.016s]
Finished. Total time: 0.016s

.\fastboot flash avb_custom_key-FP4.bin
unknown partition ‘avb_custom_key-FP4.bin’
fastboot: error: cannot determine image filename for ‘avb_custom_key-FP4.bin’

You command is wrong!

.\fastboot flash avb_custom_key-FP4.bin

right one:
.\fastboot flash avb_custom_key avb_custom_key-FP4.bin

:wink: You missed the keyword

As I said, do EXACTLY what I wrote :wink:

Oh gosh you’re right ! So sorry. Ok this worked, I’m continuing on the steps.

1 Like

Well it’s so sad but the next step is leading to the same first problem. After chosing reboot in recovery, the phone just reboots to the initial screen in fastboot mode (and by doing so does not give the possibility to factory reset).


You are always falling back to bootloader?

In which mode are you?

  1. bootloader

  2. recovery

  3. fastbootd

I’m in 1. bootloader

do a fastboot getvar all
what is your current slot?

(bootloader) current-slot:

a or b?

change it to the other one with:

fastboot --set-active=a if you ar on b or
fastboot --set-active=b if you are on a

just for testing, if you can then can change to recovery mode