FP3 Software update: 6.A.020.0

Fixed now, thanks for reporting it.

Here is the original link:


My update size is 1,03 Gb, instead of the 76Mb mentioned above.
Since my provider is KPN (The Netherlands) I don’t have Android 13 yet. I guess this could mean that with this software update A13 is available.

edit: typo’s

This update is for Android 13. If you are on Android 11, you are not concerned by it.

The size you announced lets me think the update notification you got is the upgrade to Android 13.

you’re probaly right, though the name of the update is exactly the same as the name of this topic.

To be more specific:
The update mentions the resolved issues and other improvements that are also stated in the first post of this thread. The’re is nothing about Android 13. But I’ll see, it’s downloading right now

I can confirm that it is a upgrade to Android 13, combined with the software update.

Many thanks to the team at Fairphone who developed this update.
I immediately noticed,

  • WPA3 + WPA2 mode works. No problem with reconnecting after reboot or manual disconnect.
  • Device boots faster.

(Delayed SIM PIN is not fixed yet, but I believe it will be in the future)


Thank you Fairphone Team :handshake:
Yes my wifi connection got upgraded to WPA3 soon after the update!
Finally I can disable all WPA2 mode on my home router.

Funny, I would’ve thought that fixing the delayed SIM PIN prompt is top of their list.
Or, maybe, they have some information that I don’t, for example: VERY few people really EVER turn off/reboot their phones :woozy_face:

… the telefon call issues seem to be fixed. Thank you!

1 Like

Thank you! This update seems to have restored the camera’s access to the SD card, which seems to have been a bit patchy since I updated to A13 about two weeks ago, but was lost completely over this last weekend.

1 Like

Why? It doesn‘t bother me much, that I have to enter the SIM pin after the unlock pin, that‘s just changing habits.

1 Like

Since the update my LTE does not connect anymore after disconnecting from WiFi… Airplane-Mode-Off-and-On reconnects, but that’s definitely a new…

Did you restart twice since the update ? I could never understand why twice and not once but it very often works.


Could be a problem with the APN settings. Have you checked that?

1 Like

Yes. Once the device started directly after the update, and since I turn off my phone every evening, that would be the second time.

I’ll keep watching at the issue, maybe it disappears after a few days, fingers crossed…

As mde suggests, did you look at the APN settings ? Many people had a change in them after the update.

1 Like

I just had a look; my provider (Telekom DE) does not tell an awful lot about what to enter here, but the bits they provided on their pages match my current settings.

Dummy question: if these settings were wrong, wouldn’t the phone be completely unable to connect to mobile data? (i.e. why would faulty settings work after turning Airplane mode off and on)

edit: as seen here, the password is indeed another one as stated in the Telekom pages. Funnily enough, though, after setting another password (“tm”), it is changed back to the former one (“telekom”) again.

You are right, I did not really process that part. It seems like the APN settings are not the problem then. I’m out of ideas at this point.

1 Like

Let me just watch and see, maybe it was just a hiccup…


I’ve updated to 6.A.020.0 today. A Check with the App SnoopSnitch shows that there’s a patch missing: CVE-2021-39628-1

See screenshot:


The CVE you have linked to, is very old. Probably eve before Android 13 was release(Buletin Keamanan Android—Januari 2022  |  Android Open Source Project). Android 13 has this issue fixed by a better change and I can confirm that the latest update of FP3 already has this fix.

See corresponding commit for reference.