FP3 Software update: 6.A.020.0

I just had a look; my provider (Telekom DE) does not tell an awful lot about what to enter here, but the bits they provided on their pages match my current settings.

Dummy question: if these settings were wrong, wouldn’t the phone be completely unable to connect to mobile data? (i.e. why would faulty settings work after turning Airplane mode off and on)

edit: as seen here, the password is indeed another one as stated in the Telekom pages. Funnily enough, though, after setting another password (“tm”), it is changed back to the former one (“telekom”) again.

You are right, I did not really process that part. It seems like the APN settings are not the problem then. I’m out of ideas at this point.

1 Like

Let me just watch and see, maybe it was just a hiccup…

Hey,

I’ve updated to 6.A.020.0 today. A Check with the App SnoopSnitch shows that there’s a patch missing: CVE-2021-39628-1

See screenshot:

Hey,

The CVE you have linked to, is very old. Probably eve before Android 13 was release(Buletin Keamanan Android—Januari 2022  |  Android Open Source Project). Android 13 has this issue fixed by a better change and I can confirm that the latest update of FP3 already has this fix.

See corresponding commit for reference.

Thanks.

8 Likes

Thank you for the prompt response!

I’m pretty sure though, that the first Android 13 version did not show the patch missing… :thinking:

To my knowledge SnoopSnitch uses some sort of fuzzy detection, as there is no 100% reliable marker for a patch having been applied. So this might simply be a miss in the detection. Or, alternatively: The problem has been solved in a different way than expected by the check.

I insalled the update yesterday morning, and yesterday in the evening the phone started to be unresponsive to touchscreen input 9 out of 10 times. Meaning: If I press the On/Off button, the screen lights up but does not accept any input. Apps running continue to run, no issues, volume keys do what they should do. Pressing On/Off again (Screen dark) and again (Screen on again) sometime solved it, but more often it did not. Waiting a minute and trying again somtimes solved it, sometimes not. Sometimes when it worked, after a few seconds the screen became unresponsive while using it, sometimes I could use it as long as I wanted.
I did all kind of things: Reboot, Switch off, take out battery, put it in again, restart, reboot with or without SIM, with or without SD card in, SIM in slot 2, going to flight mode, Auto rotate on or off… nothing changed. The phone did this now the whole day, driving me crazy since I was hiking and used the phone for GPS assistance/maps, and I was just about to write to Fairphone support - but now, about - dunno - 36 hours after the update or so, its back to just fine! Cannot provoke the problem anymore… The touch screen problem existed before, just after the A13 update, but I only had it three times, and in all three cases it went away after 10 minutes or so just by itself.

I have no idea

  • what causes this
  • what I can to to collect additional data to understand the issue
  • how to get it solved

Anyone had similar experiences? Did you solve it? Any hints what I should do?

Update: seems my issue is gone, either by enough of rebooting, or by fiddling with my APN settings (without actually changing them), but today and yesterday everything seems normal.

2 Likes

It may be that the problem I described above is not related to the A13 update after all, but just coincidence to some hardware issues. Here’s how the story continued:

The day after my post above, the phone finally locked up completely, not reacting to any touchscreen input, regardless how often I restarted it or which cards were in it and where. So either with or without SIM and/or SD card, the phone booted up fine, but the touchscreen was completely unresponsive. I tried safe mode boot, but even then the phone denied any input aside fom the physical buttons, which continued to work. I connected the phone via USB to my computer (which successfully recognized it), trying to do backups, but of course that did not work since I could not authorize the access from the touchscreen.

I plugged the SD card into my Windows PC, which said it requires repair, and I let Windows do the repair. I also suspected that the physical connection between the touchscreen and the motherboard had an issue, but currently travelling had no screwdriver easily at hand. I decided to ever so slightly torque the phone and applied pressure to the area where the touchscreen connector is located. After that, I re-inserted the repaired SD card - and lo and behold, the phone became functional again.

So I cannot say if it is a contact problem, the SD card problem or something completely different. However, since then I had it running three successive days and did some GPS tours, once with mobile connection on, twice in flight mode, and no issues whatsoever.

As soon as I get hold of a screwdrivcer, I’ll dismantle the device and see if anything hints on contact problems. I’m a bit frustrated that there’s no way of understanding the root cause of all this… Any hints to do some kind of post mortem would be appreciated!

1 Like

Interestingly a similar thing also worked for some people with the ghost input issue on the FP4. Over in the ghost input thread inserting some soft stuff to make the connector sit in place better was a popular workaround. Now that the sensitivity has been tampered with in a recent update to tackle the ghost inputs, many people are no longer experiencing those but input issues instead.

The following is a long shot, as the issue cited above has to do with a different FP model and another display issue, but maybe look out for sharp edges and small damages to the connector cable as well:

1 Like

Unrelated to the above 2 comments, I’ve added one more line to the release notes (under Resolved issues):

  • A bug that sometimes prevented the screen from waking up.

This was covered by the overall stability improvements from the initial notes, but given the impact of the issue, we wanted to add it explicitly.

6 Likes

I can’t remember if I checked this after applying the update, but checking just now…

The front/selfie camera is back to 16mp (FP3+ or upgraded selfie camera module). Previously it was recognised as only 4mp though several system updates.

So thanks for that fix :+1:

3 Likes

Hi, it would be better if the update itself (i.e. on the System Update setting) said it was Android 13, it looks like a minor update to A11 but the size of over 1GB says otherwise. I don’t want to have to go through the process of back-installing Android 11 again! Is there some way of warning us that this is a major version update?