System Updates keep resetting APN password to a wrong one

Hello,
Everytime my fairphone 3 gets a system update, the access point password for my mobile provider (congstar germany) gets reset from the correct one (“tm”) to a wrong one (“telekom”). Its really annoying to have to fix it every time after an update.
See here for the official setup guide by congstar.

Hi Jakob, and welcome to the forums!

Just checked my APN settings (due to another issue), and stumbled upon your post.
Disclaimer: this is the first time I have ever checked my APN settings, so I can’t tell about anything from the past.

I’m a “regular” Telekom user, but afaik Congstar belongs to Telekom somehow, hence probably the same settings on my phone.

Interestingly, my password is also “telekom”, and my phone can connect using this password.
Even more weird: after changing it to “tm”, as advised on Telekom’s pages, it reverts back to “telekom” next time I visit my APN settings…

Not sure what to make out of this, though, either way it connects to mobile data.

Am I guessing right, your mobile data does not work without changing the password? Or do you experience other issues?

Interestingly, my password is also “telekom”, and my phone can connect using this password.
Even more weird: after changing it to “tm”, as advised on Telekom’s pages, it reverts back to “telekom” next time I visit my APN settings…

You actually have to save at the top right before leaving the settings otherwise it will revert the changes. Thats probably why your change did not stick.

Am I guessing right, your mobile data does not work without changing the password? Or do you experience other issues?

Yes, mobile data does not work without the password change. Only calling and messaging works.
I also had this issue for at least one year but could not be bothered to do a bug report before… :wink:

1 Like

Oh, I see. That “Save” was extremely well hidden…

Setting my password to “tm” makes me lose the connection almost immediately, changing it back to “telekom” + Airplane Mode off&on makes it come back.

I guess it’s “telekom” for me, then. I just checked their page for Fairphone specific instructions (as Congstar has one, too), and indeed there are some details here, which actually state the password is “telekom”, but the APN should also be “internet.telekom” (without .v6. in between). I’m not changing my settings, though :slight_smile:

Anyhow, since these APN settings were also the initial ones, they must have come from the provider, I suppose, or the SIM maybe even.

I’m not sure what that means for your issue now - either Congstar sends the wrong password (somehow), or these settings are part of the update which is wrong. My suspicion is, that with all updates the provider adds their own packages (which would also explain why some are getting their Android updates very late only), including maybe the APN configuration. Or, if these settings are on the SIM, I suppose (wild guess) you could get it changed, but not sure what the costs would be, and if worth the try.

Or, maybe you set up another APN, completely manual as per instructions from Congstar, and leave the faulty one alone. Maybe only the faulty one gets changed with an update, and the second one remains untouched?

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.