FP3 Slow Charging

yes, I did. I have two FP3 and I installed the working bottom module from the other phone but it still charges slowly

The power chip is on the core module. If the phone is under warranty, better get in touch with support at fairphone .

I have the same problem.
Does it help buying a new cable for charging?

Welcome to the Fairphone community.

As described here in this thread, it might help. But the root cause can also be some debris in the bottom module, a broken connector or a dying charger. So there is no guaranty, that changing the cable will help for sure.


Hi there,

I need help. Since two days now my FP3+ is not charging correctly anymore. It was connected to the cable all night and is only charged by 33%. That’s pretty annoying. What’s wrong here? Any help is highly appreciated!

Kind regards


Slow charging is a consequence of the charger and phone not communicating properly.

There can be a number of reasons and the above posts and other topics may help you decide how to proceed.

The most common causes are dirty port on the phone, not easy to see or clean.

Will find a link

The second possibility is the cable. Fully compliant USB C cables are diagonally symmetrical so that it ‘shouldn’t’ matter which way that end is inserted.
If the wiring or contacts are damaged on one ‘side’ then it will only charge in one direction or if the contacts on one side are tarnished then the charge rate may be reduced. You can re-orientate the cable to see. If it’s the same then it should be fine. Test the cable else where and try a new cable to confirm.

If you can asses the charger and cable can quick charge other devices, we are back to the phone.
The port may be dirty, so clean or at least try a couple of times
The bottom module may not be seated well or it’s contacts may be tarnished. You can remove the bottom module, check, clean and reassemble. Whilst you do that check for a red or white square. If it is not pink or red you may still have a valid warranty.

If all the above do not work you can buy a bottom module and see if that is the cause, if you use the warranty note your phone will be wiped so save any data before you send it off.

Here is a link to a post with image of the ‘red’ square and the successful effort to clean

All the best

1 Like

I’ve owned my Fairphone 3 for around 2 and a half years. about six months ago I had this slow charging problem and I went through all the remedies that have been explained above. In the end I took the advice of someone from a different thread to update the phone while the battery is charging, and this did the trick. I had no problems until this month. I used a new charging cable which was faulty and actually damaged the USB port in the phone, so I had to buy a new lower module. This has been working fine for about 2 weeks but suddenly has started this old slow charging problem again. I think all my system updates are installed so I don’t know what I’m going to do next!

Hi Paolinho,
Cable plugs (both ends) and USB sockets can get dirty very quickly. Make sure these are all clean, including at the charger end.
If you’re still having problems, you might take your phone to a local repair shop (which doesn’t need to be a Fairphone specialist) who would be able to check the charger and cable, and maybe try other chargers and cables.
You might also get in touch with a local #fairphoneangel if there’s one in your area.

1 Like

Has anyone found a solution for this charging issue? I was reading other threads but didn´t find a clear solution.
It seems that I have the same issue with my FP3+. Some cables only charge at all one way around (cables that are USB-C to USB-C). Yesterday my cable that has been charging just well for months only charged slow charging. So I used my laptop´s USB-C to USB-C cable. It charged normally. Today the same exact laptop cable charges slow.
I´m beginning to think I have to check if the USB-port in the phone is dirty, as this laptop cable started to charge normally after a few connects and disconnects.

Sounds like a plan :slight_smile: How come you have only just thought of it :blush:

I use a magnetic cable so as not to worry.

1 Like

I did a little cleaning (taking all the lint out of the port) but that had no effect. What/how would you recommend for a better clean, if I open the whole thing? Wiping with ethanol or something like that, maybe?

How old is the phone? as you can dismantle the bottom module, but it voids the 2 year warranty.

Have you tried removing the bottom module, which doesn’t void the warranty and cleaning the port and it’s module contacts more carefully?

Yeah, I’m beginning to think there’s definitely something wrong with the module. Here’s a screen recording what is going on in USB-settings. It’s in Finnish but I think you get the idea.

Any ideas?

Looks like a connection problem to the screen, affecting just one part of the screen. Right at the end of the video you show a different text but the flickering occurs at the same place on the screen.

If the phone is still under guarantee then you could send it in for repair.

If it’s not, then I would recommend you to disassemble the phone (but don’t take the modules apart to begin with). Use compressed air to get rid of dust. Clean all contacts with cotton buds and isopropyl alcohol. Leave to dry for several hours before reassembling the phone. Be careful not to over-tighten the screws, or you may strip them.

You can follow the iFixit teardown (I don’t think you’ll need to go beyond step 7).

Thanks @OldRoutard. I think it´s got something to do with the connections of the USB-port, not the whole screen as flickering doesn´t happen anywhere else. It seems that the phone thinks another USB-device is connected or keeps getting contacted to it, although it´s not. So maybe some dirt of something in the usb-port makes it think there is another device.

And I am afraid that the 2 year warranty has just run out…

Hi regarding the warranty having expired, you can now take the bottom module apart to see if you can better clean it.

There is always a possibility that a #fairphoneangel near you has a bottom module they can provide to test that it is actually the bottom module.

For a breakdown of the module

However the flashing/disconnect could be a software issue. Have you tried a Safe Mode start

Regarding the inconsistencies::

I have two FP3+ and they have been inconsistent for two years and I have been using a magnetic adapter for six months on both

Also the notification about Rapid and Slow charging are not always relevant. Occasionally I get a ‘Rapid’ charge from 20% annotated with 1.5 hours to full other times it will say Rapid and 5 hours:

I’ve just this minute tested:

The battery is at 63% and ideally under Rapid charging would take about half an hour yet the screen shot shows 3 hours ???

The Power Management Chips, which may well control the charging rate and screen display, are on the main board.


:tangerine: * Qualcomm PMI632 power management IC
:lemon: * Qualcomm PM8953 power management IC

@OldRoutard @amoun This is getting a bit annoying. The USB-settings should be found under connected devices, right? Well, I can´t find them there. If I use the search bar in the settings app, they are found and the path shows they are under connected devices, but if I go straight to connected devices, they aren´t there.

And here´s the best part. When I restart the phone in safe mode, I can´t use the search bar in settings app. When I try to do it, it just jumps back to settings app and doesn´t let me write anything in the search bar.

Yes, but if you do not have a ‘device’ connected then you will not see the option under Connected Devices :slight_smile:

So what device have you connected and a power unit is not a ‘device’?

Try connecting a PC and then see what you can change under the settings.

Oh, ok. Thanks @amoun . Well, if I connect my laptop to my phone and open the phone in safe mode, the blinking and flickering doesn´t appear for as long as the usb cable is connected. However, I can´t choose any of the options in USB-settings either. As soon as I unconnect the cable from the phone, the flickering and blinking starts again.

Interestingly, when I kept my phone attached to the laptop and switched the phone off and on again without the safe mode, the USB-settings appeared normally, without blinking and choosable for a while. The phone also seemed to be charging (a lightning icon in the battery icon). However, when I unplugged the cable and plugged it again, it never started to charge again and the usb-settings don´t become visible again, except from the searchbar. When I go to USB-settings via the searchbar, the same blinking goes on when I unplug the phone. Also, when the phone is plugged, the USB-settings don´t blink but they aren´t choosable either.

Also another observation. Very often, when I plug my phone to a laptop or a charger, the little led light turns on (as if it was charging), but the little lightning doesn´t come to the battery icon.

What is your opinion: Software or just dirt in the USB-port causing some kind of a short circuit or something?

I opened the phone and unattached/cleaned the USB-module but didn´t open the module yet. It had no effect. It appears that Finland has a nationwide shortage in isopropylalcohol so I couldn´t get it from the pharmacy. Just my luck. :smile: