FP3 No data/4G connection following LineageOS android 13 update

I have an FP3 with LineageOS 20 installed. Since upgrading to LOS20 - Android 13 the phone cannot connect to internet using data/4G. Several weekly updates later and the problem still exists. I’ve been reading the FP and Lineage forums to see if others have experienced similar issues and to seek a potential solution, but those efforts have been unsuccessful.

I’d be really grateful for any suggestions for a remedy. Many thanks.

Welcome to the community forum.

The forum search says:

Also … did you check whether the APN settings are still correct for your mobile network provider? Every provider has them online somewhere.

Thank you for that. Yes, the APN settings match those published by my network provider - I also own a FP4 and use the same network, so have copied those APN settings. I’m a little stumped by it. Thanks again

Some more things …

Thank you - I’ve tried each of these except the system reset or fresh installation, which I’m reluctant to do - it’s a work phone and I worry about losing data or text messages. Thanks for the suggestions, though.

Do you have VoLTE enabled? Of so try to disable? Does 3G/2G work or not mobile data at all?

Same problem here - since the “upgrade” to Android 13, mobile data on my provider´s network don´t work reliably and when connected to roaming network, mobile data don´t work at all (that is, in case I´m lucky and the phone kindly allows me to connect to the roaming network - which isn´t always the case). As I live on a border where network changes are frequent, my previously reliable phone has become useless. Also, connection to a wifi that´s not connected to the internet doesn´t work, so I can´t download pictures from my camera. Except for installing OS from scratch, I´ve tried the suggestions above and they don´t fix the issues.

I had the same issue with roaming in France and what fixed the issue for me was the combination of resetting the APN configuration to default. Manually deleting the previously working APN and rebooting the phone.

1 Like

Hello Andreas,
Many thanks for your reply. I’ll try that combination.

Thank you

I also have big troubles with mobile Data since I updated to Android 13.
I don’t reach homepages and News Apps or the train schedule App can’t get any data if I’m only connected via mobile data. On WiFi there isn’t any Problem.
BUT I receive WhatsApp messages via mobile data!!!

I reset all WiFi and mobile data settings and deleted the APN, rebooted several times and manually set the APN.

The first days after updating to Android 13 the connection worked fine. But in that time I was abroad, so I was connected via roaming…

I have no idea what to do.

Who is your provider and in which country do you live?

1 Like

what can I say? I’m quite an idiot… my monthly data plan was used up… But there were so many performance issues after updating to Android 13 that I couldn’t think of the most obvious possibility…
sorry for the trouble!


I had the same trouble after updating my FP3 to Android 13. A quick Google led me to try the simplest thing first… Power off for a short time and then back on again. Voila! I’m back in the land of data. Now to hunt for a new weather widget that seems to have disappeared in the update… :sun_with_face: :sun_behind_rain_cloud:

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.