Official LineageOS 20 for FP3/FP3+

About the microG-release, you are probably right with your suspicion. I use iode 4.1 (LOS 20 + microg + tracking-blocker), it is a beta-version that is already available, maybe that’s an option for you.

MinMicroG offers a magisk module with a modded playstore that is working fine for me (you don’t need MinMicroG for that). I am doing it like this for years at this point, I never heard that google would take action against it, after all they earn money with this because it enables in-app-purchase on the playstore for MicroG-users.

The upgrade went smooth. Almost everything works just like before.

The only thing not working: Signal Backups fail. It goes to 99,9% and then says backup failed. Using external storage for signal backups.
Clearing the cache in the App settings did not help.
Any ideas?

Thanks @TeamB58 for your awesome job.

For me, the backup works ok. But the destination is internal, and because of the settings (messages will be deleted after a week on my busy channels) only at 30MB

I think the only way is to install iode 3, install the updater app v3 from beta · master · iode / ota · GitLab and upgrade to 4 from there. Or what I did is, after installing the updater-app, I copied the link from the updater to download iode 4 ROM for a fresh install. Oooor if you can wait, i can later look on my PC if the URL is still in my browser history or I could send you the whole ROM which is still on my PC.

I don’t know why iode team is handling things this way sometimes.

EDIT: Here’s a link to iode 4.1 ROM in case anyone is interested.

1 Like

i just saw the Version 4 source code on Github releases…
So, I would just wait for the other images to pop up there and give it a try in the next few weeks when I have some time.
Thanks! :slight_smile:

1 Like

I upgraded yesterday and it so far, everything works. I had to reboot once to make the mobile Internet connection work. Other than that, it is fine, but I am a very basic user.

1 Like

I just found out that this is because it says the external SD card is full, although it is not. OSM keeps crashing too, may be because the downloaded maps are on this SD Card as well.
Ejecting it and reinserting it did not help.
I will investigate more and keep you all updated.

Using OpenMTP and deleting few maps of OSM from the Sd card helped create some space. However, strange: There were 40 GB of free space before the ugrade to Lineage OS 20. After the upgrade: 0.
Anyhow, I can now back up Sgnal to the Sd Card and OSM does not crash anymore. :slight_smile:

Did the update today, two things:

  • I’m now unrooted completely, but the OTA update still took very long and apps regularly force closed
  • the indication that location is used cannot be deactivated, even though i toggled the switch in developer options

I upgraded from LOS19.1 to LOS20, everything works, Thank for your work @TeamB58 @dk1978 .

Minor bug : at the bottom of lock screen I have incorrect informations about charging status. For exemple “in charge 73%” whereas I’m not in charge and have 20% of battery.

I can confirm that signal backups work in my external storage.

I haven’t tested the OTA updates yet.

1 Like

OTA worked fine here.

The upgrade (incl. MindTheGapps upgrade) acc. to Upgrade LineageOS on FP3 | LineageOS Wiki went fine. Great!

So far I noticed as problem: There was a notification “App-Updates are available. To continue connect to a network.” (translation from German) from Android Setup. It has no access to the network, although wifi was working e.g. in Play Store.

It often happens that after the updates the okay store (among others) lost the permission to access the network. Just check in settings - apps whether network access is allowed

1 Like

Always “fun” to find the right setting. Here with some German text:

Settings symbol
“Alle [nnn] Apps ansehen”
right corner dots → “System-Apps anzeigen”
“Mobile Daten und WLAN”
toggle “Netzwerkzugriff erlauben”

Now it works. Thanks!

1 Like

Guys, I have a problem. On my main phone that was on LOS 19 microG, I dirty flashed LOS 20 microG that just went out ( The reboot went smoothly. There was the same message as mentioned above. Also, the install of updated apps through Aurora would fail.

So I went for a reboot, and alas, the animated LOS logo stays forever. Reapplying the upgrade doesn’t fix anything. Any idea of what could be wrong? Is there any way to revert to a functioning phone?

Hi all,
Recently did a clean update from 15 to 19 with microg and magisks (wiped all my phone, used magisks to modify the microg rom and flashed it).
Did a minor OTA update without issue.

But what about major update? To update from 19 to 20, I have to do the same process (manually dl microg, modify it etc…)? Will I have data losses?


Well, beware of dirty upgrades (see my post just above, I fear I will have to wipe everything).

I wanted to wipe my internal and external storage anyway, so I might as well do it before upgrading to LOS20. What is the recommended way to wipe everything? In system settings or before installing the new ROM?


Dirty Flash from 19.1 here, everything works fine, thanks for your efforts!
Except for OTA, though: the LOS Updater app just disappears after I tap “Install”.

click to unfold stack trace

FATAL EXCEPTION: main Process: org.lineageos.updater, PID: 22840 java.lang.RuntimeException: Unable to start service org.lineageos.updater.controller.UpdaterService@f2d2145 with Intent { act=action_install_update cmp=org.lineageos.updater/.controller.UpdaterService (has extras) }: android.os.ServiceSpecificException: Could not change profiles (code 1) at at$$Nest$mhandleServiceArgs(Unknown Source:0) at$H.handleMessage( at android.os.Handler.dispatchMessage( at android.os.Looper.loopOnce( at android.os.Looper.loop( at at java.lang.reflect.Method.invoke(Native Method) at$ at Caused by: android.os.ServiceSpecificException: Could not change profiles (code 1) at android.os.Parcel.createExceptionOrNull( at android.os.Parcel.createException( at android.os.Parcel.readException( at android.os.Parcel.readException( at android.os.IUpdateEngine$Stub$Proxy.setPerformanceMode( at android.os.UpdateEngine.setPerformanceMode( at org.lineageos.updater.controller.ABUpdateInstaller.install( at org.lineageos.updater.controller.UpdaterService.onStartCommand( at ... 9 more

Anyone else having this behaviour?

I experienced the very same while trying to perform the very first OTA update after a dirty flash. After a All apps > ... > Show system > Updater > Storage and cache > Clear storage, all went fine and behaves normal since then.