English

FP3 Android 10 WiFi 5Ghz unavailable

UPDATE:

A few weeks ago I did the Factory reset. Well guess what. It worked…For about a week or so… Now it’s gone again and my FP3 is developing even more bugs over time (or I’m just noticing it over time)

Maybe I really do have to revert to Android 9 if all this continues. If Fairphone still doesn’t give a cr*p about fixing bugs, my next phone definitely won’t be the Fairphone 4. I’m probably going to switch to Shift. Just because I know they’re more reliable.

1 Like

You are right, there are more and more bugs, which are very annoying.
The “funny” thing: Not only the wifi band chooser disappeared, but also the “Keep on wifi during sleep”-chooser: Fairphone 3 loses wifi connection

After few month owning the new FP3+, I really don’t know what to do anymore. Dozens of bugs, no help from the support and not one single update to fix all these bugs. And even the Google security patches seems to be on hold. Latest patch was from October. November patches are missing, now it is already December.

I can’t comment on the bugs but IIRC the schedule for security updates has always been quarterly not monthly for the FP3. I don’t like this too much myself, but from my perspective this is not part of “an Android 10 desaster”.

2 Likes

Easy, boy. Even the Pixel lineup from Google has no December updates ready, yet…

2 Likes

Yes, sure. But we don’t even have the November updates. That’s what I meant :wink:

Oh, I did not know about that. Thank you for pointing this out! I just was used to get monthly updates from the other smartphone brands I had before.
You are right, the security updates are not part of this desaster. But the limitations while calling are - in my personal view. But this is even more off-topic, I am already in contact with the support since months to get back a normal calling-functionality :wink:

Sorry for off-topic!
So, if there are solutions or hints to get at least the missing menu items (wifi band chooser and wifi sleep chooser) back: Would be happy to know about!

This brings me to this question: Is there an option in adb to select the Wifi band? I did some research but was not able to find anything.
If somebody knows about this, I would be happy if you could share your experience!

Hey, I’ve just updated to the latest FP3 Android stock firmware and afterwards the Wi-Fi Band Option was gone from the Advanced Wi-Fi preferences + I’ve had 2.4GHz selected before the update so this option was still acitve completely disabling 5GHz for me.

After multiple reboots and back and forth I figured a way to restore the Wi-Fi Band menu option.

  1. Push power button until the power/restart/screenshot menu appears
  2. Push (and keep pushing) the “Power-Off” Option until a dialog for “Safe Reboot” appears
  3. reboot into safe mode
  4. go into wi-fi preferences, advanced => WiFi Band should show up again
  5. Select 2.5ghz, then “Automatic”, then reboot
  6. verify that Wi-Fi Band option is now available again

Warning about Safe-Mode: This will reset your home screen widgets, potentially do a screenshot so you can configure your widgets again afterwards.

Update:

When you are in Safe-Mode, @Simon1 workaround also included:

  • Set back/reset the network settings (system=>advanced=>reset options=>reset WiFi, Bluetooth and mobile settings)
  • (dont know if necessarry) restore default settings in the developer options (last setting in the dev opt list) and disable the developer options afterwards.
7 Likes

Yeah, that works! Great workaround - thank you :slight_smile:

Update:
There’s a big BUT! After normal restarting I noticed that my audio player app widget was no longer on my homescreen. Soon afterwards I received a call from a number I recognized but the contact name didn’t show. After the call I checked my contacts app and nearly all my contact details were missing. Fortunately I manually synch them with my email account as soon as there’s an update to one of my contact’s details, so I was able to restore the lost information. Be aware of this!

Cool!

1st I thought it doesnt work for me!

But after the following two steps it worked:

  • Set back/reset the network settings (system=>advanced=>reset options=>reset WiFi, Bluetooth and mobile settings)
  • (dont know if necessarry) restore default settings in the developer options (last setting in the dev opt list) and disable the developer options afterwards.

@sydpol
The network reset should be added to your howto! THX a lot for your research!

@hypnotoad
Disappearing of some widgets after saveboot is normal.
I sync my contacts with the DAVx5 app to my own private nextcloud server and nothing was lost or had to be restored after the saveboot. I recommend this setup to everyone!

1 Like

@Simon1 Did you do these steps in Safe-Mode as well?

@hypnotoad Here is the official Google documentation on Safe-Mode. Yes the Widgets are getting reset, the contacts problem shouldn’t appear and might have to do with some caching mechanism.

I was quite upset with the Wi-Fi issue appearing last night, glad I spent the time to register here and leave a comment. Have a nice New Year’s Eve everybody.

Thanks for the additional information! I wasn’t too concerned regarding the widget, but the contacts issue could have been rather frustrating :thinking:

Yes, the steps were made in savemode. And afterwards I had to restart in savemode again to get the select WiFi option.

Wish you a great new years eve, too!

Thanks! Reset Wifi in Safe-Mode worked for me.

2 Likes

I am baffled that I just found your solution some months after you posted it… It is working great, thank you very much!

Of course the widgets have to be done new, but that is not a problem.

I am doing the same; using DAVx5 with my own private server running nextcloud. But in my case after the saveboot: Contacts, calendars and tasks was empty without any content. Not a big deal, of course. Doing a new sync and everything was available again.

So guys - I think I found another workaround. Fortunately that one will not use the reset nor the safe-mode.

  1. Put your phone in airplane mode.
  2. Do regular reboot
  3. Enter settings menu of WiFi (be carefull not to turn WiFi on! so I recommend the longer way through the complete settings menu)
  4. You will see the WiFi frequency chooser on “Automatic” → toggle it to 5GHz*
  5. Now switch WiFi on / airplane mode off

*with me neither 2.4Ghz nor reselecting “Automatic” worked - I fear here is the problem of some kind of config inconsistency which will screw up the widget. So forcing a new setting aside from the default “Automatic” might do the trick for you. So if you had the “5GHz Option” before it went dark, I guess the “2.4GHz Option” will work.

That’s it! Still though, I think a “Solution” requires Fairphone to actually get rid of this problem…

As background info: I tested it once, and before I did it, I rebooted to safe-mode. Still I didn’t change anything - just confirmed that the option reappeared within the WiFi settings menu. The beauty of this rather unorthodox steps (instead of a well thought WiFi settings reset within safe-mode) is: your contacts will stay intact, your home screen will stay intact, your wifi list will stay intact. Beaware, if you reboot to safe-mode even once, that will or might not hold.

Thanks a lot - wouldn’t have gotten here without you!

(This bug happened to me just lately after the upgrade from FP OS A.0077 → A.0084)

7 Likes

Thank you very much!
Yesterday I was testing a WiFi extender, switched my FP3 to 2.4Ghz, and then the menu option to choose frequency band disappeared, leaving me stuck in 2.4Ghz.
Your simple steps brought the menu option back. Cudos!

Thank you so much for sharing your experience!

In my case the band switcher disappears again after disabling airplane mode at the end. :unamused:

yeah - it’s a nasty bug so I definetely can’t promise that workaround will fit everywhere :confused:
I can just recommend to give it another try. And to click through these options (just try using “2.4Ghz only” - check, else airplane mode & reboot. try “5ghz only” - check, else airplane mode & reboot). Don’t know if time is a factor too, so probably take a breath after having switched the frequency chooser.
I feel the most promising thing to do, would be to first try enabling wifi instead of turning off airplane mode.

Officially solved by software update A.0101 - let’s hope they are right about that. At least Update A.0084->A.0101 kept it for me :wink:
@sydpol definetely earned the solution point for timesaving :+1:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.