English

My FP3 doesn't like higher 5Ghz Wifi channels, especially channel 116

Hi guys, I wanted to say I was having some issues with my internet connection, which became most apparent during internet calls. The test here may help you to see if your settings have improved your phone’s connection (see the response times).

Just for info. I have a FritzBox 7530
a) you can rename the 2.4GHz and 5GHz SSID so you can connect to either.
b) Eventually I disabled the 5GHz in the FritzBox settings and I have no problems with the 2.4GHz connection,
c) I do have to restart the phone if I switch wifi off on the phone which I imagine is a seperarte issue

I can’t believe I found this thread only now. I was puzzled because my FP3 used to have problems with 5Ghz on some days, but not on others. Obviously, my FritzBox 6490 selecting the channel automatically explains that. Today it was extremely unstable again, and lo and behold, channel 116. I’ve set it to channel 52 now, everything fine so far.

4 Likes

Just in case anyone wondered: Same problem with the new update 8901.3.A.0077.20201221 that was released yesterday. Channel 116 is super flaky/slow, so I’m back on channel 100 (switched from 52 to less crowded 100 a while ago).

PS: I’ve just upgraded from Android 9 to 10.

Does anybody know whether this is being looked into by Fairphone? Do we know if it’s a software issue or an unfixable hardware/design bug?

I’ve switched my phone to 2.4 GHz only for the time being as I’m often connected to routers I have no control over.

I have nothing of inside information or support feedback - but stumbled upon the licensing certificate within the “About Phone” settings category.
I fear we can mark this “wont fix” (or someone checks if a FP3+ has a different wording), I quote:

“The 5GHz wireless LAN frequency band is restricted to indoor use only throughout the EU”

Having looked up what the indoor use bands / frequency areas are, I fear that this is correlated to the observations of connection problems above band 100, as the area of strictly indoor use is in the range below. Compare here i.e.
On that page is written in german the recommendation to use the lower frequency bands at the access point, as was pointed out as a workaround here earlier already.
Considering that there now is a workaround to reliably have the frequency chooser within the WiFi settings menu, I can just recommend to use the 2.4GHz only option if you fail to connect to a network where you don’t have administrative access.
BTW, my wificountrycode reads US too, and reading the licensing I’d expect that to be the least restrictive option already. Deducing it might be an hardware thing which motivated that licensing.

2 Likes

@waldie Interesting find - But I dont think it’s the explanation here. I rather think it’s an (outdated) standard license text. Before DFS was introduced (years/decades ago), 5GHz WAS only allowed indoors in the EU. DFS was introduced to change exactly that. So today (and for years) that ist not an issue anymore. Additionally, We are all talking about indoor use anyway. Even before DFS, channels above 52 we’re allowed in the EU - Limited to Indoor.
So that does not explain the issues.

I would ask if any Fairphone official could give a statement in the situation. Will the bad performance/instability on high 5 GHz channels get fixed eventually?

1 Like

This is only a user forum you can contact support@fairphone.com for their understanding.

The company Sporton Int inc who researched the FCC compliancy for FP approved it for the whole range indeed in 2019 here. So I would say you doubted my finding correctly :wink:
I was quite fascinated by that paper, and just now managed to have a decent connection to my FritzBox 6490 standing in the same room up to a distance of 3m explicitly on channel 116. The FritzBox claim a connection of 300-500Mbit/s depending on distance (and during active usage, so I trust these values). This drops heavily once I have just one wall in between. Combination of wall+distance ~5m makes it impossible for me to even establish a connection on channel 116, which was the sole research I did for my earlier post. I don’t experience that bad quality for every channel above 100, but it is not the only one either.
I think it would be quite interesting to know how other devices with same chipset behave on channel 116 in comparasion to channel 52 or so on the same device.

BTW, as here is mentioned to connect to public 5GHz WiFi it is not so clear, that we are all talking about indoor use only.

Since it’s been a while since somebody mentioned FP support in November 2019 (!) I made a support request (#430922) about this issue. I mentioned this thread but the support person completely ignored what I wrote and sent me a wall of text with general WiFi troubleshooting tips. On the plus side, it only took three days… To be nice I actually went through all the steps and made all the requested screenshots, and then asked again about progress on this issue. Let’s see if it goes anywhere.

2 Likes

This wiki page shows the 5GHz channels and the bandwidth for each. For example you wills see channel 116 and 118 use the same bandwidth with the later using the 20MHz of the 116 and another 20Mhz higher.

So there could be interference.

You will note from the wiki that from channel 50 up the signal strength is only 500mw which means there is likely to be a huge drop off in viability given the inverse square rule over distance.

The 500mw is for indoor use and if there is a local outdoor signal of higher strength that may also interfere.

You support request may turn up something interesting, but I note asking technical questions isn’t something I’ve had a sensible response to.

You may also be interested more on the conditions that would allow channel 116 to be used.

Thanks for the information, but this is not a general problem. We have 7 devices in our house that use 5GHz WiFi. The only ones having trouble with it are the two FP3s.

2 Likes

So all the other device can use channel 116, do use differnt channels if all the devices are being used at the same time or do you rely on automatic channel selection, and if so do you know what channels are being used etc.

Apologies if you’ve already checked all that.

No problem. All the other devices just work with the router set to automatic channel selection. Not a single disconnect ever. The FPs sh*t their pants whenever the router selects a channel with a high number, especially 116, or when I set one manually. I’ve seen exactly the same with other AVM FRITZ!Box routers my phone connected to.

2 Likes

From the FRITZ!OS 7.24-84849 changelog:

  • Fixed - In rare cases, multiple radar wait times occurred in the 5-GHz band followed by lost connections
  • Fixed - In rare cases, the 5-GHz connection to the FRITZ!Box was lost
  • Fixed - When Wi-Fi standard switched from “11a+n” to “11n+ac”, problems with channel assignments occurred in some cases

Source: FRITZ! Lab | Updates & improvements | AVM International

2 Likes

Thanks @DeepSea. If one of the “rare cases” is the Fairphone that would be great. As I wrote, all my other devices work fine with the Fritzbox. It’ll probably be months though until my provider pushes the update to my Fritzbox (I’m on version 7.20).

Does anybody have a Fritzbox with version 7.24 or later and can confirm that this solves the problem?

It doesn’t. I’m running FRITZ!OS 7.25.

I contacted AVM support because I noticed that at least my box would not return to a fixed channel I set manually. You can set a fixed channel manually, which avoids the problem, but the box will still switch to a different channel when it discovers interference, so far so understandable. However, the box should switch back to the channel which was set manually once the interference is gone according to AVM documentation, and my box never does that (at least it seems like that to me).

Support was helpful in listing options I could change, basically amounting to avoid 5GHz for troubled devices, which I don’t want to do because 5GHz works totally fine on channels below 116.
And they said if the box didn’t return to the fixed channel, this would mean the interference wouldn’t be gone. But I can set the channel just fine manually again when I discover connection trouble, and then the channel works fine for a while again.

Since the internet tells me the Fairphone 3 is not the only device troubled by channels 116 and upwards, and since the internet tells me there even are devices supporting only a few channels at the bottom of the range up to channel 48 or something, I proposed that AVM could implement a setting so that the user could set a range of channels which the box would limit its attempts to change the channel to due to detected interference.
Support said they forwarded this for consideration. With this, at least the issue at home would be avoidable reliably. As for being somewhere else, I accept WiFi as flaky tech along with USB and Bluetooth … it works, unless it doesn’t for (too) often mysterious reasons, not much use to expect or bother too much :slight_smile: .

5 Likes

I guess I was lucky then. I never had problems with WiFi (except with Fairphones) or Bluetooth (except with Fairphones), and none, ever, with USB. Anyway, thanks for the detailed explanation!

After introducing a new Fritz!Box 7590 into my network two small WLAN-5GHz-Bridges stopped working from time to time. Turns out the router detected RADAR (sic) disrupting channels 52 to 64 and changed the channel overriding my manual setting (44) to 112.

The default setting for 5 GHz WLAN is “Wi-Fi 5” (n+ac) and the router wants to use 160GHz bandwidth (8 channels). The two bridges either follow USA rules (channels 120 to 128 forbidden) or asian rules (all channels above 64 forbidden) and stop working.

Having no chance I had to lower the Wi-Fi standard to 4. Now the router only “needs” two channels and works stable on channel 44 - including a Fairphone 3+ as one client :wink: .

2 Likes

Interesting, but unfortunately it still seems to depend on local circumstances.

I’ve set the 5GHz standard to 802.11a+n (Wi-Fi 4) for other compatibility reasons (some device didn’t like ac), and I tried to fix the channel to everything below 116, but my FRITZ!Box 6490 Cable will inevitably switch at some point due to interference.
It didn’t switch a noticeable while now from the currently set channel 100, but I tried this channel before, too … it will not last, I’m afraid.

For 2.4GHz FRITZ!OS already has a setting to enable/disable the use of channels 12 and 13 for auto channel. So they should be able to introduce a similar setting for 5GHz. Seeing that there are different device compatibility levels out there I just want it to be somewhat flexible, so I proposed to be able to set a channel range. Let’s see what they do.