English

My FP3 doesn't like higher 5Ghz Wifi channels, especially channel 116

Does your FP3 connect to the fritzbox after switching off the repeater?

Hi, my FP3 Wifi on Channel 116 was very flaky too. Fritzbox 7560 OS 7.12. On Original Android and on /e/ Version 0.9p2020051454091. Fixing 5GHz to Channel 52 did resolve the issue for me.
greeting, bodo

3 Likes

I had a Fritzbox 7581. The 5GHz could not connect to the FP3 or the FP2 of my friend.
Now I have a Fritzbox 7590 and the setting for the wifi channels is on automatic.
I get a very good signal on channel 100, so is the FP2. I am in Tilburg, the Netherlands.
I am on /e/. Didn’t have the Fritzbox 7590 when I was on orginal android.

Could reproduce
Fritzbox 7590 in an environment with several 2.4 GHz networks and very few 5 GHz networks.
Fairphone 3 on current patch level randomly lost wifi connection on channel 124 and 116, was being automatically steered to 2.4 GHz by the router. Switched 5 GHz Autochannel to 5 GHz channel 52 enforced and haven’t had a single drop since. I didn’t switch on the 160 MHz channel width though.

4 Likes

I also had this issue and pegged my router to a lower 5 GHz channel and it’s been happy since! Unfortunately it seems higher channels are default on public wifi, since those still get dropped and then “disabled” on 5 GHz.

I also can confirm that my WiFi seems more stable (still not perfect), with my 5GHz configured to use channel 52 on a new AVM FRITZ!Box 7590. Are there now opensource WLAN drivers we could integrate into the FP2/3 LoS builds @chrmhoffmann?

2 posts were split to a new topic: Fairphone 2 Wi-Fi reception drops using channel 120

Hi guys, I wanted to say I was having some issues with my internet connection, which became most apparent during internet calls. The test here may help you to see if your settings have improved your phone’s connection (see the response times).

Just for info. I have a FritzBox 7530
a) you can rename the 2.4GHz and 5GHz SSID so you can connect to either.
b) Eventually I disabled the 5GHz in the FritzBox settings and I have no problems with the 2.4GHz connection,
c) I do have to restart the phone if I switch wifi off on the phone which I imagine is a seperarte issue

I can’t believe I found this thread only now. I was puzzled because my FP3 used to have problems with 5Ghz on some days, but not on others. Obviously, my FritzBox 6490 selecting the channel automatically explains that. Today it was extremely unstable again, and lo and behold, channel 116. I’ve set it to channel 52 now, everything fine so far.

4 Likes

Just in case anyone wondered: Same problem with the new update 8901.3.A.0077.20201221 that was released yesterday. Channel 116 is super flaky/slow, so I’m back on channel 100 (switched from 52 to less crowded 100 a while ago).

PS: I’ve just upgraded from Android 9 to 10.

Does anybody know whether this is being looked into by Fairphone? Do we know if it’s a software issue or an unfixable hardware/design bug?

I’ve switched my phone to 2.4 GHz only for the time being as I’m often connected to routers I have no control over.