My FP3 doesn't like higher 5Ghz Wifi channels, especially channel 116

No problem. All the other devices just work with the router set to automatic channel selection. Not a single disconnect ever. The FPs sh*t their pants whenever the router selects a channel with a high number, especially 116, or when I set one manually. I’ve seen exactly the same with other AVM FRITZ!Box routers my phone connected to.

2 Likes

From the FRITZ!OS 7.24-84849 changelog:

  • Fixed - In rare cases, multiple radar wait times occurred in the 5-GHz band followed by lost connections
  • Fixed - In rare cases, the 5-GHz connection to the FRITZ!Box was lost
  • Fixed - When Wi-Fi standard switched from “11a+n” to “11n+ac”, problems with channel assignments occurred in some cases

Source: FRITZ! Lab | Updates & improvements | AVM International

2 Likes

Thanks @DeepSea. If one of the “rare cases” is the Fairphone that would be great. As I wrote, all my other devices work fine with the Fritzbox. It’ll probably be months though until my provider pushes the update to my Fritzbox (I’m on version 7.20).

Does anybody have a Fritzbox with version 7.24 or later and can confirm that this solves the problem?

It doesn’t. I’m running FRITZ!OS 7.25.

I contacted AVM support because I noticed that at least my box would not return to a fixed channel I set manually. You can set a fixed channel manually, which avoids the problem, but the box will still switch to a different channel when it discovers interference, so far so understandable. However, the box should switch back to the channel which was set manually once the interference is gone according to AVM documentation, and my box never does that (at least it seems like that to me).

Support was helpful in listing options I could change, basically amounting to avoid 5GHz for troubled devices, which I don’t want to do because 5GHz works totally fine on channels below 116.
And they said if the box didn’t return to the fixed channel, this would mean the interference wouldn’t be gone. But I can set the channel just fine manually again when I discover connection trouble, and then the channel works fine for a while again.

Since the internet tells me the Fairphone 3 is not the only device troubled by channels 116 and upwards, and since the internet tells me there even are devices supporting only a few channels at the bottom of the range up to channel 48 or something, I proposed that AVM could implement a setting so that the user could set a range of channels which the box would limit its attempts to change the channel to due to detected interference.
Support said they forwarded this for consideration. With this, at least the issue at home would be avoidable reliably. As for being somewhere else, I accept WiFi as flaky tech along with USB and Bluetooth … it works, unless it doesn’t for (too) often mysterious reasons, not much use to expect or bother too much :slight_smile: .

5 Likes

I guess I was lucky then. I never had problems with WiFi (except with Fairphones) or Bluetooth (except with Fairphones), and none, ever, with USB. Anyway, thanks for the detailed explanation!

After introducing a new Fritz!Box 7590 into my network two small WLAN-5GHz-Bridges stopped working from time to time. Turns out the router detected RADAR (sic) disrupting channels 52 to 64 and changed the channel overriding my manual setting (44) to 112.

The default setting for 5 GHz WLAN is “Wi-Fi 5” (n+ac) and the router wants to use 160GHz bandwidth (8 channels). The two bridges either follow USA rules (channels 120 to 128 forbidden) or asian rules (all channels above 64 forbidden) and stop working.

Having no chance I had to lower the Wi-Fi standard to 4. Now the router only “needs” two channels and works stable on channel 44 - including a Fairphone 3+ as one client :wink: .

2 Likes

Interesting, but unfortunately it still seems to depend on local circumstances.

I’ve set the 5GHz standard to 802.11a+n (Wi-Fi 4) for other compatibility reasons (some device didn’t like ac), and I tried to fix the channel to everything below 116, but my FRITZ!Box 6490 Cable will inevitably switch at some point due to interference.
It didn’t switch a noticeable while now from the currently set channel 100, but I tried this channel before, too … it will not last, I’m afraid.

For 2.4GHz FRITZ!OS already has a setting to enable/disable the use of channels 12 and 13 for auto channel. So they should be able to introduce a similar setting for 5GHz. Seeing that there are different device compatibility levels out there I just want it to be somewhat flexible, so I proposed to be able to set a channel range. Let’s see what they do.

Although you probably mean 160 MHz, maybe you can configure your router to use up to 80 MHz, otherwise radio could collide with other WiFi devices more often, including RADAR…

According to List of WLAN channels - Wikipedia , channels 120 to 128 are allowed. And regarding Japan: Do you mean indoor use?

I don’t think there is a problem. In Europe (NL) channel 116 is the maximum selected channel. If you have 80Mhz bandwidth the max.freq. of the ac spec is reached.
That being said. I tested the wifi network at channel 116 and experience no problems.
(Download speed reached 270mbit/s)

:zipper_mouth_face:

I was wrong about channel 116. The router from my provider doesnt apply that channel setting. Sorry!

1 Like

Does your router work with higher channels?

After further investigating I realized I had to reboot the router to enable the channel 116.
I used this channel with no problems on the Fairphone but the wifi adapter from the PC didn’t like it at all. Download speed on the PC was cut in half. So I’m on channel 56 now.

I can’t use a higher channel. Those are not available in the EU, as I explained

Take a look here, please: List of WLAN channels - Wikipedia

Spoiler: The higher channels are available in the EU…

2 Likes

Yes you are entirely correct, sorry.

I was able to play with a router that has channels 36 - 128 available. At channel 120 my Fairphone 3+ does okay. Beyond that it struggles with keeping a connection and has a very very poor bandwidth.

1 Like

Progress, of sorts, with my support request about this problem. 12 days after I uploaded a series of screenshots from my FP3 that support had asked for, including one with the build number, some friendly but confused person asked me to please verify that my Fairphone 2 is running the latest software. :roll_eyes:

It’s a bit like talking to a really bad chat bot, except each response takes weeks…

However, when I politely pointed out the error, the support person replied after only one day that they’d have to “ask for advice from the relevant department”. So there’s hope. Maybe.

1 Like

There’s this word ‘hope’ that the future will be fairer but not necessarily to me.

Some routers do not detect other radio sources that are broadcasting on the same frequencies, such as RADAR stations (e.g. for weather services), maybe your model is not capable of detecting them either…

Ah, they have not updated their common text blocks, yet…

They have! They sent me their FP3 text blocks first (all of them it seemed), and then the FP2 text block after I’d responded to the first message.

1 Like

Seems like support needs support…

2 Likes