English

FP2 reboots in certain wifi networks

What you’ve applied is what we call a workaround.

I’m happy you do not suffer from the reboot issue anymore, but I’d be happier if we figured out what exactly caused the problem. Because then we can -perhaps- solve it, or at least document it better. At the very least your case, as far as it is documented, adds in that sense.

#wifireboots

3 Likes

I agree with you.
If there is anything I can do that would help let me know.

Yes, there is - but it’s actually more work as usual with the remaining 5% to finish.
Since we now know it has something to do with your 2,4GHz wifi a deeper investigation
would be useful.
The more simple steps first would be followed by the more technical and complex tasks.

  1. Restart your router once (one power cycle) and wait until everything is up and running again (may take up to 5 mins.)
  2. Get a free network analyzing tool like e.g. net analyzer (lite) from the Google play store
  3. Use the (easy to use) tool and provide us with some more basic info such as:
  • Which type of network encryption are you using, tkip; ccmp or the latest wpa2 (AES) ? (recommended)

  • Which network ̶p̶̶r̶̶o̶̶t̶̶o̶̶c̶̶o̶̶l̶ band are you using (should rely to the 802.11??? wifi standard)
    (in your router config)
    802.11n (ok)
    802.11g (ok)
    802.11n+g (ok)
    802.11n+g+b (troublesome)

Read the wiki here:

Make sure this mode b is not active, change the mode if actually set in your router.
It could only affect your mobile and not the bitten fruits :wink: as there probably are
chipset/driver differences.

  • Is your network ssid hidden or publicly presented so it can be seen by others?
    I had devices having troubles to reconnect to a hidden network after being properly registered to its unhidden ssid.

  • If there was no hit yet try to take some snapshots of this net analyzer tool (power
    button+volume down).
    Here we can see the signal reception strength, channel usage and overlap with other devices, connection speed to your router, encryption mode set etc.

looks like: (clear sensitive pieces of information using an image manipulation tool e.g. m$-paint/gimp)

or

  1. Clear the (2,4GHz) registration on your FP2 + the device from the list of permitted devices in your APs wifi list.
  2. Re-register the FP2 again (2,4GHz) taking the above mentioned into account and see if things are better (maybe this guide can assist you)
  3. If not check if a firmware update for your router is available to fix an issue

Any more rigorous steps like resetting and reconfiguring your router etc. are quite extensive and would also affect other devices using the router.

  1. If nothing helps - perform a Guru meditation session and remain on 5GHz smiley
    .
    .
    .
    Any other ideas what could be done to nail this cause (without replacing the hardware)?
7 Likes

Wow, that’s a lot!
Maybe - if @yvonnee has some terminal for her router - she can check the settings for encryption and network protocoll without having to install some app on her phone via this software.
Even if it’s just to make sure, there are no troubles being imported by installing another app. :wink:

@yvonnee if you don’t have a google account, you can get the free apps from the playstore using “Yalp-store”, that can be installed from f-droid. (Ok, that’s even one or two more apps to install; so much for my first advice. :roll_eyes:)
https://f-droid.org/de/packages/com.github.yeriomin.yalpstore/
An alternative to yalp is “Aurora-store”, that - in fact - is a fork of yalp:
https://f-droid.org/de/packages/com.dragons.aurora/
(Anyone any experience with this store? I just use yalp so far.)

That’s just some minor remarks to the (as far as I can judge it) great advice by @Patrick1.

I keep my fingers crossed for you.

3 Likes

Yes, these are the last five 5% as I always could experience prior to finishing a job completely.

Yes, of course that’s a valid point too.
She may as well dig into the routers configuration which as many these days may offer some kind of web mask.
My thought was about having a view from the handset side how the connection is seen there. The apple phones are working, so the wifi may be set up correct, anyway due to unknown reasons her FP2 faces troubles.

This could be an extra benefit for our community to provide better advice for future cases suffering network related troubles. At last her phone works fine with 5GHz now.

2 Likes

I don’t have time today or tomorrow but I will try to do this investigation soon.

haha I really would not know whether I have a terminal for my router?

I have a google account so I will try the app @Patrick1 suggested

2 Likes

well I tried this but it was not easy to use and I can not provide you with the information you asked. maybe I did something wrong but I could not find the network encryption or the network protocol in the net analyzer app :disappointed:

1 Like

Well, tech savvy people regularly tend to underestimate the complexity of such things :yum:
Do you get any of the screens @Patrick1 has pictured above?
The middle one at least shows the encryption; on the right hand side (WPA2).
Information on the protocol, I don’t see in the picture above. :frowning:

Edit:
I just tried some network analysers myself.
Most need GSF (Google Services, if I got it right).
More important yet, it seems, that with Android 6, the Location Services might need to be activated. Do you have this service turned on?

1 Like

@BertG

True…

Ehm, yes sorry. This piece of information again would have to be checked in the APs configuration. My Fritzbox offers these protocols:

protocol

@yvonnee

I am sorry if this tool is not yet as self explanatory as needed. Hopefully I can lead you a bit further.

There are only two information pages needed to be selected.
I don’t know how the default setup is after being installed and started for the first time.
But on the left hand side there is the menu from which you can switch to two analysis pages providing many of the interesting pieces of information.
Should look this way:

Tapping this gets you here:

Tapping any of the marked should bring you to the upper familiar screens and you may also scroll if necessary.

I hope this will get you further.
Sorry for the inconvenience.

1 Like

thank you @Patrick1 and @BertG !

I have 1 question left:

Where can I find the above information ?

all the rest I found thanks to your clear explanations :grinning:
see the following screenshots (my wifi is ziggo DAFBC and ziggo DAFBC-5G)

I am really curious what you make of this …

2 Likes

Thank you, almost perfect. :ok_hand: The information screenshot both times show the 5G setup…:wink: but anyway let’s see what we have here

So as we can see the handshaking was successful. The network connection at the time was properly established. Signal reception looks ok too. You are using the most common encryption type WPA2 with AES. Nothing to do here.
5GHz frequency looks ok, no overlap and you don’t face any troubles with it.

Generally spoken, the cause of your problem must not necessarily be your router but another one (different network) interfering. You can only reconfigure your 2,4GHz network which hopefully solves the problems.
Looking at the 2,4GHz frequency there are others, but they are far apart. Yours do fully overlap with the yellow. This looks a bit strange anyway.
All the others, even on my screenshot are using ~4 channels. The yellow network is spread over ~8 channels and even has a stronger signal than yours, which is not very common. So there is not much room to spread.

One side story here: I knew people who encountered massive problems with their handsets using 2,4GHz wifi at home. They also used an analyzing tool and found one signal spread over the entire range from channel 1 to 13 and it was strong although obviously from another neighbor. The network name sounded like some type of high-class industrial wifi access point, nothing ordinary. And it seem to pump with 100% signal strenght. So many other neighbors had troubles with their common Netgear, Fritzbox, DLink etc. APs to get their wifi reliable up at home having only limited signal strenght and reception.
As this neighbor was no renter but apartment owner he did not open the door for anyone. So no one could do much about it.

In your case this yellow network does not look like a standard setup. This may be the culprit causing interference with your 2,4GHz connection. I once gave you a link in a previous reply to an online setup guide for your specific Ubee AP and I have read some more into it (also a Belgian manual and screenshots of the interface can be downloaded here if you are missing them), specifically the wifi channels part.
It is commonly recommended to use one of the channels 1,6,11, but mostly as a standard setup the auto mode is active and no one can tell where you will end up. This is fine, as long as you don’t have troubles which is not the case for you.
Manual switching then is necessary (it can only become better). Furthermore it is then advised to:

Before changing anything on your routers setup, please use it’s configuration backup option!

Now you could try out channel 1 or 13, maybe this solves your problem already.
If not, as it slightly shimmers through the 2,4GHz label you are on channel 8 (the 2,4GHz information screen is missing here). To fully overlap with the yellow network switch to channel 6. If this also does not help at last the channels 3 or 11 could be tried.
No one can tell for sure how this yellow network is setup. What I can see it’s the only one using 40MHz, not 20/80Mz which is a special mode not very often used. It’s a DrayTec device which is using the 40MHz mode to improve performance by logically using more than one channel at once. If it’s not installed in your household it seems to be a nearby neighbor also not having limited his signal strength to his living space.
This could explain why both other 2,4GHz networks are spread to the fullest using channel 1 & 13.
While I was reading through some relevant chapters of the online guide (mainly by examining screenshots) and found you could also go through the wifi chapters and compare the 2,4GHz settings with the 5GHz settings. Many options should be equal.
I am a bit impressed by the features and all these available configuration options, pew. Rather something for network specialists.

In the part “Wireless2.4GHzRadio”
I could find the network band option.

In the part “Wireless2.4GHzAdvanced”
I could not find the option for the specific wifi band (802.11b/g/n/ac/…) it may use. I could only find keywords such as 802.11b Only --> XPress™ Technology Disabled Enabled 802.11n Protection Auto Off

According to the wifi standard wiki the b mode is one of the oldest and should be avoided for the reasons mentioned above (from the same wiki page).
If this so called Xpress mode means 802.11b mode better disable it for 2,4GHz and see how things are going.

At last since there is a backup option for your settings there may be a firmware update available at www.ziggo.nl/software.
This could also help if nothing else did by now.

Hopefully with all of this you are able to tackle down this curious problem on the 2,4GHz side.

Good luck.

5 Likes

Thank you @Patrick1 ! for your detailed explanations.
I need to sit down and read this carefully to understand all of it but I will try your suggestions later.

I wanted to be perfect :wink: so below the missing screenshots

2 Likes

Perfect :smiley:

As I assumed your actual 2,4GHz channel is 8. The connection also is properly established as the handshake state shows.
According to the mentioned wifi channel guide channel 6 would be a better place, but I believe moving (completely) out of this yellow network range would have a better effect.

After all I wonder how the other handsets operate. You wrote there were more iPhones in your household. Do they use the 2,4GHz or the 5GHz network?
If they are on the 2,4GHz net, do they never have any network problems? (dropped connections, timeouts when using a browser, stuttering youtube videos things like that)

For me it looks like your phone operates properly (as you can see when using the 5GHz network).
But if there is network interference it can show up in different unpredictable forms. It can be that surfing is not reliable working. But in heavy cases the entire connection (reception) can be unsteady. So your phone is busy permanently reconnecting to the AP and even therefore data packets have to be exchanged to get the connection up again. Corrupted data packets could cause such a behavior.
There are plenty of wifi transceiver modules on the market. It’s most sure these iPhones keep different ones than our FP2.

3 Likes

The other handsets as wel as my laptop operate on the 2.4 ghz wifi and i know they all have short wifi connection problemes sometimes. I actually thought that that was normal :roll_eyes:

2 Likes

Now this puts a slightly different view on the entire situation.
Initially it looked like only the FP2 had problems and the other devices weren’t even bothering with network issues.
So, yes - I think we are on a good way to finding a solution.

If everything is setup and performing well there should never occur any wifi problems as long as the AP and Internet Service Provider are doing their job.

Usually your wifi is setup (configuring the AP), all devices registered and then it should simply stay available. You may disable or enable wifi of any device (computer/phone even the AP itself via wifi on/off button) at any time and the reconnect should be done flawlessly within a few seconds. That’s the way I know it and how it actually should work (in a way like to plug in an invisible network plug :wink:).

1 Like

Oke so if i understand it correctly and as we already suspected my wifi is the problem. The difference between my FP and the other devices is that my FP reboots when loosing the wifi connection and the other devices will reconnect to the wifi without rebooting.

2 Likes

Yep, that’s my conclusion.

That seems to be the individual reaction to your wifi problem.

So the initial thing you should do is to assure a proper (stable) wifi network which hopefully isn’t disturbed by other networks (I can only see the yellow network as being unusual).
Once your network is stable your devices should also keep a reliable connection.
Reactions on a faulty network can be very different. It depends on hardware and also software (the drivers). There should be some kind of error/exception handling going on if the device encounters instability/errors with the wifi network. But these are very specific and internal processes usually only developers know in detail.

A troublesome wifi network may not bother the device and only cause reconnects or a poor performance.
But in worst case if the error handling cannot deal with the situation the wifi of a device may get stuck or the driver could crash (which again has to be handled by the OS kernel having its own exception handler).

Things are getting complex from here on. :sweat:

BTW. If the 2,4GHz issue cannot be solved by any means now, maybe give it another try when having updated to Android 7.

3 Likes

Hi, I’m new here (actually got a fairphone for 3 years now but new to the forum) and I signed up here because I have the same issue with my phone rebooting when trying to reconnect with the wifi in my new flat. Before there that was hardly ever a problem. My question now is what can I do about it? Is this solvable or do I need another wifi? And will the new update help with this issue?

Edit: No, @paulakreuzer, better not close this topic. Surely I read the rebootsguide, but about this specific issue there’s no help, exept on this page. Maybe @Patrick1 knows how to solve the issue.

@AlexandK #welcome to the forum.
Since you are new here I assume you don’t know the #rebootsguide yet? Click the blue link to find lots of tips for fixing reboots.


Since this topic was quiet for 3 months I’ll now close it and redirect to the general topic about reboots: FP2 random reboots - see #rebootsguide for help
Please continue there if you have further questions.


Okay since this topic is about specific reboots caused by wifi networks and it’s even linked to from the rebootsguide I reopened it and changed the title to something more descriptive.

2 Likes