English

UI crashing after playing bluetooth audio

LineageOS 15.1-20181022-NIGHTLY-FP2
Baseband firmware: 4437.1-FP2-0-08
no GAPPS installed

Frequently, when I start playing music through my Bluetooth Headset (Teufel Move BT) the UI of ‘Vanilla Music Player’ becomes unresponsive and no music is played. After about 2 min the system crashes and reboots. After the reboot, playing music through BT works fine for a while.

From the logcat it looks as if AudioFX is crashing repeatedly.

Any ideas on the source of this issue?

EDIT: The issue seems to be with ‘Vanilla Music Player’. I have been using DSub for a while, and the problems disappeared. Hopefully a futur update will solve the issue…

1 Like

After reading through this topic I somehow got the impression although the player is often recommended it still seems buggy.
Have you tried another player just to verify the simple playback functionality e.g. MXPlayer / VLC which work pretty well for me via BT earplugs.

In some cases there may be a delay when using BT audio. MXPlayer has different routines to handle this.
Maybe you have some kind of runtime delay causing the crash. Have you tried to use Vanilla… without BT active (using headphones via the conventional audio jack if available) just to see if it crashes anyway after some time?

Have you tried without active wifi?
and here
I am just guessing.

Could you try without AudioFX to see whether the fault lies there?
You can deactivate the AudioFX App in the Settings.

Some background …

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.