Help with Vanilla Music / Cover fetch needed

after recommendations I moved to Vanilla Music und installed the Cover Fetch plugin. That almosts works. Almost means: Once I fetch a conver from the net, I want to save it to the folder where the MP3s reside (on the SD card).

But when I confirm “write to folder.jpg” I get the error message “Nothing selected from SAF file picker, exiting”.

What does this error message tell me? I did not get a dialog where I could pick something. I did get that once, but all I got there was an info screen that told me how I would have to select the SD card “SD card access required, steps below”. But that come only once, now I only get the SAF file picker error…

Obviously Vanilla Music can access the SD card, otherwise it couldn’t play the music. Is it that Cover Fetch needs that permission, too? How could I grant that? The “steps below” do not seem to fit…


I looked into the seetings. Both Vanilla Music and Cover Fetch seem to have read and read/write access to the SD card, so I do not understand what’s going wrong here?

Oh, btw, maybe this matters: I run FP Open OS 18.04

1 Like

Maybe related: I cannot delete songs from Vanilla Music. When selecting “delete” there’s just a note saying something like “0 songs deleted”. Vanilla Music got all permissions it asked for. The songs are on my external SD card. I’m pretty sure some Vanilla Music updates ago this worked.

I’m using latest FPOS, latest Vanilla Music from F-Droid.

I have seen something similar today. Even when I deleted the song through USB it would not go away and report “0 songs deleted”. I guess this is a bug. Re-reading the entire music library helped. Also, I had an issue with a wrong cover and it would not accept the correct cover even after placing it deliberately into the folder and renaming it folder.jpg. Re-reading the library cured this, too.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.