FP2 reboots in certain wifi networks

Do you get any reboots if you connect to another WiFi?


Yes, I tried that before sending it to the headquarter, unfortunately that was not the reason

Since yesterday evening I connected my phone to my 5 GHz wifi, I also put the sim card in but I did not instal third party apps.
There were no reboots last night :grinning:

this morning I installed whatsapp and went to work where I have no wifi, After work I returned home and the wifi is on since then and still no reboots :smiley:

The difference is that I am now connected to the 5 GHz wifi, I do not see how this can solve the problem but I am happy if it does.
But I will see how it goes…


I do not remember but I believe not. But I will try that tomorow


@Patrick1 Thank you for your help and the expanation :smile:


Can you ask the owner of that WiFi what kind of AP they use for 2.4 GHz and 5 GHz?

1 Like

Yes I can but first I would like to know what an AP is ?

1 Like

I used the wifi at my work today and I had no reboots :slight_smile:


Access Point, the device your FP2 connects to, wirelessly.

At this point it will benefit you if learn the difference between 5 GHz and 2,4 GHz.

In summary:

2,4 GHz is rather crowded (more chance for interference), a bit longer range than 5 GHz, allowed outdoor and indoor, slower than 5 GHz.

5 GHz is not very crowded (less chance for interference), a bit shorter range than 2.4 GHz, allowed indoor only, faster than 2.4 GHz.

Both have their + and -. All devices with WiFi can do 2.4 GHz, 5 GHz not. So you see 2.4 GHz is the default with APs if it can only do one. Many devices these days can do both though.

Now, if you use NS trains or stations, they only provide 2.4 GHz. So if you never use the 2.4 GHz you may miss out on those. I’m curious if your phone would crash if you’d use 2.4 GHz WiFi there or if it is ONLY at work where your phone crashes?


This looks very promising.


Thanks for the explanation !

The strange thing is that i believe that it only rebooted at home, and that the reboots stopped since i use the 5g wifi.

So it is kind of mysterious.
I think the the wifi at my work is also 2.4Ghz. And my phone did not reboot.
I will travel with ns tomorrow …


Right, now we’re getting somewhere. What kind of AP do you have at home?


I have internet from ziggo. The AP is a ubee EVW321B

My second Fairphone also rebooted way too much. But since I really love the idea of a fair smartphone, I tried to accept it.
Luckily I needed to replace my battery and so I found out that the old battery caused the reboots. Since I inserted the new battery my Fairphone didn’t spontaneously reboot anymore.
I must not forget the reason: the old battery is a fraction of a millimeter shorter than the new one.
Sorry. I did not read the entire thread until now. The problem here has nothing to do with the battery. Good luck with finding the solution(s)!


Interesting, indeed. I ask myself if this tiny little difference is by random or intentionally due to a design change from FP…:thinking:


So if you haven’t changed anything else (apps etc.) it seems to show that the cause of your troubles were probably wifi related.
This brings me back to your headline. This now is your third FP2 but I assume always the same access point and network provider.
Maybe at this point we can agree on the statement that any third party app so far and the battery can be excluded as the root cause of your problem.

You could experience at your work that the phone can operate flawless. It is becoming more obvious there must be something wrong with your home wifi setup, whether hardware wise or configuration wise.
Generally you could look out if there is a more recent firmware available for your ubee EVW321B model.
If it turns out more clearly that your AP causes this problem we can assist you with further advice.
Please keep up your informative responses.


I also have Ziggo plus a uBee modem, though a slightly older model which cannot do both 2.4 GHz and 5 GHz (I couldn’t find it on ubeeinteractive.com though), and AFAICT didn’t have issues with it (I am using it in bridge mode now though). My uBee modem didn’t get updated firmware anymore (so no fix for KRACK, though APs generally don’t need fixes for that).

It could be possible that someone near your house (one of the other APs) has one of those AirPort routers which apparently caused reboots at work for @StevenHachel this was fixed by @chrmhoffmann but in LOS only AFAIK (LineageOS is alternative firmware for FP2).


yes I agree with that.

wifi at other places works without reboots, and at home the 5G wifi works without reboots to it is only the 2,4Ghz wifi which causes reboots on my current fairphone (and probably on the first two aswell)

My family (all with Iphones) do not have this problem .

I think now that it is the combination from my AP and my fairphone using the 2,4Ghz wifi which causes the reboots


So far using the 5Ghz wifi option on my AP is no problem , it works well.

I think my problem is kind of solved :smiley:

1 Like

I would like to thank everyone who helped me with this very annoying problem.
And I am really happy that I can enjoy my fairphone now :smiley:


Very good. This again has shown a very interesting case of unpredictable reboots caused by the wifi setup. As many users here have reboots which they could not clearly track back to a specific cause this should be taken more often into consideration when new cases here come up.

Now you know - it’s the iphones disturbing the 2,4GHz network attacking your helpless FP2…:rofl:
How many are they 3:1 - that’s not fair anyway. But fairness actually is what FP is up to…smiley