FP2 encryption doesn't start without camera modules or with torch turned on


I had been trying to perform a full disk encryption on my FP2 running LineageOS 16 but it didn’t start, so I:

  • turned the torch on -> still not working
  • took front/rear camera modules off -> still not working

Is there any other workaround?

Just to confirm: When you start encryption in the Settings, the phone just reboots and afterwards in the Settings you can start encryption again?

You have set your screen lock to a PIN, password or pattern (not to None or to Swipe)?

Same problem here, LineageOS 16, password configured. Can’t encrypt anyway the phone without camera, torch, so on.


If you want to get radical and if you are prepared to delete everything on the data partition including all your data in the process (the data partition really is the only thing that gets encrypted) you can try to clean the partition from everything that might prevent successful encryption, after this it would at least not be the fault of anything on the data partition …

1 Like

Yes, the phone just reboots and I can start encryption again.
I have set password for the screen lock.

Same suggestion then.

Is it possible to take a data backup and restore it after successful encryption?

Do you mean

  1. Create data backup
  2. Encrypt
  3. Restore data backup

“Is it still possible to do data backups after enabling encryption”?

I think it depends. How do you want to do the backup?

1 Like

I would like to know both.

Ufff, might go through all the hassle if it works, but is it just maybe or for sure that this would work?

Ok, that worked, thanks. Not too much problem backing up with TWRP on the microSD. The media I have it synced so no issues.


1 Like

Hi, I followed AnotherElk’s steps and managed to finish encryption (the LineageOS says the phone is encrypted), but no password is asked when I reboot into TWRP and there are already some errors on the TWRP console after starting it:

Could not mount /data and unable to find crypto footer.
Updating partition details…
Failed to mount ‘/data’ (Invalid argument)
Unable to mount storage
Failed to mount ‘/data’ (Invalid argument)
Full SELinux support is present.
Unable to mount /data/media/TWRP/.twrps
MTP Enabled

Does this mean the phone is not encrypted, or is there another problem occurring here?

The steps I followed:

Your phone is encrypted.
Whether TWRP can decrypt this encryption depends on the OS and the TWRP version.

TWRP 3.3.0-0 and 3.3.1-0 on the Fairphone 2 can not decrypt anything.

TWRP 3.2.3-0 reliably decrypts encryption up to Android 7 (current Fairphone OSes, LineageOS 14.1), but can not decrypt Android 8/9 encryption (LineageOS 15.1/16.0).

There’s a custom TWRP 3.2.3 build here, which attempts to decrypt Android 8/9 encryption, but as of now it doesn’t manage to do it reliably.


I see, is it possible to update LineageOS using built-in update feature in my case?

With encryption in place the only thing that really is encrypted is the data partition.
OS updates don’t affect the data partition, and TWRP doesn’t need access to the data partition for tasks which don’t affect it.

So, theoretically, using the built-in Updater should work just fine.

I never use the built-in Updater, however, so I can’t say how this works out in practice. Just try it.
If it doesn’t work this way for you, you can

  • try a different TWRP version, or
  • download the new OS build to the SD card in the phone (if there is one) and install it with TWRP, or
  • use TWRP’s ADB sideload feature and push the OS build to the phone from a computer via USB using ADB.

Okay, I got it. Thank you so much for your help!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.