FP1: Macadamia 1.9.9-pre3 Alpha (Android Kitkat)

The location icon showing up does not necessarily mean that GPS is on. Maybe it’s just updating the estimated location based on the cell towers it connects to.

This is strange indeed. I’ll look into it.

@Luiz_Eduardo_Pia_de_, do you have a SIM card with data only?[quote=“makkno, post:115, topic:19450”]
I´ve an MTK Logger Report, which i could send to you.

Perfect. Send it my way if it’s not too big or upload it somewhere and send me the link.

@Sjlver and @Kris_S

Noted. Thanks for your detailed feedback. (I won’t look into the OpenGApps issues because there will be a different GApps package).

It is on your computer at the location you run the command from. If you are on Linux and you haven’t switched directory, it’s probably in your home directory. On Windows, it might be in your User directory or maybe at C:\?

When the location icon is lit, the battery report also claims GPS is on, and the battery drain in noticeable (yesterday it was almost scarily vertical). My SIM is a regular one, not data only (the provider is TIM, in Brazil).

You can try sideloading Google Keyboard and enabling installation from untrusted sources, you don’t even need a working keyboard on the phone for that! But that’s probably a GApps issue that the final version won’t have.

1 Like

I don’t know if it is available for Android KitKat (I don’t know how to check it), but can you add the galician language?

Unfortunately not. These are the only languages we have available:

en_GB, en_SG, zh_CN, en_US, en_AU, zh_TW, en_NZ, fr_CA, nl_BE, fr_BE, de_DE, de_CH, fr_CH, it_CH, de_LI, nl_NL, pl_PL, ja_JP, fr_FR, ko_KR, es_ES, de_AT, it_IT, ru_RU, cs_CZ

(and we won’t include all of them, I guess, e.g. no Chinese)

Installed over @chrmhoffmann’s like in post #28. Didn’t need to wipe data.

After two days using, seems to be working almost identically to chrmhoffmann’s, ie. super well!

New glitches:

  • Fairphone updater keeps asking sudo.
  • “Unfortunately, Email has stopped” occasionally pops up. I only use Gmail for email.
  • Battery status not stuck at 14%, but is otherwise glitchy as in FairphoneOS 1.8.5.
  • Maximum charging current has dropped from 0.8A to 0.67A? I have a current meter, and the current used to be steadily around 0.8A, only depending on charger & usb cable. I didn’t think Android handles the inner charging stuff at all. There is a slight chance that this is because I dropped my phone the day before installing, who knows!
  • I liked old Fairphone 1 style boot & charging animations better : )

Glitches common to chrmhoffmann’s:

  • Facebook Messenger: about 1/20 messages are missing the last word, as the text does not fit into its allocated bubble.
  • Snapchat: encodes glitched video. Preview is ok, but sent videos have color plane displacement and band of noise on the side, while saved videos are completely black with band of noise on the side. Instagam, which also re-encodes video, works fine.

Telephony was buggy on chrmhoffmann’s build, and wifi & mobile data sometimes stopped working. Will report any glitches on these. I do suspect that my Fairphone once called to my aunt Tupu on its own.

Good work, thank you :frog:

1 Like

Trying to help someone navigate to the #touchscreentest I just went to testing mode and saw that the english translations to the mandarin characters are missing.


Oh wow, I didn’t know anyone would ever boot into that mode … I’ll see whether there is anything I can do.


I’ll quickly sum up my experience (But nothing I haven’t read already in previous posts):

  • Upgrade from Kola Nut worked fine
  • All the previously installed apps were still there, some worked only after installing SDFix
  • Play Store doesn’t work
  • Can’t get OpenGApps to work, but have only tried via sd-card.
  • BT works fine with my headset, which is BT 4.0

I can confirm the langauge bug. The language is set to spanish, all the apps and menus seems to be in spanish except for the settings that is in english.

The notification LED is not working. At least with missed calls and whatsapp messages, when the battery is less than 15% or is charging the LED is working.

P.S.: Do you prefer to reply in this topic the bugs, or is it better to post a new topic?

I’ll have a look into that one.

For the moment posting in this thread is fine. If we continue lengthy discussions about a particular bug, we might just move some messages to a new thread.

The camera is not working for me. I used OpenGapps and replaced the default app with the Google Camera. I will try and reinstall the default one.

how can i fix this? i have the same problem and cannot update my phone

/edit i tried to do the manual install as explained here: https://fairphone.zendesk.com/hc/en-us/articles/202478028

atfer several ‘problems’ it worked.

1 Like


I just installed the new version and everything went quite well. I like it, it looks great and some things work better on my phone (like GPS, start-up time and of course apps that weren’t compatible with 4.4.2!).

What I’ve noticed so far:

Concerning the apps:

  • Play Store doesn’t launch anymore (as everyone told before!).
  • YouTube launches, but says that it’s not connected to the internet (even if the phone is).
  • Shazam doesn’t launch anymore.
  • three of my apps “disapeared” in the process (QR Droid Private, GPS Fix and TCL Sytral).

For SMS/MMS, I use two apps (the pre-loaded app and Handcent). Now you have to choose the default application and when it’s done, the other doesn’t work anymore! I find it annoying as I’m usually using both of them.

At each startup, I have the following message: “Slot 2: no SIM card detected. Check if the SIM card is ready”. I only have one SIM card so it’s a bit irritating :smiley:

The language is set to French, but some of the text is in English.

When USB is connected, the debug mode is set automatically.

The battery dropped suddenly from 30% to 15% (and then 14%-13%… very quickly).

Finally, details :
I miss the direct tool to choose the Wi-Fi network; now one has to go to Settings / Wireless & Networks / Wi-Fi. I miss the reboot function, too. And I prefered the old loading screen :slight_smile:

That’s it for now! :smiley: Keep on the good work!

1 Like

This is to be expected since you need Google Services for them to work. Try this package:

No clue, why this happens. Did you install them as system apps?

Sorry, there is nothing we can do about this. This is the new behavior of Android. You can still switch back and forth and all messages should appear in both apps.

Noted. I’ll look into it.

This has been reported before. It’s only the Settings app, isn’t it? Did you stumble upon any other non-translated strings?

Yes, I’ve done this for the alpha testing. Thanks for reminding me to remove it before the final release.

Do you have a bugreport for that?

What exactly do you mean here?

This is not a bug but a feature request. I’ll put it on my to-do-list with a low priority.

I really love the new one. I hope you don’t mind it too much :wink:


I confirm the camera works if I install OpenGapps using the Aroma installer but leaving the default Camera and Gallery apps intact. These steps were not necessary with chrmhoffmann’s 4.4.4 ROM.
I also now have a problem with the Google Keyboard and will try to reinstall the GAPPS keeping the default keyboard.
I personally like the ability of the Aroma installer of OpenGapps to ensure I only have one version of the corresponding apps on my /system partition and would very much like to see these inconveniences fixed.

I installed over @chrmhoffmann’s #kitkat without data wipe, but with cache and dalvik cache wipe.

  • I’m having some problems with Roaming*, but they might have been there before. I would have to do a data wipe to find it out and I can’t backup everything right now.
  • GPS shows as turned off, when I turn it off, but when I look into battery stats, it is on the whole time.**
  • I set the the language to German, but everything is in English:

*GsmInboundSMShelper is producing a wakelock until I receive any SMS. I am now sending myself a SMS each time after startup.
**Might also have been there before.

1 Like

@everyone who has problems with Google Apps:
Please try this GApps package: https://s3.eu-central-1.amazonaws.com/gakitkat/gapps-1.9.9.zip

Edit: Fixed typo in link